summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2017-03-11 17:02:24 -0800
committerSchala2017-03-11 17:02:24 -0800
commite401a38c1b948e46b9c38edb46bcc24199b5beef (patch)
treeac7cc8d40565070462d6ff1873e8a4df4c3f3547
parent8bfdb479c2fab3da6d67d9aa2ee58c0020614440 (diff)
downloadaur-e401a38c1b948e46b9c38edb46bcc24199b5beef.tar.gz
1.1.29+41+gdf5330d1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD32
-rw-r--r--libxslt-1.1.28-win32-shared.patch33
4 files changed, 25 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1e50b78dae7..361f83779096 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,25 @@
# Generated by mksrcinfo v8
-# Fri Aug 19 07:23:18 UTC 2016
+# Sun Mar 12 01:01:19 UTC 2017
pkgbase = mingw-w64-libxslt
pkgdesc = XML stylesheet transformation library (mingw-w64)
- pkgver = 1.1.29
- pkgrel = 2
- url = http://xmlsoft.org/XSLT
+ pkgver = 1.1.29+41+gdf5330d1
+ pkgrel = 1
+ url = http://xmlsoft.org/XSLT/
arch = any
license = custom
makedepends = mingw-w64-configure
- depends = mingw-w64-crt
depends = mingw-w64-libxml2
depends = mingw-w64-libgcrypt
options = !strip
options = staticlibs
options = !buildflags
options = !emptydirs
- source = http://xmlsoft.org/sources/libxslt-1.1.29.tar.gz
+ source = git://git.gnome.org/libxslt#commit=df5330d1054bdacf17f4fbd43b528fcf453cc9ec
source = libxslt-1.1.26-w64.patch
- source = libxslt-1.1.28-win32-shared.patch
source = libxslt.m4-libxslt-1.1.26.patch
source = 0003-fix-concurrent-directory-creation.all.patch
- md5sums = a129d3c44c022de3b9dcf6d6f288d72e
+ md5sums = SKIP
md5sums = b994c0d9df0f644e219cf63561ee0d4e
- md5sums = 19646f155b518b40cb63e41270215964
md5sums = 61b520bbd42006c16bbfc85bc5342b96
md5sums = 6da8eb266e6be4f843cf63bd74c6388b
diff --git a/.gitignore b/.gitignore
index 5b06d8419137..9b095975f4a0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+libxslt/
pkg/
src/
*.gz
+*.log
*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 4d76c945f3d0..07dba6fb1a78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,39 @@
pkgname=mingw-w64-libxslt
-pkgver=1.1.29
-pkgrel=2
+pkgver=1.1.29+41+gdf5330d1
+_commit=df5330d1054bdacf17f4fbd43b528fcf453cc9ec
+pkgrel=1
pkgdesc="XML stylesheet transformation library (mingw-w64)"
arch=(any)
-url="http://xmlsoft.org/XSLT"
-license=(custom)
-depends=(mingw-w64-crt mingw-w64-libxml2 mingw-w64-libgcrypt)
+url="http://xmlsoft.org/XSLT/"
+license=("custom")
+depends=(mingw-w64-libxml2 mingw-w64-libgcrypt)
makedepends=(mingw-w64-configure)
options=(!strip staticlibs !buildflags !emptydirs)
-source=("http://xmlsoft.org/sources/libxslt-${pkgver}.tar.gz"
+source=("git://git.gnome.org/libxslt#commit=$_commit"
"libxslt-1.1.26-w64.patch"
-"libxslt-1.1.28-win32-shared.patch"
"libxslt.m4-libxslt-1.1.26.patch"
"0003-fix-concurrent-directory-creation.all.patch")
-md5sums=('a129d3c44c022de3b9dcf6d6f288d72e'
+md5sums=('SKIP'
'b994c0d9df0f644e219cf63561ee0d4e'
- '19646f155b518b40cb63e41270215964'
'61b520bbd42006c16bbfc85bc5342b96'
'6da8eb266e6be4f843cf63bd74c6388b')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd "$srcdir/libxslt"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
prepare() {
- cd libxslt-${pkgver}
+ cd "$srcdir/libxslt"
patch -p1 -i "${srcdir}/libxslt-1.1.26-w64.patch"
- patch -p1 -i "${srcdir}/libxslt-1.1.28-win32-shared.patch"
patch -p1 -i "${srcdir}/libxslt.m4-libxslt-1.1.26.patch"
patch -p1 -i "${srcdir}/0003-fix-concurrent-directory-creation.all.patch"
- autoreconf -fi
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "$srcdir/libxslt-${pkgver}"
+ cd "$srcdir/libxslt"
unset LDFLAGS
for _arch in ${_architectures}; do
mkdir -p "build-${_arch}" && pushd "build-${_arch}"
@@ -44,9 +47,8 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "$srcdir/libxslt-${pkgver}/build-${_arch}"
+ cd "$srcdir/libxslt/build-${_arch}"
make DESTDIR="$pkgdir" install
- #rm -r "$pkgdir"/usr/${_arch}/share
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
diff --git a/libxslt-1.1.28-win32-shared.patch b/libxslt-1.1.28-win32-shared.patch
deleted file mode 100644
index 6534de3c9d60..000000000000
--- a/libxslt-1.1.28-win32-shared.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- libxslt-1.1.27/configure.in.orig 2012-09-17 13:01:19 +0400
-+++ libxslt-1.1.27/configure.in 2012-09-17 13:01:57 +0400
-@@ -3,6 +3,7 @@
- AC_INIT(libxslt/xslt.c)
- AC_CONFIG_HEADERS(config.h)
- AC_CANONICAL_HOST
-+AC_LIBTOOL_WIN32_DLL
- AC_USE_SYSTEM_EXTENSIONS
-
- dnl
---- libxslt-1.1.27/libexslt/Makefile.am.orig 2012-09-17 13:00:51 +0400
-+++ libxslt-1.1.27/libexslt/Makefile.am 2012-09-17 13:01:45 +0400
-@@ -27,7 +27,7 @@
- dynamic.c
-
- libexslt_la_LIBADD = $(top_builddir)/libxslt/libxslt.la $(EXTRA_LIBS) $(LIBGCRYPT_LIBS)
--libexslt_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -version-info $(LIBEXSLT_VERSION_INFO)
-+libexslt_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -version-info $(LIBEXSLT_VERSION_INFO) -no-undefined
-
- man_MANS = libexslt.3
-
---- libxslt-1.1.27/libxslt/Makefile.am.orig 2012-09-17 13:01:08 +0400
-+++ libxslt-1.1.27/libxslt/Makefile.am 2012-09-17 13:01:37 +0400
-@@ -64,7 +64,8 @@
- libxslt_la_LDFLAGS = \
- $(WIN32_EXTRA_LDFLAGS) \
- $(LIBXSLT_VERSION_SCRIPT) \
-- -version-info $(LIBXSLT_VERSION_INFO)
-+ -version-info $(LIBXSLT_VERSION_INFO) \
-+ -no-undefined
-
- man_MANS = libxslt.3
-