summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Powell2015-07-28 11:57:24 -0500
committerCorey Powell2015-07-28 11:57:24 -0500
commit51f5ceccc97b05b441f2596aa3af9db3868d79e6 (patch)
tree2d1d6c12a872f42289071d416b154bc5866c7914
downloadaur-51f5ceccc97b05b441f2596aa3af9db3868d79e6.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c43df17e0cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mingw-w64-libyaml
+ pkgdesc = YAML 1.1 library (mingw-w64)
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = http://pyyaml.org/wiki/LibYAML
+ arch = any
+ license = MIT
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-crt
+ source = http://pyyaml.org/download/libyaml/yaml-0.1.6.tar.gz
+ md5sums = 5fe00cda18ca5daeb43762b80c38e06e
+
+pkgname = mingw-w64-libyaml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..414606a2ba5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Corey Powell (mistdragon100@gmail.com)
+# Swiped from the official libyaml package and modified for mingw-w64
+pkgname=mingw-w64-libyaml
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="YAML 1.1 library (mingw-w64)"
+arch=('any')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-gcc')
+url="http://pyyaml.org/wiki/LibYAML"
+license=('MIT')
+source=(http://pyyaml.org/download/libyaml/yaml-${pkgver}.tar.gz)
+md5sums=('5fe00cda18ca5daeb43762b80c38e06e')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_config="mingw"
+build() {
+ cd "${srcdir}/yaml-${pkgver}"
+ unset LDFLAGS
+ for _arch in ${_architectures}; do
+ cp -R ${srcdir}/yaml-${pkgver} ${srcdir}/yaml-${pkgver}-${_arch}
+ cd ${srcdir}/yaml-${pkgver}-${_arch}
+ #Finally compile
+ ./configure \
+ --prefix=/usr/${_arch} --host=${_arch} \
+ CFLAGS="-DYAML_DECLARE_STATIC" --enable-static --disable-shared
+ make all
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/yaml-${pkgver}-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ #make DESTDIR="${pkgdir}" install
+ install -m644 -D LICENSE "${pkgdir}/usr/${_arch}/share/licenses/${pkgname}/LICENSE"
+ done
+}