summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-09-03 10:19:54 +0200
committerMichel Zou2017-09-03 10:19:54 +0200
commit922288fe5d93324b1c8793959dc8c64cbb317739 (patch)
treea8a8dbf32c0460898c5d562ca42f7b579f883251
parent60ce9f988e460e7c84550f1e7ef59717778b8aae (diff)
downloadaur-922288fe5d93324b1c8793959dc8c64cbb317739.tar.gz
1.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
-rw-r--r--libzip_cmake-fixes.patch73
3 files changed, 54 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 043c88449063..87e2b5ac3bc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon May 1 15:35:26 UTC 2017
+# Sun Sep 3 08:19:54 UTC 2017
pkgbase = mingw-w64-libzip
pkgdesc = A C library for reading, creating, and modifying zip archives (mingw-w64)
- pkgver = 1.2.0
+ pkgver = 1.3.0
pkgrel = 1
url = http://www.nih.at/libzip/index.html
arch = any
@@ -13,10 +13,10 @@ pkgbase = mingw-w64-libzip
options = staticlibs
options = !buildflags
options = !strip
- source = http://www.nih.at/libzip/libzip-1.2.0.tar.xz
+ source = http://www.nih.at/libzip/libzip-1.3.0.tar.xz
source = libzip_cmake-fixes.patch
- md5sums = 2a9b316d16218f1b7562d5a5e0fcbd79
- md5sums = 7d7862d2f5c68066b055c7b3ad0796a3
+ md5sums = bf0342c919bea07ba8197a1691a4d2da
+ md5sums = 46d3be836580abcdcb722d86c4f9a9b0
pkgname = mingw-w64-libzip
diff --git a/PKGBUILD b/PKGBUILD
index d117f01def9f..750ef3d0844b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-libzip
-pkgver=1.2.0
+pkgver=1.3.0
pkgrel=1
pkgdesc="A C library for reading, creating, and modifying zip archives (mingw-w64)"
url="http://www.nih.at/libzip/index.html"
@@ -11,13 +11,14 @@ makedepends=('mingw-w64-cmake')
options=('staticlibs' '!buildflags' '!strip')
source=("http://www.nih.at/libzip/libzip-${pkgver}.tar.xz"
'libzip_cmake-fixes.patch')
-md5sums=('2a9b316d16218f1b7562d5a5e0fcbd79'
- '7d7862d2f5c68066b055c7b3ad0796a3')
+md5sums=('bf0342c919bea07ba8197a1691a4d2da'
+ '46d3be836580abcdcb722d86c4f9a9b0')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "$srcdir/libzip-${pkgver}"
+ # https://github.com/nih-at/libzip/pull/7
patch -p1 -i "$srcdir/libzip_cmake-fixes.patch"
}
diff --git a/libzip_cmake-fixes.patch b/libzip_cmake-fixes.patch
index 0f7d76a102d4..20281307554d 100644
--- a/libzip_cmake-fixes.patch
+++ b/libzip_cmake-fixes.patch
@@ -1,36 +1,53 @@
-diff -rupN libzip-1.0.1/CMakeLists.txt libzip-1.0.1-new/CMakeLists.txt
---- libzip-1.0.1/CMakeLists.txt 2015-05-04 22:49:38.000000000 +0200
-+++ libzip-1.0.1-new/CMakeLists.txt 2015-11-09 21:12:27.926634684 +0100
-@@ -106,3 +106,7 @@ CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DI
- # installation
+From 6444109a12480cc40d6169111ea6491332d754cb Mon Sep 17 00:00:00 2001
+From: Julien Schueller <schueller@phimeca.com>
+Date: Sun, 3 Sep 2017 09:54:27 +0200
+Subject: [PATCH 1/2] [cmake] install pkgconfig file
+
+---
+ CMakeLists.txt | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eea9be1..6644816 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,5 +1,4 @@
+ # TODO:
+-# 1. pkgconfig file not yet built.
+ # 2. installation not tested.
+ # 3. Problems generating html pages.
+ # 4. create usable libtool .la file
+@@ -124,7 +123,14 @@ ADD_SUBDIRECTORY(src)
+ ADD_SUBDIRECTORY(regress)
+ ADD_SUBDIRECTORY(examples)
- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/zipconf.h DESTINATION lib/libzip/include)
-+
+-# TODO: pkgconfig file
++# pkgconfig file
++SET(prefix ${CMAKE_INSTALL_PREFIX})
++SET(exec_prefix ${prefix})
++SET(libdir ${prefix}/lib)
++SET(includedir ${prefix}/lib)
+SET(LIBS -lz)
+CONFIGURE_FILE(libzip.pc.in libzip.pc @ONLY)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/libzip.pc DESTINATION lib/pkgconfig)
-diff -rupN libzip-1.0.1/lib/CMakeLists.txt libzip-1.0.1-new/lib/CMakeLists.txt
---- libzip-1.0.1/lib/CMakeLists.txt 2015-04-29 22:46:14.000000000 +0200
-+++ libzip-1.0.1-new/lib/CMakeLists.txt 2015-11-09 20:53:15.992812515 +0100
-@@ -183,7 +183,13 @@ IF(NOT HAVE_MKSTEMP)
- ENDIF(NOT HAVE_MKSTEMP)
- ADD_LIBRARY(zip SHARED ${LIBZIP_SOURCES} ${LIBZIP_EXTRA_FILES} ${LIBZIP_OPSYS_FILES})
--SET_TARGET_PROPERTIES(zip PROPERTIES VERSION 3.0 SOVERSION 3 )
-+SET(SOVERSION_MAJ 4)
-+SET(SOVERSION_MIN 0)
-+SET_TARGET_PROPERTIES(zip PROPERTIES VERSION ${SOVERSION_MAJ}.${SOVERSION_MIN} SOVERSION ${SOVERSION_MAJ})
-+IF(WIN32)
-+ SET_TARGET_PROPERTIES(zip PROPERTIES SUFFIX "-${SOVERSION_MAJ}${CMAKE_SHARED_LIBRARY_SUFFIX}")
-+ENDIF(WIN32)
-+
- TARGET_LINK_LIBRARIES(zip ${ZLIB_LIBRARY})
- INSTALL(TARGETS zip
- RUNTIME DESTINATION bin
-diff -rupN libzip-1.0.1/man/CMakeLists.txt libzip-1.0.1-new/man/CMakeLists.txt
---- libzip-1.0.1/man/CMakeLists.txt 2015-04-29 17:43:29.000000000 +0200
-+++ libzip-1.0.1-new/man/CMakeLists.txt 2015-11-09 21:14:45.138242668 +0100
-@@ -99,7 +99,7 @@ ENDif(CMAKE_SYSTEM_NAME MATCHES BSD)
+ # write out config file
+ CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/cmake-config.h.in
+
+From fdbe7ce30a5ee31b7e520d5cf1a6b19db7ffd962 Mon Sep 17 00:00:00 2001
+From: Julien Schueller <schueller@phimeca.com>
+Date: Sun, 3 Sep 2017 09:57:06 +0200
+Subject: [PATCH 2/2] [cmake] install man pages in share/man
+
+---
+ man/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
+index 4934f8b..d43c10f 100644
+--- a/man/CMakeLists.txt
++++ b/man/CMakeLists.txt
+@@ -105,7 +105,7 @@ ENDif(CMAKE_SYSTEM_NAME MATCHES BSD)
# installation