summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-04-12 05:47:30 +0100
committerAlexandros Theodotou2019-04-12 05:47:30 +0100
commit9e7ab246ef80890beecd9ec4eae26317e3dbb538 (patch)
tree096eae4e2206406e04fbd1930382f21d43dd10cd
parent347f2f3b97317d2b3b1917966b6497eba2a6eed9 (diff)
downloadaur-mingw-w64-lilv.tar.gz
add patch to disable bench util
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--lilv_nobench.patch26
3 files changed, 29 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f52afdb3020..2874e419b8ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-lilv
pkgdesc = A C library interface to the LV2 plug-in standard
pkgver = 0.24.4
- pkgrel = 4
+ pkgrel = 5
url = https://drobilla.net/software/lilv/
arch = any
license = custom:ISC
diff --git a/PKGBUILD b/PKGBUILD
index 4e26e0f03a5e..d58c5e7dd7f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgbase=lilv
pkgname=mingw-w64-lilv
pkgver=0.24.4
-pkgrel=4
+pkgrel=5
pkgdesc="A C library interface to the LV2 plug-in standard"
arch=('any')
url="https://drobilla.net/software/lilv/"
@@ -29,6 +29,7 @@ prepare() {
sed -i "/ldconfig/d" wscript
patch src/util.c < "${srcdir}/../lilv_symlink.patch"
+ patch wscript < "${srcdir}/../lilv_nobench.patch"
}
build() {
diff --git a/lilv_nobench.patch b/lilv_nobench.patch
new file mode 100644
index 000000000000..66795622abaa
--- /dev/null
+++ b/lilv_nobench.patch
@@ -0,0 +1,26 @@
+diff -crB lilv-0.24.4/wscript lilv-0.24.4_patched/wscript
+*** lilv-0.24.4/wscript 2019-04-12 05:44:40.484443350 +0100
+--- lilv-0.24.4_patched/wscript 2019-04-12 05:45:16.317775629 +0100
+***************
+*** 427,436 ****
+ obj = build_util(bld, 'utils/lv2apply', defines, 'SNDFILE')
+
+ # lv2bench (less portable than other utilities)
+! if bld.is_defined('HAVE_CLOCK_GETTIME') and not bld.env.STATIC_PROGS:
+! obj = build_util(bld, 'utils/lv2bench', defines)
+! if not bld.env.MSVC_COMPILER and not bld.env.DEST_OS == 'darwin':
+! obj.lib = ['rt']
+
+ # Documentation
+ autowaf.build_dox(bld, 'LILV', LILV_VERSION, top, out)
+--- 427,436 ----
+ obj = build_util(bld, 'utils/lv2apply', defines, 'SNDFILE')
+
+ # lv2bench (less portable than other utilities)
+! # if bld.is_defined('HAVE_CLOCK_GETTIME') and not bld.env.STATIC_PROGS:
+! # obj = build_util(bld, 'utils/lv2bench', defines)
+! # if not bld.env.MSVC_COMPILER and not bld.env.DEST_OS == 'darwin':
+! # obj.lib = ['rt']
+
+ # Documentation
+ autowaf.build_dox(bld, 'LILV', LILV_VERSION, top, out)