summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-04-12 05:13:27 +0100
committerAlexandros Theodotou2019-04-12 05:13:27 +0100
commit347f2f3b97317d2b3b1917966b6497eba2a6eed9 (patch)
tree3ce63ca6b6c2581dfd546699b87d2e0f768b5a5e
parent57e56de48e5cc789fbc8f0191df99eda15cd7082 (diff)
downloadaur-347f2f3b97317d2b3b1917966b6497eba2a6eed9.tar.gz
fix patch for symlinks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--create_hard_link.patch18
-rw-r--r--lilv_symlink.patch26
4 files changed, 30 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adf5c08c77dc..3f52afdb3020 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-lilv
pkgdesc = A C library interface to the LV2 plug-in standard
pkgver = 0.24.4
- pkgrel = 3
+ pkgrel = 4
url = https://drobilla.net/software/lilv/
arch = any
license = custom:ISC
diff --git a/PKGBUILD b/PKGBUILD
index 9a598277e439..4e26e0f03a5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgbase=lilv
pkgname=mingw-w64-lilv
pkgver=0.24.4
-pkgrel=3
+pkgrel=4
pkgdesc="A C library interface to the LV2 plug-in standard"
arch=('any')
url="https://drobilla.net/software/lilv/"
@@ -28,7 +28,7 @@ prepare() {
# don't run local ldconfig
sed -i "/ldconfig/d" wscript
- patch --forward --strip=1 --input="${srcdir}/create_hard_link.patch"
+ patch src/util.c < "${srcdir}/../lilv_symlink.patch"
}
build() {
@@ -40,9 +40,9 @@ build() {
pushd build-${_arch}
CC="$_arch-gcc" CXX="$_arch-g++" python waf configure --prefix=/usr/"$_arch" \
- #--bindings \
--no-bash-completion \
--dyn-manifest #\
+ #--bindings \
#--test
python waf build
diff --git a/create_hard_link.patch b/create_hard_link.patch
deleted file mode 100644
index f960a9fdcf9e..000000000000
--- a/create_hard_link.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/src/util.c b/src/util.c
-index 4973181..32900f7 100644
---- a/src/util.c
-+++ b/src/util.c
-@@ -465,10 +465,10 @@ lilv_symlink(const char* oldpath, const char* newpath)
- int ret = 0;
- if (strcmp(oldpath, newpath)) {
- #ifdef _WIN32
-- ret = !CreateSymbolicLink(newpath, oldpath, 0);
-- if (ret) {
-+ /*ret = !CreateSymbolicLink(newpath, oldpath, 0);*/
-+ /*if (ret) {*/
- ret = !CreateHardLink(newpath, oldpath, 0);
-- }
-+ /*}*/
- #else
- ret = symlink(oldpath, newpath);
- #endif
diff --git a/lilv_symlink.patch b/lilv_symlink.patch
new file mode 100644
index 000000000000..0f2531bf8616
--- /dev/null
+++ b/lilv_symlink.patch
@@ -0,0 +1,26 @@
+diff -crB lilv-0.24.4/src/util.c lilv-0.24.4_patched/src/util.c
+*** lilv-0.24.4/src/util.c 2018-07-21 09:10:18.000000000 +0100
+--- lilv-0.24.4_patched/src/util.c 2019-04-12 05:10:21.891170609 +0100
+***************
+*** 465,474 ****
+ int ret = 0;
+ if (strcmp(oldpath, newpath)) {
+ #ifdef _WIN32
+! ret = !CreateSymbolicLink(newpath, oldpath, 0);
+! if (ret) {
+ ret = !CreateHardLink(newpath, oldpath, 0);
+! }
+ #else
+ ret = symlink(oldpath, newpath);
+ #endif
+--- 465,474 ----
+ int ret = 0;
+ if (strcmp(oldpath, newpath)) {
+ #ifdef _WIN32
+! /*ret = !CreateSymbolicLink(newpath, oldpath, 0);*/
+! /*if (ret) {*/
+ ret = !CreateHardLink(newpath, oldpath, 0);
+! /*}*/
+ #else
+ ret = symlink(oldpath, newpath);
+ #endif