summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-04-12 01:26:40 +0100
committerAlexandros Theodotou2019-04-12 01:46:33 +0100
commitc3724e46e3a775ea9fae9b2385fc7b0c466df00b (patch)
treed4bb8f0b733284c68913cb98f648fe184550fdfd
downloadaur-c3724e46e3a775ea9fae9b2385fc7b0c466df00b.tar.gz
test
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD60
-rw-r--r--lilvmm.patch40
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b90b743ec63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-lilv
+ pkgdesc = A C library interface to the LV2 plug-in standard
+ pkgver = 0.24.4
+ pkgrel = 1
+ url = https://drobilla.net/software/lilv/
+ arch = any
+ license = custom:ISC
+ makedepends = mingw-w64-python
+ depends = mingw-w64-sratom
+ optdepends = bash-completion: completion for bash
+ optdepends = mingw-w64-libsndfile: for lv2apply
+ source = https://download.drobilla.net/mingw-w64-lilv-0.24.4.tar.bz2
+ source = https://download.drobilla.net/mingw-w64-lilv-0.24.4.tar.bz2.sig
+ validpgpkeys = 907D226E7E13FA337F014A083672782A9BF368F3
+ sha512sums = cb909c83dbac36b51a206fe508aec51e52ddf068f9a159d053888594402def8d140aae0d9e1e1866e722396f7ec8dea4b86d4c1b958f56eb3193b78307918a89
+ sha512sums = SKIP
+
+pkgname = mingw-w64-lilv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66b8010560cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Alexandros Theodotou <alex@zrythm.org>
+# `lilv` Maintainer: David Runge <dave@sleepmap.de>
+# Contributor: Ray Rashif <schiv@archlinux.org>
+# Contributor: speps <speps at aur dot archlinux dot org>
+
+pkgname=mingw-w64-lilv
+pkgver=0.24.4
+pkgrel=1
+pkgdesc="A C library interface to the LV2 plug-in standard"
+arch=('any')
+url="https://drobilla.net/software/lilv/"
+license=('custom:ISC')
+depends=('mingw-w64-sratom')
+makedepends=('mingw-w64-python')
+optdepends=('bash-completion: completion for bash'
+ 'mingw-w64-libsndfile: for lv2apply')
+source=("https://download.drobilla.net/${pkgname}-${pkgver}.tar.bz2"{,.sig})
+sha512sums=('cb909c83dbac36b51a206fe508aec51e52ddf068f9a159d053888594402def8d140aae0d9e1e1866e722396f7ec8dea4b86d4c1b958f56eb3193b78307918a89'
+ 'SKIP')
+validpgpkeys=('907D226E7E13FA337F014A083672782A9BF368F3')
+
+_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ # don't run local ldconfig
+ sed -i "/ldconfig/d" wscript
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ for _arch in "${_architectures[@]}"; do
+ python waf configure --prefix=/usr/"$_arch" \
+ --bindings \
+ --no-bash-completion \
+ --dyn-manifest \
+ --test
+ python waf build
+ done
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+
+ python waf test
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python waf install --destdir="${pkgdir}"
+ # license
+ install -vDm 644 COPYING \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # bash completion
+ install -vDm 644 utils/lilv.bash_completion\
+ "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/lilvmm.patch b/lilvmm.patch
new file mode 100644
index 000000000000..c60f87db30bd
--- /dev/null
+++ b/lilvmm.patch
@@ -0,0 +1,40 @@
+Index: trunk/lilv/lilv/lilvmm.hpp
+===================================================================
+--- trunk/lilv/lilv/lilvmm.hpp (revision 4975)
++++ trunk/lilv/lilv/lilvmm.hpp (revision 5092)
+@@ -48,4 +48,9 @@
+ inline RT name(T1 a1, T2 a2) { \
+ return lilv_ ## prefix ## _ ## name(me, a1, a2); \
++ }
++
++#define LILV_WRAP3(RT, prefix, name, T1, a1, T2, a2, T3, a3) \
++ inline RT name(T1 a1, T2 a2, T3 a3) { \
++ return lilv_ ## prefix ## _ ## name(me, a1, a2, a3); \
+ }
+
+@@ -138,4 +143,25 @@
+ LILV_WRAP1(bool, nodes, contains, const Node, node);
+ LILV_WRAP0(Node, nodes, get_first);
++};
++
++struct UI {
++ inline UI(const LilvUI* c_obj) : me(c_obj) {}
++ LILV_WRAP_CONVERSION(const LilvUI);
++
++ LILV_WRAP0(const LilvNode*, ui, get_uri);
++ LILV_WRAP0(const LilvNode*, ui, get_bundle_uri);
++ LILV_WRAP0(const LilvNode*, ui, get_binary_uri);
++ LILV_WRAP0(const LilvNodes*, ui, get_classes);
++ /*LILV_WRAP3(bool, ui, is_supported,
++ LilvUISupportedFunc, supported_func,
++ const LilvNode*, container_type,
++ const LilvNode**, ui_type);*/
++ LILV_WRAP1(bool, ui, is_a, const LilvNode*, class_uri);
++
++ const LilvUI* me;
++};
++
++struct UIs {
++ LILV_WRAP_COLL(UIs, UI, uis);
+ };
+