summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-04-12 04:21:17 +0100
committerAlexandros Theodotou2019-04-12 04:21:17 +0100
commitd69f78fe5a61e7f5588077a1acfc8988870a6c68 (patch)
treef9a10e8f47b288defe718f473967e4862a40a57b
parentc3724e46e3a775ea9fae9b2385fc7b0c466df00b (diff)
downloadaur-d69f78fe5a61e7f5588077a1acfc8988870a6c68.tar.gz
try again
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD58
2 files changed, 48 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b90b743ec63..9ed55e465475 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-lilv
pkgdesc = A C library interface to the LV2 plug-in standard
pkgver = 0.24.4
- pkgrel = 1
+ pkgrel = 2
url = https://drobilla.net/software/lilv/
arch = any
license = custom:ISC
@@ -9,8 +9,12 @@ pkgbase = mingw-w64-lilv
depends = mingw-w64-sratom
optdepends = bash-completion: completion for bash
optdepends = mingw-w64-libsndfile: for lv2apply
- source = https://download.drobilla.net/mingw-w64-lilv-0.24.4.tar.bz2
- source = https://download.drobilla.net/mingw-w64-lilv-0.24.4.tar.bz2.sig
+ options = !libtool
+ options = !strip
+ options = !buildflags
+ options = !makeflags
+ source = https://download.drobilla.net/lilv-0.24.4.tar.bz2
+ source = https://download.drobilla.net/lilv-0.24.4.tar.bz2.sig
validpgpkeys = 907D226E7E13FA337F014A083672782A9BF368F3
sha512sums = cb909c83dbac36b51a206fe508aec51e52ddf068f9a159d053888594402def8d140aae0d9e1e1866e722396f7ec8dea4b86d4c1b958f56eb3193b78307918a89
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 66b8010560cb..4549982cb9b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,10 @@
# Contributor: Ray Rashif <schiv@archlinux.org>
# Contributor: speps <speps at aur dot archlinux dot org>
+_pkgbase=lilv
pkgname=mingw-w64-lilv
pkgver=0.24.4
-pkgrel=1
+pkgrel=2
pkgdesc="A C library interface to the LV2 plug-in standard"
arch=('any')
url="https://drobilla.net/software/lilv/"
@@ -14,7 +15,8 @@ depends=('mingw-w64-sratom')
makedepends=('mingw-w64-python')
optdepends=('bash-completion: completion for bash'
'mingw-w64-libsndfile: for lv2apply')
-source=("https://download.drobilla.net/${pkgname}-${pkgver}.tar.bz2"{,.sig})
+options=('!libtool' '!strip' '!buildflags' '!makeflags')
+source=("https://download.drobilla.net/${_pkgbase}-${pkgver}.tar.bz2"{,.sig})
sha512sums=('cb909c83dbac36b51a206fe508aec51e52ddf068f9a159d053888594402def8d140aae0d9e1e1866e722396f7ec8dea4b86d4c1b958f56eb3193b78307918a89'
'SKIP')
validpgpkeys=('907D226E7E13FA337F014A083672782A9BF368F3')
@@ -22,39 +24,61 @@ validpgpkeys=('907D226E7E13FA337F014A083672782A9BF368F3')
_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "${_pkgbase}-${pkgver}"
# don't run local ldconfig
sed -i "/ldconfig/d" wscript
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${srcdir}"
for _arch in "${_architectures[@]}"; do
- python waf configure --prefix=/usr/"$_arch" \
+ rm -rf build-${_arch}
+ cp -r "${_pkgbase}-${pkgver}" build-${_arch}
+ pushd build-${_arch}
+
+ CC="$_arch-gcc" python waf configure --prefix=/usr/"$_arch" \
--bindings \
--no-bash-completion \
- --dyn-manifest \
- --test
+ --dyn-manifest #\
+ #--test
python waf build
+
+ popd
done
}
check() {
- cd "${pkgname}-${pkgver}"
+ cd "${_pkgbase}-${pkgver}"
- python waf test
+ #python waf test
}
package() {
- cd "${pkgname}-${pkgver}"
- python waf install --destdir="${pkgdir}"
- # license
- install -vDm 644 COPYING \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # bash completion
- install -vDm 644 utils/lilv.bash_completion\
- "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+ cd "${srcdir}"
+
+ for _arch in "${_architectures[@]}"; do
+ pushd "build-${_arch}"
+
+ python waf install --destdir="${pkgdir}"
+
+ # license
+ install -vDm 644 COPYING \
+ "${pkgdir}/usr/$_arch/share/licenses/${_pkgbase}/LICENSE"
+ # bash completion
+ install -vDm 644 utils/lilv.bash_completion\
+ "${pkgdir}/usr/$_arch/share/bash-completion/completions/${_pkgbase}"
+
+ # move DLL to bin directory
+ install -d $pkgdir/usr/${_arch}/bin
+ mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin
+
+ # strip
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+
+ popd
+ done
}
# vim:set ts=2 sw=2 et: