summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2023-08-29 22:03:27 +0200
committerMichel Zou2023-08-29 22:03:27 +0200
commit5b8794f360016b2ce9a0f2cfdfd65556a69c0b51 (patch)
tree80bceb0f122c7d62d2d76ca449cffa41ce8da10f
parentf0f3cf64687f67369520e72db029fdb0a52369b2 (diff)
downloadaur-5b8794f360016b2ce9a0f2cfdfd65556a69c0b51.tar.gz
16.0.6
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 454cf9810ced..8d7b5cdc7104 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = mingw-w64-llvm
pkgdesc = Collection of modular and reusable compiler and toolchain technologies (mingw-w64)
- pkgver = 15.0.7
+ pkgver = 16.0.6
pkgrel = 1
url = http://llvm.org/
arch = any
license = custom:Apache 2.0 with LLVM Exception
makedepends = mingw-w64-cmake
- makedepends = llvm>=15
+ makedepends = llvm>=16
makedepends = python
depends = mingw-w64-zlib
depends = mingw-w64-z3
@@ -16,15 +16,15 @@ pkgbase = mingw-w64-llvm
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/llvm/llvm-project/releases/download/llvmorg-15.0.7/llvm-15.0.7.src.tar.xz
- source = https://github.com/llvm/llvm-project/releases/download/llvmorg-15.0.7/llvm-15.0.7.src.tar.xz.sig
- source = https://github.com/llvm/llvm-project/releases/download/llvmorg-15.0.7/cmake-15.0.7.src.tar.xz
- source = https://github.com/llvm/llvm-project/releases/download/llvmorg-15.0.7/cmake-15.0.7.src.tar.xz.sig
+ source = https://github.com/llvm/llvm-project/releases/download/llvmorg-16.0.6/llvm-16.0.6.src.tar.xz
+ source = https://github.com/llvm/llvm-project/releases/download/llvmorg-16.0.6/llvm-16.0.6.src.tar.xz.sig
+ source = https://github.com/llvm/llvm-project/releases/download/llvmorg-16.0.6/cmake-16.0.6.src.tar.xz
+ source = https://github.com/llvm/llvm-project/releases/download/llvmorg-16.0.6/cmake-16.0.6.src.tar.xz.sig
validpgpkeys = 474E22316ABF4785A88C6E8EA2C794A986419D8A
validpgpkeys = D574BD5D1D0E98895E3BF90044F2485E45D59042
- sha256sums = 4ad8b2cc8003c86d0078d15d987d84e3a739f24aae9033865c027abae93ee7a4
+ sha256sums = e91db44d1b3bb1c33fcea9a7d1f2423b883eaa9163d3d56ca2aa6d2f0711bc29
sha256sums = SKIP
- sha256sums = 8986f29b634fdaa9862eedda78513969fe9788301c9f2d938f4c10a3e7a3e7ea
+ sha256sums = 39d342a4161095d2f28fb1253e4585978ac50521117da666e2b1f6f28b62f514
sha256sums = SKIP
pkgname = mingw-w64-llvm
diff --git a/PKGBUILD b/PKGBUILD
index 1700598f7795..b5d81b3fcfb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=('mingw-w64-llvm')
-pkgver=15.0.7
+pkgver=16.0.6
pkgrel=1
pkgdesc="Collection of modular and reusable compiler and toolchain technologies (mingw-w64)"
arch=('any')
@@ -11,9 +11,9 @@ options=('!strip' '!buildflags' 'staticlibs')
_source_base=https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver
source=($_source_base/llvm-$pkgver.src.tar.xz{,.sig}
$_source_base/cmake-$pkgver.src.tar.xz{,.sig})
-sha256sums=('4ad8b2cc8003c86d0078d15d987d84e3a739f24aae9033865c027abae93ee7a4'
+sha256sums=('e91db44d1b3bb1c33fcea9a7d1f2423b883eaa9163d3d56ca2aa6d2f0711bc29'
'SKIP'
- '8986f29b634fdaa9862eedda78513969fe9788301c9f2d938f4c10a3e7a3e7ea'
+ '39d342a4161095d2f28fb1253e4585978ac50521117da666e2b1f6f28b62f514'
'SKIP')
validpgpkeys=('474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
'D574BD5D1D0E98895E3BF90044F2485E45D59042') # Tobias Hieta <tobias@hieta.se>
@@ -21,7 +21,7 @@ validpgpkeys=('474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstell
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- mv cmake{-$pkgver.src,}
+ rename -v -- "-$pkgver.src" '' cmake-$pkgver.src
cd "$srcdir/llvm-$pkgver.src/"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
@@ -37,7 +37,7 @@ build() {
-DLLVM_ENABLE_RTTI=ON \
-DLLVM_INCLUDE_BENCHMARKS=OFF \
-DLLVM_ENABLE_ASSERTIONS=OFF \
- -DLLVM_TARGETS_TO_BUILD="X86;AMDGPU" \
+ -DLLVM_TARGETS_TO_BUILD="X86" \
-DLLVM_DEFAULT_TARGET_TRIPLE="${_arch}" \
-DLLVM_TARGET_ARCH="X86" \
-DLLVM_TABLEGEN=/usr/bin/llvm-tblgen \