summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2017-03-06 08:47:24 -0800
committerSchala2017-03-06 08:47:24 -0800
commit6285d81dd21d4e7c8e38210b735c160b7d48378e (patch)
treea5253d8a708dd216355b9e8e519e5eeb3bdb180a
parent08dbc7f28f4e1aec5f6197d091f3a8960f15551f (diff)
downloadaur-6285d81dd21d4e7c8e38210b735c160b7d48378e.tar.gz
2.10
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 286ff415fade..9bb4a6f66b31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Aug 19 07:28:51 UTC 2016
+# Mon Mar 6 16:47:10 UTC 2017
pkgbase = mingw-w64-lzo
pkgdesc = Portable lossless data compression library (mingw-w64)
- pkgver = 2.09
- pkgrel = 2
- url = http://www.oberhumer.com/opensource/lzo/
+ pkgver = 2.10
+ pkgrel = 1
+ url = http://www.oberhumer.com/opensource/lzo
arch = any
license = GPL
makedepends = mingw-w64-configure
@@ -12,8 +12,8 @@ pkgbase = mingw-w64-lzo
options = staticlibs
options = !strip
options = !buildflags
- source = http://www.oberhumer.com/opensource/lzo/download/lzo-2.09.tar.gz
- md5sums = c7ffc9a103afe2d1bba0b015e7aa887f
+ source = http://www.oberhumer.com/opensource/lzo/download/lzo-2.10.tar.gz
+ sha1sums = 4924676a9bae5db58ef129dc1cebce3baa3c4b5d
pkgname = mingw-w64-lzo
diff --git a/.gitignore b/.gitignore
index 5b06d8419137..49c4674d6625 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
pkg/
src/
*.gz
+*.log
*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index f6887cbe3d72..bcc59abee219 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
pkgname=mingw-w64-lzo
-pkgver=2.09
-pkgrel=2
+pkgver=2.10
+pkgrel=1
pkgdesc="Portable lossless data compression library (mingw-w64)"
arch=(any)
-url="http://www.oberhumer.com/opensource/lzo/"
+url="http://www.oberhumer.com/opensource/lzo"
license=("GPL")
makedepends=(mingw-w64-configure)
depends=(mingw-w64-crt)
options=(staticlibs !strip !buildflags)
source=("http://www.oberhumer.com/opensource/lzo/download/lzo-${pkgver}.tar.gz")
-md5sums=('c7ffc9a103afe2d1bba0b015e7aa887f')
+sha1sums=('4924676a9bae5db58ef129dc1cebce3baa3c4b5d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -20,6 +20,9 @@ build() {
${_arch}-configure \
--target=${_arch}
make
+ ${_arch}-gcc $CFLAGS -fpic -I../include/lzo -o minilzo/minilzo.o -c ../minilzo/minilzo.c
+ ${_arch}-ar rcs libminilzo.a minilzo/minilzo.o
+ ${_arch}-gcc -shared -o libminilzo-0.dll -Wl,--out-implib,libminilzo.dll.a minilzo/minilzo.o
popd
done
}
@@ -28,7 +31,10 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/lzo-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
- #rm -r "$pkgdir/usr/${_arch}/share"
+ install -m644 libminilzo-0.dll "$pkgdir/usr/${_arch}/bin"
+ install -m644 libminilzo.dll.a "$pkgdir/usr/${_arch}/lib"
+ install -m644 libminilzo.a "$pkgdir/usr/${_arch}/lib"
+ install -p -m644 ../minilzo/minilzo.h "$pkgdir/usr/${_arch}/include/lzo"
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done