summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2015-10-10 16:05:13 -0700
committerBuildTools2015-10-10 16:05:13 -0700
commit9a1df9be890befca888914687ace15f7e735aabe (patch)
tree7eb28246576e9ddc9e4162c049052ea5b4f3d74a
downloadaur-9a1df9be890befca888914687ace15f7e735aabe.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02fea1c4537a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-lzo
+ pkgdesc = Portable lossless data compression library (mingw-w64)
+ pkgver = 2.09
+ pkgrel = 1
+ url = http://www.oberhumer.com/opensource/lzo/
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://www.oberhumer.com/opensource/lzo/download/lzo-2.09.tar.gz
+ md5sums = c7ffc9a103afe2d1bba0b015e7aa887f
+
+pkgname = mingw-w64-lzo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..25cca9a92b37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..745e8cf0bcee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=mingw-w64-lzo
+pkgver=2.09
+pkgrel=1
+pkgdesc="Portable lossless data compression library (mingw-w64)"
+arch=(any)
+url="http://www.oberhumer.com/opensource/lzo/"
+license=("GPL")
+makedepends=(mingw-w64-configure)
+depends=(mingw-w64-crt)
+options=(staticlibs !strip !buildflags)
+source=("http://www.oberhumer.com/opensource/lzo/download/lzo-${pkgver}.tar.gz")
+md5sums=('c7ffc9a103afe2d1bba0b015e7aa887f')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/lzo-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --target=${_arch}
+ make
+ #${_arch}-gcc -shared src/*.o -o src/liblzo2-0.dll -Xlinker --out-implib -Xlinker src/liblzo2.dll.a
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/lzo-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ #install -Dm644 src/liblzo2-0.dll "${pkgdir}"/usr/${_arch}/bin/liblzo2-0.dll
+ #install -m644 src/liblzo2.dll.a "${pkgdir}"/usr/${_arch}/lib/liblzo2.dll.a
+ rm -r "$pkgdir/usr/${_arch}/share"
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ done
+}