summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-09-25 10:00:45 +0200
committerMichel Zou2022-09-25 10:00:45 +0200
commita7ee24d5ac6feca39fa6781520411cf31d5236dd (patch)
treefc68e6aafc35f33c5a1e0dc19bf22c57c70245a2
parentfa6da073d424774b4229c8154870cf411e01d5c4 (diff)
downloadaur-a7ee24d5ac6feca39fa6781520411cf31d5236dd.tar.gz
4.1.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b1edb4c9c9f..14e45ad532ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-med
pkgdesc = Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5
- pkgver = 4.1.0
+ pkgver = 4.1.1
pkgrel = 1
url = https://www.salome-platform.org/downloads
arch = any
@@ -10,8 +10,7 @@ pkgbase = mingw-w64-med
options = !buildflags
options = !strip
options = staticlibs
- source = https://files.salome-platform.org/Salome/other/med-4.1.0.tar.gz
- sha256sums = 847db5d6fbc9ce6924cb4aea86362812c9a5ef6b9684377e4dd6879627651fce
+ source = https://files.salome-platform.org/Salome/other/med-4.1.1.tar.gz
+ sha256sums = dc2b5d54ebf0666e3ff2e974041d2ab0da906061323537023ab165d573389dd0
pkgname = mingw-w64-med
-
diff --git a/PKGBUILD b/PKGBUILD
index 9b3c3bff9abe..b2058e46ea4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-med
-pkgver=4.1.0
+pkgver=4.1.1
pkgrel=1
pkgdesc='Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5'
arch=('any')
@@ -9,19 +9,18 @@ depends=('mingw-w64-hdf5')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
source=("https://files.salome-platform.org/Salome/other/med-${pkgver}.tar.gz")
-sha256sums=('847db5d6fbc9ce6924cb4aea86362812c9a5ef6b9684377e4dd6879627651fce')
+sha256sums=('dc2b5d54ebf0666e3ff2e974041d2ab0da906061323537023ab165d573389dd0')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/med-${pkgver}"
- curl -L https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch | patch -p1
- sed -i 's/if H5_VERS_MINOR > 10/if 0/g' src/ci/MEDfileCompatibility.c
+ cd "${srcdir}/med-${pkgver}_SRC"
+ curl -L https://raw.githubusercontent.com/archlinux/svntogit-community/packages/med/trunk/hdf5-1.12.patch | patch -p1
sed -i "s|Lmcons.h|lmcons.h|g" src/2.3.6/ci/MEDunvCr.c src/ci/MEDmeshUniversalNameWr.c
}
build() {
- cd "${srcdir}/med-${pkgver}"
+ cd "${srcdir}/med-${pkgver}_SRC"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
CPPFLAGS="-DH5_USE_110_API" ${_arch}-cmake -DMEDFILE_BUILD_TESTS=OFF -DMEDFILE_INSTALL_DOC=OFF ..
@@ -32,7 +31,7 @@ build() {
package() {
for _arch in $_architectures; do
- cd "$srcdir"/med-${pkgver}/build-${_arch}
+ cd "$srcdir"/med-${pkgver}_SRC/build-${_arch}
make install DESTDIR="$pkgdir"
rm "$pkgdir"/usr/${_arch}/bin/*.exe
mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin