summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-09-25 22:14:25 +0200
committerMichel Zou2019-09-25 22:14:25 +0200
commit9c2e6d38e8a4c536be8a0a2bf16cbedb9ea46c05 (patch)
treeea05f266bb925554f50d7a421a3d844e30b975d5
parent824a2b35cc0e75128b40bfb641db873099068911 (diff)
downloadaur-9c2e6d38e8a4c536be8a0a2bf16cbedb9ea46c05.tar.gz
19.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--mingw-posix.patch13
-rw-r--r--py3k.patch75
4 files changed, 88 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfe41916100a..d415baab988c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = mingw-w64-mesa
pkgdesc = An open-source implementation of the OpenGL specification (mingw-w64)
- pkgver = 19.1.0
+ pkgver = 19.2.0
pkgrel = 1
url = https://www.mesa3d.org/
arch = any
license = custom
makedepends = mingw-w64-gcc
makedepends = scons
- makedepends = python2-mako
+ makedepends = python-mako
depends = mingw-w64-dlfcn
depends = mingw-w64-llvm
options = staticlibs
options = !strip
options = !buildflags
- source = https://mesa.freedesktop.org/archive/mesa-19.1.0.tar.xz
- source = https://mesa.freedesktop.org/archive/mesa-19.1.0.tar.xz.sig
- source = mingw-posix.patch
+ source = https://mesa.freedesktop.org/archive/mesa-19.2.0.tar.xz
+ source = https://mesa.freedesktop.org/archive/mesa-19.2.0.tar.xz.sig
+ source = py3k.patch
validpgpkeys = 71C4B75620BC75708B4BDB254C95FAAB3EB073EC
validpgpkeys = A5CC9FEC93F2F837CB044912336909B6B25FADFA
- sha256sums = 2a6c3af3a803389183168e449c536304cf03e0f82c4c9333077933543b9d02f3
+ sha256sums = b060caa2a00f856431160ff7377d0e8f58f2aa48c16ee5a9e265ebdccb10852a
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1ceb70ede414..46060bb9e1d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
pkgname=mingw-w64-mesa
-pkgver=19.1.0
+pkgver=19.2.0
pkgrel=1
pkgdesc="An open-source implementation of the OpenGL specification (mingw-w64)"
arch=('any')
url="https://www.mesa3d.org/"
license=("custom")
-makedepends=('mingw-w64-gcc' 'scons' 'python2-mako')
+makedepends=('mingw-w64-gcc' 'scons' 'python-mako')
depends=('mingw-w64-dlfcn' 'mingw-w64-llvm')
options=('staticlibs' '!strip' '!buildflags')
validpgpkeys=(71C4B75620BC75708B4BDB254C95FAAB3EB073EC # Dylan Baker <dylan@pnwbakers.com>
A5CC9FEC93F2F837CB044912336909B6B25FADFA) # Juan A. Suarez Romero <jasuarez@igalia.com>
-source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig} mingw-posix.patch)
-sha256sums=('2a6c3af3a803389183168e449c536304cf03e0f82c4c9333077933543b9d02f3' SKIP SKIP)
+source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig} py3k.patch)
+sha256sums=('b060caa2a00f856431160ff7377d0e8f58f2aa48c16ee5a9e265ebdccb10852a' SKIP SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd "${srcdir}"/mesa-${pkgver}
- # https://gitlab.freedesktop.org/mesa/mesa/merge_requests/784
- patch -p1 -i "${srcdir}"/mingw-posix.patch
+
+ # https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2127
+ patch -p1 -i "${srcdir}"/py3k.patch
# libLLVMSupport.a: undefined reference to `compressBound' (only with static llvm)
sed -i "s|'LLVMSupport',|'LLVMSupport', 'z',|g" scons/llvm.py
diff --git a/mingw-posix.patch b/mingw-posix.patch
deleted file mode 100644
index 9846e8708c03..000000000000
--- a/mingw-posix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/scons/llvm.py b/scons/llvm.py
-index a84ad51d97a..7ebcaf1c58c 100644
---- a/scons/llvm.py
-+++ b/scons/llvm.py
-@@ -123,7 +123,7 @@ def generate(env):
- if env['platform'] == 'windows' and env['crosscompile']:
- # LLVM 5.0 requires MinGW w/ pthreads due to use of std::thread and friends.
- assert env['gcc']
-- env['CXX'] = env['CXX'] + '-posix'
-+ env.AppendUnique(CXXFLAGS = ['-posix'])
- elif llvm_version >= distutils.version.LooseVersion('4.0'):
- env.Prepend(LIBS = [
- 'LLVMX86Disassembler', 'LLVMX86AsmParser',
diff --git a/py3k.patch b/py3k.patch
new file mode 100644
index 000000000000..c7ad30a18b43
--- /dev/null
+++ b/py3k.patch
@@ -0,0 +1,75 @@
+diff --git a/scons/crossmingw.py b/scons/crossmingw.py
+index 609cd00418e..b2efccea7e8 100644
+--- a/scons/crossmingw.py
++++ b/scons/crossmingw.py
+@@ -128,9 +128,9 @@ def generate(env):
+ if not path:
+ path = []
+ if SCons.Util.is_String(path):
+- path = string.split(path, os.pathsep)
++ path = str.split(path, os.pathsep)
+
+- env['ENV']['PATH'] = string.join([dir] + path, os.pathsep)
++ env['ENV']['PATH'] = str.join(os.pathsep, [dir] + path)
+
+ # Most of mingw is the same as gcc and friends...
+ gnu_tools = ['gcc', 'g++', 'gnulink', 'ar', 'gas']
+diff --git a/scons/custom.py b/scons/custom.py
+index 8028990ef61..d2576ae9ddb 100644
+--- a/scons/custom.py
++++ b/scons/custom.py
+@@ -262,8 +262,13 @@ def parse_source_list(env, filename, names=None):
+ sym_table = parser.parse(src.abspath)
+
+ if names:
+- if isinstance(names, basestring):
+- names = [names]
++ import sys
++ if sys.version_info[0] >= 3:
++ if isinstance(names, str):
++ names = [names]
++ else:
++ if isinstance(names, basestring):
++ names = [names]
+
+ symbols = names
+ else:
+diff --git a/scons/gallium.py b/scons/gallium.py
+index 72d8604169e..9381f804a31 100755
+--- a/scons/gallium.py
++++ b/scons/gallium.py
+@@ -132,7 +132,7 @@ def check_cc(env, cc, expr, cpp_opt = '-E'):
+ sys.stdout.write('Checking for %s ... ' % cc)
+
+ source = tempfile.NamedTemporaryFile(suffix='.c', delete=False)
+- source.write('#if !(%s)\n#error\n#endif\n' % expr)
++ source.write(('#if !(%s)\n#error\n#endif\n' % expr).encode())
+ source.close()
+
+ # sys.stderr.write('%r %s %s\n' % (env['CC'], cpp_opt, source.name));
+diff --git a/src/freedreno/vulkan/tu_extensions.py b/src/freedreno/vulkan/tu_extensions.py
+index 0a45b859e2b..dbb3a72d71e 100644
+--- a/src/freedreno/vulkan/tu_extensions.py
++++ b/src/freedreno/vulkan/tu_extensions.py
+@@ -79,7 +79,7 @@ EXTENSIONS = [
+
+ class VkVersion:
+ def __init__(self, string):
+- split = string.split('.')
++ split = str.split('.')
+ self.major = int(split[0])
+ self.minor = int(split[1])
+ if len(split) > 2:
+diff --git a/src/intel/vulkan/anv_extensions.py b/src/intel/vulkan/anv_extensions.py
+index dad49a1e564..60f97dd3e08 100644
+--- a/src/intel/vulkan/anv_extensions.py
++++ b/src/intel/vulkan/anv_extensions.py
+@@ -186,7 +186,7 @@ for i in range(len(EXTENSIONS) - 1):
+
+ class VkVersion:
+ def __init__(self, string):
+- split = string.split('.')
++ split = str.split('.')
+ self.major = int(split[0])
+ self.minor = int(split[1])
+ if len(split) > 2: