summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-02-21 19:19:54 +0100
committerMichel Zou2020-02-21 19:19:54 +0100
commitbdf6e5abc8b117c34c3bf1f36f6dd7b0275a6d8e (patch)
tree75031f5e48ef93ed1c8389dfe05f965b9198b0b7
parent896b0b1f4e80e9e034cd32038a3cfff59e21a6be (diff)
downloadaur-bdf6e5abc8b117c34c3bf1f36f6dd7b0275a6d8e.tar.gz
20.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 11 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04c884deea51..2c3a45f7f80f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = mingw-w64-mesa
pkgdesc = An open-source implementation of the OpenGL specification (mingw-w64)
- pkgver = 19.3.0
+ pkgver = 20.0.0
pkgrel = 1
url = https://www.mesa3d.org/
arch = any
license = custom
- makedepends = mingw-w64-gcc
- makedepends = scons
+ makedepends = mingw-w64-meson
makedepends = python-mako
depends = mingw-w64-dlfcn
depends = mingw-w64-llvm
options = staticlibs
options = !strip
options = !buildflags
- source = https://mesa.freedesktop.org/archive/mesa-19.3.0.tar.xz
- source = https://mesa.freedesktop.org/archive/mesa-19.3.0.tar.xz.sig
+ source = https://mesa.freedesktop.org/archive/mesa-20.0.0.tar.xz
+ source = https://mesa.freedesktop.org/archive/mesa-20.0.0.tar.xz.sig
validpgpkeys = 71C4B75620BC75708B4BDB254C95FAAB3EB073EC
validpgpkeys = A5CC9FEC93F2F837CB044912336909B6B25FADFA
- sha256sums = 5fa0e4e9dca79560f6882e362f9db36d81cf96da16cf6a84e0ada7466a99a5d7
+ sha256sums = bb6db3e54b608d2536d4000b3de7dd3ae115fc114e8acbb5afff4b3bbed04b34
sha256sums = SKIP
pkgname = mingw-w64-mesa
diff --git a/PKGBUILD b/PKGBUILD
index c148a08b500e..696cbd0f2de4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
pkgname=mingw-w64-mesa
-pkgver=19.3.0
+pkgver=20.0.0
pkgrel=1
pkgdesc="An open-source implementation of the OpenGL specification (mingw-w64)"
arch=('any')
url="https://www.mesa3d.org/"
license=("custom")
-makedepends=('mingw-w64-gcc' 'scons' 'python-mako')
+makedepends=('mingw-w64-meson' 'python-mako')
depends=('mingw-w64-dlfcn' 'mingw-w64-llvm')
options=('staticlibs' '!strip' '!buildflags')
validpgpkeys=(71C4B75620BC75708B4BDB254C95FAAB3EB073EC # Dylan Baker <dylan@pnwbakers.com>
A5CC9FEC93F2F837CB044912336909B6B25FADFA) # Juan A. Suarez Romero <jasuarez@igalia.com>
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig})
-sha256sums=('5fa0e4e9dca79560f6882e362f9db36d81cf96da16cf6a84e0ada7466a99a5d7'
+sha256sums=('bb6db3e54b608d2536d4000b3de7dd3ae115fc114e8acbb5afff4b3bbed04b34'
'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -23,27 +23,16 @@ prepare () {
build() {
cd "${srcdir}"/mesa-${pkgver}
for _arch in ${_architectures}; do
- if test "${_arch}" = x86_64-w64-mingw32
- then
- machine="x86_64"
- else
- machine="x86"
- fi
- LLVM=/usr/${_arch} scons platform=windows toolchain=crossmingw machine=${machine} build=release libgl-gdi
+ ${_arch}-meson build-${_arch}
+ ninja -C build-${_arch}
done
}
package() {
cd "${srcdir}"/mesa-${pkgver}
for _arch in ${_architectures}; do
- if test "${_arch}" = x86_64-w64-mingw32
- then
- machine="x86_64"
- else
- machine="x86"
- fi
install -d "$pkgdir"/usr/${_arch}/bin
- install -m755 build/windows-${machine}/gallium/targets/libgl-gdi/opengl32.dll "$pkgdir"/usr/${_arch}/bin
+ install -m755 build-${_arch}/src/gallium/targets/libgl-gdi/opengl32.dll "$pkgdir"/usr/${_arch}/bin
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
done
}