summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-01-06 20:06:28 +0100
committerMichel Zou2020-01-06 20:06:28 +0100
commitd2e635dda37f6ad3cd06cd56b10f2cf067ecc5ab (patch)
tree28f33e2b290eba20384a8bfe7e635974c581715c
downloadaur-d2e635dda37f6ad3cd06cd56b10f2cf067ecc5ab.tar.gz
git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc512cc69e9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mingw-w64-mesa-git
+ pkgdesc = An open-source implementation of the OpenGL specification (mingw-w64)
+ pkgver = 20.0.0_devel.118918.d62dd8b0cb7
+ pkgrel = 1
+ url = https://www.mesa3d.org/
+ arch = any
+ license = custom
+ makedepends = mingw-w64-meson
+ makedepends = python-mako
+ depends = mingw-w64-dlfcn
+ depends = mingw-w64-llvm
+ provides = mingw-w64-mesa
+ conflicts = mingw-w64-mesa
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = git+git://anongit.freedesktop.org/mesa/mesa
+ sha256sums = SKIP
+
+pkgname = mingw-w64-mesa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df8064ad8ebd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+pkgname=mingw-w64-mesa-git
+pkgver=20.0.0_devel.118918.d62dd8b0cb7
+pkgrel=1
+pkgdesc="An open-source implementation of the OpenGL specification (mingw-w64)"
+arch=('any')
+url="https://www.mesa3d.org/"
+license=("custom")
+makedepends=('mingw-w64-meson' 'python-mako')
+depends=('mingw-w64-dlfcn' 'mingw-w64-llvm')
+provides=('mingw-w64-mesa')
+conflicts=('mingw-w64-mesa')
+options=('staticlibs' '!strip' '!buildflags')
+source=("git+git://anongit.freedesktop.org/mesa/mesa")
+sha256sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+pkgver() {
+ cd mesa
+ read -r _ver <VERSION
+ echo ${_ver/-/_}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare () {
+ cd "${srcdir}"/mesa
+}
+
+build() {
+ cd "${srcdir}"/mesa
+ for _arch in ${_architectures}; do
+ ${_arch}-meson build-${_arch}
+ ninja -C build-${_arch}
+ done
+}
+
+package() {
+ cd "${srcdir}"/mesa
+ for _arch in ${_architectures}; do
+ install -d "$pkgdir"/usr/${_arch}/bin
+ install -m755 build-${_arch}/src/gallium/targets/libgl-gdi/opengl32.dll "$pkgdir"/usr/${_arch}/bin
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ done
+}