summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2018-06-13 22:39:17 +0200
committerNicola Murino2018-06-13 22:39:17 +0200
commit7a1e04529430877f034b732bb692ed4f6443b902 (patch)
tree207434d82f52df0dfe78fb31d080c76a7c4fe32e
parent230f33df4af3c093c42f09e955b276463e493321 (diff)
downloadaur-7a1e04529430877f034b732bb692ed4f6443b902.tar.gz
remove conflicting cflags
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--toolchain-mingw.meson4
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 481c782dd868..7ab4cb03cafe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon May 14 09:46:09 UTC 2018
+# Wed Jun 13 20:39:13 UTC 2018
pkgbase = mingw-w64-meson
pkgdesc = Meson wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 5
+ pkgrel = 7
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = GPL
@@ -13,7 +13,7 @@ pkgbase = mingw-w64-meson
optdepends = mingw-w64-wine: Set NEED_WINE env variable in your PKGBUILD to use wine support in meson
source = toolchain-mingw.meson
source = meson-mingw-wrapper
- sha256sums = 32d9dc088394e17753231e4cc24c53c3d3c0e29130a9aa37c6ca080d865a22e2
+ sha256sums = e9ed0a02b0f6ef00f76b2e41d02f2cc486355f9799072a3c6267fefcbf48b110
sha256sums = d02f4469567104c03d908b1eb7cd2093342bf84b58bd2dc458e33ffd708b5ccb
pkgname = mingw-w64-meson
diff --git a/PKGBUILD b/PKGBUILD
index 978372d83c49..8a06957dda08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-meson
pkgver=1
-pkgrel=5
+pkgrel=7
arch=('any')
pkgdesc="Meson wrapper for MinGW (mingw-w64)"
depends=('meson' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
@@ -10,7 +10,7 @@ license=("GPL")
url="http://fedoraproject.org/wiki/MinGW"
source=("toolchain-mingw.meson"
"meson-mingw-wrapper")
-sha256sums=('32d9dc088394e17753231e4cc24c53c3d3c0e29130a9aa37c6ca080d865a22e2'
+sha256sums=('e9ed0a02b0f6ef00f76b2e41d02f2cc486355f9799072a3c6267fefcbf48b110'
'd02f4469567104c03d908b1eb7cd2093342bf84b58bd2dc458e33ffd708b5ccb')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -29,9 +29,10 @@ build() {
}
package() {
+ install -d "${pkgdir}"/usr/bin
install -d "${pkgdir}"/usr/share/mingw
for _arch in ${_architectures}; do
- install -Dm 755 "${srcdir}/${_arch}-meson" "$pkgdir/usr/bin/${_arch}-meson"
+ install -m 755 "${srcdir}/${_arch}-meson" "$pkgdir/usr/bin/${_arch}-meson"
install -m 644 toolchain-${_arch}.meson "${pkgdir}"/usr/share/mingw/
install -m 644 toolchain-${_arch}-wine.meson "${pkgdir}"/usr/share/mingw/
done
diff --git a/toolchain-mingw.meson b/toolchain-mingw.meson
index 2f34e3f36fb4..8aed5b092825 100644
--- a/toolchain-mingw.meson
+++ b/toolchain-mingw.meson
@@ -11,8 +11,8 @@ exe_wrapper = '@TRIPLE@-wine'
[properties]
root = '@TRIPLE@'
-c_args = ['-O2', '-g', '-pipe', '-Wall', '-Wp,-D_FORTIFY_SOURCE=2', '-fexceptions', '--param=ssp-buffer-size=4']
-cpp_args = ['-O2', '-g', '-pipe', '-Wall', '-Wp,-D_FORTIFY_SOURCE=2', '-fexceptions', '--param=ssp-buffer-size=4']
+c_args = ['-Wp,-D_FORTIFY_SOURCE=2', '-fexceptions', '--param=ssp-buffer-size=4']
+cpp_args = ['-Wp,-D_FORTIFY_SOURCE=2', '-fexceptions', '--param=ssp-buffer-size=4']
needs_exe_wrapper = true
[host_machine]