summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2018-05-10 23:21:52 +0200
committerNicola Murino2018-05-10 23:21:52 +0200
commit7f8dd11412d277ed51f5bcafeba818c0b739fcc7 (patch)
treeca6240c1d1f3dbc648e67f20363f3c27db2a1fde
parenta3253e8c490d02aee0803c98a4f88176a17ace1c (diff)
downloadaur-7f8dd11412d277ed51f5bcafeba818c0b739fcc7.tar.gz
add a wrapper script
thanks to kfg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--meson-mingw-wrapper23
-rw-r--r--toolchain-mingw.meson1
4 files changed, 36 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2be8ff9e93d2..9fc4fbcd099d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 8 12:34:59 UTC 2018
+# Thu May 10 21:21:46 UTC 2018
pkgbase = mingw-w64-meson
pkgdesc = Meson wrapper for MinGW (mingw-w64)
pkgver = 1
- pkgrel = 2
+ pkgrel = 3
url = http://fedoraproject.org/wiki/MinGW
arch = any
license = GPL
@@ -12,7 +12,9 @@ pkgbase = mingw-w64-meson
depends = mingw-w64-pkg-config
optdepends = wine: runtime support
source = toolchain-mingw.meson
- sha256sums = 61477f5e313b16d24e6dd669a732953941ad9b648ad7a057e909da37cccd879e
+ source = meson-mingw-wrapper
+ sha256sums = c98abe7959a53685747c08c350925c0c1eb4043ebf8a12553568772251cbdf86
+ sha256sums = 955ab09bc5e0f191964e008a54caa695290264c84f16fac7e48c1a2fe0838232
pkgname = mingw-w64-meson
diff --git a/PKGBUILD b/PKGBUILD
index af851636ee43..18328a5232d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-meson
pkgver=1
-pkgrel=2
+pkgrel=3
arch=('any')
pkgdesc="Meson wrapper for MinGW (mingw-w64)"
depends=('meson' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
optdepends=('wine: runtime support')
license=("GPL")
url="http://fedoraproject.org/wiki/MinGW"
-source=("toolchain-mingw.meson")
-sha256sums=('61477f5e313b16d24e6dd669a732953941ad9b648ad7a057e909da37cccd879e')
+source=("toolchain-mingw.meson"
+ "meson-mingw-wrapper")
+sha256sums=('c98abe7959a53685747c08c350925c0c1eb4043ebf8a12553568772251cbdf86'
+ '955ab09bc5e0f191964e008a54caa695290264c84f16fac7e48c1a2fe0838232')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
@@ -20,12 +22,14 @@ build() {
_cpu_family="x86_64"
fi
sed "s|@TRIPLE@|${_arch}|g;s|@PROCESSOR@|${_arch::-12}|g;s|@CPU_FAMILY@|${_cpu_family}|g" toolchain-mingw.meson > toolchain-${_arch}.meson
+ sed "s|@TRIPLE@|${_arch}|g;" meson-mingw-wrapper > ${_arch}-meson
done
}
package() {
install -d "${pkgdir}"/usr/share/mingw
for _arch in ${_architectures}; do
+ install -Dm 755 "${srcdir}/${_arch}-meson" "$pkgdir/usr/bin/${_arch}-meson"
install -m 644 toolchain-${_arch}.meson "${pkgdir}"/usr/share/mingw/
done
}
diff --git a/meson-mingw-wrapper b/meson-mingw-wrapper
new file mode 100644
index 000000000000..313702065c2a
--- /dev/null
+++ b/meson-mingw-wrapper
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+meson setup \
+ --prefix /usr/@TRIPLE@ \
+ --libdir /usr/@TRIPLE@/lib \
+ --libexecdir /usr/@TRIPLE@/lib \
+ --bindir /usr/@TRIPLE@/bin \
+ --sbindir /usr/@TRIPLE@/bin \
+ --includedir /usr/@TRIPLE@/include \
+ --datadir /usr/@TRIPLE@/share \
+ --mandir /usr/@TRIPLE@/share/man \
+ --infodir /usr/@TRIPLE@/share/info \
+ --localedir /usr/@TRIPLE@/share/locale \
+ --sysconfdir /usr/@TRIPLE@/etc \
+ --localstatedir /var \
+ --sharedstatedir /var/lib \
+ --buildtype release \
+ --wrap-mode nofallback \
+ --strip \
+ --cross-file /usr/share/mingw/toolchain-@TRIPLE@.meson \
+ --default-library both \
+ "$@" \
+ -D b_lto=true
diff --git a/toolchain-mingw.meson b/toolchain-mingw.meson
index b52220e0406e..8a322a0a6341 100644
--- a/toolchain-mingw.meson
+++ b/toolchain-mingw.meson
@@ -7,6 +7,7 @@ pkgconfig = '@TRIPLE@-pkg-config'
ranlib = '@TRIPLE@-ranlib'
strip = '@TRIPLE@-strip'
windres = '@TRIPLE@-windres'
+exe_wrapper = 'wine'
[properties]
root = '@TRIPLE@'