summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-09-02 09:39:22 +0200
committerMichel Zou2017-09-02 09:39:22 +0200
commit0a05c0b2f19762f991e3bce1312efcb3f46e0c40 (patch)
treeb6f2fed07f53e8a34c87a9bbc159f053ec84f3a5
parent3c17e451ec9e3bde7e32365b75a7bf96655f1eca (diff)
downloadaur-0a05c0b2f19762f991e3bce1312efcb3f46e0c40.tar.gz
shared
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 6 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1af3ae411daf..3e49f7eddcc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Oct 28 22:38:04 UTC 2016
+# Sat Sep 2 07:39:22 UTC 2017
pkgbase = mingw-w64-minizip
pkgdesc = ZIP file extraction library (mingw-w64)
pkgver = 1.2.8
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/nmoinvaz/minizip
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index badbd1285595..aa780f6d5e9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-minizip
pkgver=1.2.8
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='ZIP file extraction library (mingw-w64)'
url='https://github.com/nmoinvaz/minizip'
@@ -17,10 +17,9 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd minizip
+ sed -i "s|\-version\-info|\-no\-undefined \-version\-info|g" Makefile.am
- rm -f Makefile
- autoreconf -i
- autoconf && automake --add-missing && automake
+ autoreconf -vfi
}
build() {
@@ -37,22 +36,7 @@ package() {
for _arch in ${_architectures}; do
cd "$srcdir/minizip/build-${_arch}"
make install DESTDIR="$pkgdir"
-# ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}
-#
-# build() {
-# cd minizip
-#
-# ./configure --prefix=/usr
-# make
-# }
-#
-# package() {
-# cd minizip
-#
-# make install DESTDIR="$pkgdir"
-# libtool --finish "$pkgdir/usr/lib"
-# install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-# }