summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMladen Milinkovic2019-07-09 01:14:23 +0200
committerMladen Milinkovic2019-07-09 01:14:23 +0200
commitc7620100ad9c20db7876a77ccd6519be2f89db64 (patch)
treec0e8ad1761b9363f96e418e7465fb91b6aef49bf
downloadaur-c7620100ad9c20db7876a77ccd6519be2f89db64.tar.gz
Version 0.29.1
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD77
3 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..551ac607f7c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-mpv
+ pkgdesc = Video player based on MPlayer/mplayer2 (mingw-w64)
+ pkgver = 0.29.1
+ pkgrel = 1
+ url = https://mpv.io/
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-gcc
+ makedepends = perl
+ makedepends = pkg-config
+ makedepends = python
+ depends = mingw-w64-ffmpeg
+ depends = mingw-w64-lcms2
+ depends = mingw-w64-libass
+ depends = mingw-w64-libbluray
+ depends = mingw-w64-libjpeg-turbo
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = mpv-0.29.1.tar.gz::https://github.com/mpv-player/mpv/archive/v0.29.1.tar.gz
+ sha256sums = f9f9d461d1990f9728660b4ccb0e8cb5dce29ccaa6af567bec481b79291ca623
+
+pkgname = mingw-w64-mpv
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c98cdbbd9a8b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.log
+*.sig
+*.tar
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4ed0d3fa865
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+_pkgname=mpv
+pkgname="mingw-w64-${_pkgname}"
+pkgver=0.29.1
+pkgrel=1
+pkgdesc="Video player based on MPlayer/mplayer2 (mingw-w64)"
+url="https://mpv.io/"
+arch=('any')
+license=('GPL')
+depends=("mingw-w64-ffmpeg"
+ "mingw-w64-lcms2"
+ "mingw-w64-libass"
+ "mingw-w64-libbluray"
+ "mingw-w64-libjpeg-turbo"
+ "mingw-w64-shaderc"
+ "mingw-w64-crossc")
+makedepends=("mingw-w64-gcc"
+ "perl"
+ "mingw-w64-pkg-config"
+ "python")
+options=(staticlibs !strip !buildflags)
+source=(${_pkgname}-${pkgver}.tar.gz::https://github.com/mpv-player/${_pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=('f9f9d461d1990f9728660b4ccb0e8cb5dce29ccaa6af567bec481b79291ca623')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ pushd ${_pkgname}-${pkgver}
+ [[ -x ./waf ]] || /usr/bin/python3 ./bootstrap.py
+ popd
+
+ for _arch in ${_architectures}; do
+ cp -rf "${_pkgname}-${pkgver}" "build-${_arch}"
+ done
+ rm -rf "${_pkgname}-${pkgver}"
+}
+
+build() {
+ cd "${srcdir}/"
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+ DEST_OS=win32 \
+ TARGET=${_arch} \
+ PKG_CONFIG=/usr/bin/${_arch}-pkg-config \
+ CC=/usr/bin/${_arch}-gcc \
+ PERL=/usr/bin/perl \
+ AR=/usr/bin/${_arch}-ar \
+ WINDRES=/usr/bin/${_arch}-windres \
+ ./waf configure \
+ --prefix=/usr/$_arch \
+ --check-c-compiler=gcc \
+ --enable-libmpv-shared \
+ --disable-egl-angle \
+ --disable-egl-angle-lib
+ ./waf build
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}"
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ export PYTHON=/usr/$_arch/bin/python
+ ./waf install --destdir="${pkgdir}"
+
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+
+ # Move encoding-profiles.conf to share/doc alongside the example .conf files.
+ # mpv doesn't search /etc for configuration on MinGW.
+ mv "${pkgdir}/usr/$_arch/etc/mpv/"*.conf "${pkgdir}/usr/$_arch/share/doc/mpv/"
+
+ popd
+ done
+}