summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2024-01-12 19:55:12 +0100
committerMichel Zou2024-01-12 19:55:12 +0100
commit64138ffcf42a948aea7fdac806dfcc372d0325e9 (patch)
tree36533f24aea96672baf9288daaf2ed027922666c
downloadaur-64138ffcf42a948aea7fdac806dfcc372d0325e9.tar.gz
1.5.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d13bdb60239
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mingw-w64-nanoflann
+ pkgdesc = a C++ header-only library for Nearest Neighbor (NN) search wih KD-trees (mingw-w64)
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/jlblancoc/nanoflann
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-eigen
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/jlblancoc/nanoflann/archive/v1.5.0.tar.gz
+ sha256sums = 89aecfef1a956ccba7e40f24561846d064f309bc547cc184af7f4426e42f8e65
+
+pkgname = mingw-w64-nanoflann
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7bd53e16765
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=('mingw-w64-nanoflann')
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='a C++ header-only library for Nearest Neighbor (NN) search wih KD-trees (mingw-w64)'
+url='https://github.com/jlblancoc/nanoflann'
+arch=('any')
+license=('BSD')
+makedepends=('mingw-w64-cmake')
+options=('!strip' '!buildflags' 'staticlibs')
+depends=('mingw-w64-eigen')
+source=("https://github.com/jlblancoc/nanoflann/archive/v${pkgver}.tar.gz")
+sha256sums=('89aecfef1a956ccba7e40f24561846d064f309bc547cc184af7f4426e42f8e65')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd nanoflann-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DNANOFLANN_BUILD_EXAMPLES=OFF -DNANOFLANN_BUILD_TESTS=OFF ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/nanoflann-$pkgver/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ done
+}