summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-11-20 07:58:37 -0500
committerPatrick Northon2021-11-20 07:58:37 -0500
commit294379278ce15b345f5b6f9492e40438f0998360 (patch)
tree7bc016489159020161d903eadcfb4f19c3ba7327
parent1ab64f7725130a4583c7568396687c7ec2585f54 (diff)
downloadaur-294379278ce15b345f5b6f9492e40438f0998360.tar.gz
Bump version and include both shared and static libraries. Remove program prefix, tests and man pages.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2f928789268..22cbec7f9bfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-ncurses
pkgdesc = System V Release 4.0 curses emulation library (mingw-w64)
- pkgver = 6.2
- pkgrel = 3
+ pkgver = 6.3
+ pkgrel = 1
url = https://www.gnu.org/software/ncurses/
arch = any
license = MIT
@@ -14,7 +14,7 @@ pkgbase = mingw-w64-ncurses
options = !strip
options = !buildflags
options = staticlibs
- source = ncurses-6.2.tar.gz::https://ftp.gnu.org/pub/gnu/ncurses/ncurses-6.2.tar.gz
- sha256sums = 30306e0c76e0f9f1f0de987cf1c82a5c21e1ce6568b9227f7da5b71cbea86c9d
+ source = ncurses-6.3.tar.gz::https://ftp.gnu.org/pub/gnu/ncurses/ncurses-6.3.tar.gz
+ sha256sums = 97fc51ac2b085d4cde31ef4d2c3122c21abc217e9090a43a30fc5ec21684e059
pkgname = mingw-w64-ncurses
diff --git a/PKGBUILD b/PKGBUILD
index ff56824d031c..50d3b9ca901a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
# Contributor: Andrew Sun <adsun701@gmail.com>
-pkgname=mingw-w64-ncurses
-pkgver=6.2
-pkgrel=3
+_pkgname=ncurses
+pkgname=mingw-w64-${_pkgname}
+pkgver=6.3
+pkgrel=1
pkgdesc="System V Release 4.0 curses emulation library (mingw-w64)"
arch=('any')
url="https://www.gnu.org/software/ncurses/"
@@ -12,7 +13,7 @@ makedepends=('mingw-w64-configure' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
depends=('mingw-w64-crt' 'mingw-w64-regex' 'mingw-w64-libiconv')
options=('!strip' '!buildflags' 'staticlibs')
source=("ncurses-${pkgver}.tar.gz"::"https://ftp.gnu.org/pub/gnu/ncurses/ncurses-${pkgver}.tar.gz")
-sha256sums=('30306e0c76e0f9f1f0de987cf1c82a5c21e1ce6568b9227f7da5b71cbea86c9d')
+sha256sums=('97fc51ac2b085d4cde31ef4d2c3122c21abc217e9090a43a30fc5ec21684e059')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -23,7 +24,9 @@ build() {
LIBS="$(${_arch}-pkg-config --libs regex) -liconv" ${_arch}-configure \
--without-ada \
--with-cxx \
- --without-shared \
+ --with-cxx-shared \
+ --with-shared \
+ --with-normal \
--without-pthread \
--enable-pc-files \
--disable-rpath \
@@ -38,7 +41,11 @@ build() {
--enable-sp-funcs \
--enable-term-driver \
--enable-interop \
- --enable-widec
+ --enable-widec \
+ --without-manpages \
+ --without-tests \
+ --without-debug \
+ --program-prefix=
make
popd
done
@@ -48,8 +55,11 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/ncurses-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
- cp -R ${pkgdir}/usr/${_arch}/include/ncursesw ${pkgdir}/usr/${_arch}/include/ncurses
- cp ${pkgdir}/usr/${_arch}/lib/libncursesw.a ${pkgdir}/usr/${_arch}/lib/libncurses.a
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ [[ -d "${pkgdir}/usr/lib" ]] && rm -rf "${pkgdir}/usr/lib"
+ #cp -R ${pkgdir}/usr/${_arch}/include/ncursesw ${pkgdir}/usr/${_arch}/include/ncurses
+ #cp ${pkgdir}/usr/${_arch}/lib/libncursesw.a ${pkgdir}/usr/${_arch}/lib/libncurses.a
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}