summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-03-13 10:41:25 +0100
committerMichel Zou2016-03-13 10:41:25 +0100
commit8b7bd378885bb1a15a4febf6075f50ae515e4b65 (patch)
treee82383c7ef7d8eb37382a3530d2ee15e628c25ab
downloadaur-8b7bd378885bb1a15a4febf6075f50ae515e4b65.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4522e86054ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 09:41:25 UTC 2016
+pkgbase = mingw-w64-netcdf-cxx
+ pkgdesc = NetCDF c++ bindings (mingw-w64)
+ pkgver = 4.2
+ pkgrel = 1
+ url = http://www.unidata.ucar.edu/downloads/netcdf/netcdf-cxx/index.jsp
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-netcdf
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = http://www.unidata.ucar.edu/downloads/netcdf/ftp/netcdf-cxx4-4.2.tar.gz
+ sha1sums = 59628c9f06c211a47517fc00d8b068da159ffa9d
+
+pkgname = mingw-w64-netcdf-cxx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03edcc397e79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=mingw-w64-netcdf-cxx
+pkgver=4.2
+pkgrel=1
+pkgdesc="NetCDF c++ bindings (mingw-w64)"
+arch=("i686" "x86_64")
+url="http://www.unidata.ucar.edu/downloads/netcdf/netcdf-cxx/index.jsp"
+depends=('mingw-w64-netcdf')
+makedepends=('mingw-w64-configure')
+options=('staticlibs' '!buildflags' '!strip')
+license=('custom')
+source=("http://www.unidata.ucar.edu/downloads/netcdf/ftp/netcdf-cxx4-${pkgver}.tar.gz")
+sha1sums=('59628c9f06c211a47517fc00d8b068da159ffa9d')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd ${srcdir}/netcdf-cxx4-${pkgver}
+ sed -i "s|libnetcdf_c__4_la_LDFLAGS = -version-info|libnetcdf_c__4_la_LDFLAGS = -no-undefined -version-info|g" cxx4/Makefile.am
+ autoreconf -vfi
+}
+
+build() {
+ cd ${srcdir}/netcdf-cxx4-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/netcdf-cxx4-${pkgver}/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}