summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-06-13 20:15:17 +0200
committerMichel Zou2017-06-13 20:15:17 +0200
commit7ed9b12dcaaea7368587953cbb2740a706e24e89 (patch)
tree589e2f157d2e2a22acd625d264bb535abf13d1b4
downloadaur-7ed9b12dcaaea7368587953cbb2740a706e24e89.tar.gz
4.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d78ae186711d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Jun 13 18:15:17 UTC 2017
+pkgbase = mingw-w64-netcdf-cxx-legacy
+ pkgdesc = Backward compatible netCDF C++ library (mingw-w64)
+ pkgver = 4.2
+ pkgrel = 1
+ url = http://www.unidata.ucar.edu/downloads/netcdf/netcdf-cxx
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-netcdf
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = ftp://ftp.unidata.ucar.edu/pub/netcdf/netcdf-cxx-4.2.tar.gz
+ md5sums = d32b20c00f144ae6565d9e98d9f6204c
+
+pkgname = mingw-w64-netcdf-cxx-legacy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a526f0971ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=mingw-w64-netcdf-cxx-legacy
+spkgname=netcdf-cxx
+pkgver=4.2
+pkgrel=1
+pkgdesc="Backward compatible netCDF C++ library (mingw-w64)"
+arch=("any")
+url="http://www.unidata.ucar.edu/downloads/netcdf/netcdf-cxx"
+depends=('mingw-w64-netcdf')
+makedepends=('mingw-w64-configure')
+options=('staticlibs' '!buildflags' '!strip')
+license=('GPL')
+source=("ftp://ftp.unidata.ucar.edu/pub/netcdf/${spkgname}-${pkgver}.tar.gz")
+md5sums=('d32b20c00f144ae6565d9e98d9f6204c')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}"/${spkgname}-${pkgver}
+ sed -i "s|libnetcdf_c___la_LDFLAGS = -version|libnetcdf_c___la_LDFLAGS = -no-undefined -version|g" cxx/Makefile.am
+ autoreconf -vfi
+}
+
+build() {
+ cd "${srcdir}"/${spkgname}-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}"/${spkgname}-${pkgver}/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ rm -r "$pkgdir"/usr/${_arch}/share
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}