summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-11-18 18:43:34 +0100
committerMichel Zou2021-11-18 18:43:34 +0100
commita639671460e6e437165e38f5b5846f56d9659321 (patch)
tree1beb8745e784c4c6dc7ba7eb713c82cd4807695b
parent5890e26ff380a0651e296125547df4e0f9f1c9b7 (diff)
downloadaur-a639671460e6e437165e38f5b5846f56d9659321.tar.gz
3.10.4
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb3207ae06da..822caaa12b0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-nlohmann-json
pkgdesc = Header-only JSON library for Modern C++ (mingw-w64)
- pkgver = 3.9.1
+ pkgver = 3.10.4
pkgrel = 1
url = https://github.com/nlohmann/json
arch = any
@@ -10,8 +10,7 @@ pkgbase = mingw-w64-nlohmann-json
options = !buildflags
options = !strip
options = staticlibs
- source = https://github.com/nlohmann/json/archive/v3.9.1.tar.gz
- sha256sums = 4cf0df69731494668bdd6460ed8cb269b68de9c19ad8c27abc24cd72605b2d5b
+ source = https://github.com/nlohmann/json/archive/v3.10.4.tar.gz
+ sha256sums = 1155fd1a83049767360e9a120c43c578145db3204d2b309eba49fbbedd0f4ed3
pkgname = mingw-w64-nlohmann-json
-
diff --git a/PKGBUILD b/PKGBUILD
index 99abb2869196..2540a5cbd603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-nlohmann-json
-pkgver=3.9.1
+pkgver=3.10.4
pkgrel=1
pkgdesc='Header-only JSON library for Modern C++ (mingw-w64)'
url='https://github.com/nlohmann/json'
@@ -9,7 +9,7 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
source=("https://github.com/nlohmann/json/archive/v${pkgver}.tar.gz")
-sha256sums=('4cf0df69731494668bdd6460ed8cb269b68de9c19ad8c27abc24cd72605b2d5b')
+sha256sums=('1155fd1a83049767360e9a120c43c578145db3204d2b309eba49fbbedd0f4ed3')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -17,7 +17,7 @@ build() {
cd "$srcdir/json-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DBUILD_TESTING=OFF -DJSON_MultipleHeaders=ON ..
+ ${_arch}-cmake -DJSON_BuildTests=OFF -DJSON_MultipleHeaders=ON ..
make
popd
done