summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2017-11-12 09:15:05 +0000
committerAndrew Sun2017-11-12 09:15:05 +0000
commit4799d54b283eb7cac681c6262031bb06e49b64d6 (patch)
treeee8a2e70ebeb3c15b42a16f3c21d24b7b9b16216
downloadaur-4799d54b283eb7cac681c6262031bb06e49b64d6.tar.gz
add mingw-w64-ntldd-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c65b3bc7c11f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-ntldd-git
+ pkgdesc = Tracks dependencides in Windows PE binaries (mingw-w64)
+ pkgver = r17.3a08ea2
+ pkgrel = 1
+ url = https://github.com/LRN/ntldd
+ arch = any
+ license = GPL3
+ makedepends = mingw-w64-gcc
+ makedepends = git
+ depends = mingw-w64-crt
+ depends = wine
+ provides = mingw-w64-ntldd
+ conflicts = mingw-w64-ntldd
+ source = git+https://github.com/LRN/ntldd.git
+ md5sums = SKIP
+
+pkgname = mingw-w64-ntldd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ace7e8164a86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Andrew Sun <adsun701@gmail.com>
+
+pkgname=mingw-w64-ntldd-git
+pkgver=r17.3a08ea2
+pkgrel=1
+pkgdesc="Tracks dependencides in Windows PE binaries (mingw-w64)"
+arch=('any')
+license=('GPL3')
+depends=("mingw-w64-crt" "wine")
+makedepends=("mingw-w64-gcc" "git")
+url="https://github.com/LRN/ntldd"
+provides=("mingw-w64-ntldd")
+conflicts=("mingw-w64-ntldd")
+source=("git+https://github.com/LRN/ntldd.git")
+md5sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+pkgver() {
+ cd "${srcdir}/ntldd"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ rm -rf "${srcdir}/build-${_arch}"
+ cp -R ${srcdir}/ntldd/. "${srcdir}/build-${_arch}"
+ cd "${srcdir}/build-${_arch}"
+ CC=${_arch}-gcc \
+ AR=${_arch}-ar \
+ RANLIB=${_arch}-ranlib \
+ make
+ done
+}
+
+package () {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/build-${_arch}"
+ install -d "${pkgdir}/usr/${_arch}/"{bin,include,lib}
+ install -m644 -t "${pkgdir}/usr/${_arch}/include" libntldd.h
+ install -m644 -t "${pkgdir}/usr/${_arch}/lib" libntldd.a
+ install -m755 -t "${pkgdir}/usr/${_arch}/bin" ntldd.exe
+ install -m644 -D README "${pkgdir}/usr/${_arch}/share/doc/ntldd/README"
+ done
+}