summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Bart2018-10-15 12:08:30 -0300
committerEduardo Bart2018-10-15 12:08:30 -0300
commit294b7b65795708b1d71a66147a829198dfac327a (patch)
treea8d86bbe63e14854e6af46beeb09cf11c46e5b4f
parentd22f7ad7837d2fe25b7f8836b587fa1456ea5368 (diff)
downloadaur-294b7b65795708b1d71a66147a829198dfac327a.tar.gz
Update to 1.19.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--fixcmake.patch50
3 files changed, 10 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cbda82d76ca..2da801d46bcd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-openal
pkgdesc = Cross-platform 3D audio library, software implementation (mingw-w64)
- pkgver = 1.18.2
+ pkgver = 1.19.1
pkgrel = 1
url = https://github.com/kcat/openal-soft
arch = any
@@ -10,10 +10,8 @@ pkgbase = mingw-w64-openal
options = !strip
options = !buildflags
options = staticlibs
- source = http://kcat.strangesoft.net/openal-releases/openal-soft-1.18.2.tar.bz2
- source = fixcmake.patch
- sha256sums = 9f8ac1e27fba15a59758a13f0c7f6540a0605b6c3a691def9d420570506d7e82
- sha256sums = b6a516e20f5d85e4e94e1f469c23d5f8b5953f7a82c0636b5d68d98e47ce5fd0
+ source = git+https://github.com/kcat/openal-soft#commit=6761218e51699f46bf25c377e65b3e9ea5e434b9
+ sha256sums = SKIP
pkgname = mingw-w64-openal
diff --git a/PKGBUILD b/PKGBUILD
index e9b90bca0266..6684cd22d5b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-openal
-pkgver=1.18.2
+pkgver=1.19.1
pkgrel=1
pkgdesc="Cross-platform 3D audio library, software implementation (mingw-w64)"
arch=(any)
@@ -8,16 +8,14 @@ license=('LGPL')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=(!strip !buildflags staticlibs)
-source=(http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2
- fixcmake.patch)
-sha256sums=('9f8ac1e27fba15a59758a13f0c7f6540a0605b6c3a691def9d420570506d7e82'
- 'b6a516e20f5d85e4e94e1f469c23d5f8b5953f7a82c0636b5d68d98e47ce5fd0')
+_commit=6761218e51699f46bf25c377e65b3e9ea5e434b9 # tags/openal-soft-1.19.1
+source=("git+https://github.com/kcat/openal-soft#commit=$_commit")
+sha256sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "${srcdir}/openal-soft-${pkgver}"
- patch -Np1 < ${srcdir}/fixcmake.patch
+ cd "${srcdir}/openal-soft"
# static
for _arch in ${_architectures}; do
@@ -39,7 +37,7 @@ build() {
package() {
# static
for _arch in ${_architectures}; do
- cd "${srcdir}/openal-soft-${pkgver}/build-static-${_arch}"
+ cd "${srcdir}/openal-soft/build-static-${_arch}"
make DESTDIR="${pkgdir}" install
rm -r "$pkgdir"/usr/${_arch}/share
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
@@ -47,7 +45,7 @@ package() {
# shared
for _arch in ${_architectures}; do
- cd "${srcdir}/openal-soft-${pkgver}/build-shared-${_arch}"
+ cd "${srcdir}/openal-soft/build-shared-${_arch}"
make DESTDIR="${pkgdir}" install
rm -r "$pkgdir"/usr/${_arch}/share
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
diff --git a/fixcmake.patch b/fixcmake.patch
deleted file mode 100644
index 83fc33d0a332..000000000000
--- a/fixcmake.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From cae4b1a062b53dd25eba7caa41622be730106749 Mon Sep 17 00:00:00 2001
-From: Chris Robinson <chris.kcat@gmail.com>
-Date: Wed, 28 Mar 2018 14:34:58 -0700
-Subject: [PATCH] Don't specify macros as arguments to CHECK_INCLUDE_FILE(S)
-
----
- CMakeLists.txt | 15 +++++++++++++--
- 1 file changed, 13 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index df1dfe63..07454f15 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -577,7 +577,12 @@ ENDIF()
-
-
- # Check if we have Windows headers
--CHECK_INCLUDE_FILE(windows.h HAVE_WINDOWS_H -D_WIN32_WINNT=0x0502)
-+SET(OLD_REQUIRED_DEFINITIONS ${CMAKE_REQUIRED_DEFINITIONS})
-+SET(CMAKE_REQUIRED_DEFINITIONS ${CMAKE_REQUIRED_DEFINITIONS} -D_WIN32_WINNT=0x0502)
-+CHECK_INCLUDE_FILE(windows.h HAVE_WINDOWS_H)
-+SET(CMAKE_REQUIRED_DEFINITIONS ${OLD_REQUIRED_DEFINITIONS})
-+UNSET(OLD_REQUIRED_DEFINITIONS)
-+
- IF(NOT HAVE_WINDOWS_H)
- CHECK_SYMBOL_EXISTS(gettimeofday sys/time.h HAVE_GETTIMEOFDAY)
- IF(NOT HAVE_GETTIMEOFDAY)
-@@ -975,8 +980,11 @@ OPTION(ALSOFT_REQUIRE_WINMM "Require Windows Multimedia backend" OFF)
- OPTION(ALSOFT_REQUIRE_DSOUND "Require DirectSound backend" OFF)
- OPTION(ALSOFT_REQUIRE_WASAPI "Require WASAPI backend" OFF)
- IF(HAVE_WINDOWS_H)
-+ SET(OLD_REQUIRED_DEFINITIONS ${CMAKE_REQUIRED_DEFINITIONS})
-+ SET(CMAKE_REQUIRED_DEFINITIONS ${CMAKE_REQUIRED_DEFINITIONS} -D_WIN32_WINNT=0x0502)
-+
- # Check MMSystem backend
-- CHECK_INCLUDE_FILES("windows.h;mmsystem.h" HAVE_MMSYSTEM_H -D_WIN32_WINNT=0x0502)
-+ CHECK_INCLUDE_FILES("windows.h;mmsystem.h" HAVE_MMSYSTEM_H)
- IF(HAVE_MMSYSTEM_H)
- CHECK_SHARED_FUNCTION_EXISTS(waveOutOpen "windows.h;mmsystem.h" winmm "" HAVE_LIBWINMM)
- IF(HAVE_LIBWINMM)
-@@ -1013,6 +1021,9 @@ IF(HAVE_WINDOWS_H)
- SET(ALC_OBJS ${ALC_OBJS} Alc/backends/wasapi.c)
- ENDIF()
- ENDIF()
-+
-+ SET(CMAKE_REQUIRED_DEFINITIONS ${OLD_REQUIRED_DEFINITIONS})
-+ UNSET(OLD_REQUIRED_DEFINITIONS)
- ENDIF()
- IF(ALSOFT_REQUIRE_WINMM AND NOT HAVE_WINMM)
- MESSAGE(FATAL_ERROR "Failed to enabled required WinMM backend")