summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-11-30 22:03:28 +0100
committerMichel Zou2016-11-30 22:03:28 +0100
commit3d1d146c7eb6291bfec037d700a1b75c7a374d05 (patch)
treee6eed8f42f1b2d7fd005fca4508d0725dacb9d2e
parent29559bcdab2bfdfb95857430f69550ef7af8f0a7 (diff)
downloadaur-3d1d146c7eb6291bfec037d700a1b75c7a374d05.tar.gz
1.17.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 28 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9432f38e4963..2141619d5227 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Nov 30 21:03:28 UTC 2016
pkgbase = mingw-w64-openal
- pkgdesc = OpenAL audio library for use with opengl (mingw-w64)
- pkgver = 1.16.0
- pkgrel = 5
- url = http://connect.creativelabs.com/openal/
+ pkgdesc = Cross-platform 3D audio library, software implementation (mingw-w64)
+ pkgver = 1.17.2
+ pkgrel = 1
+ url = https://github.com/kcat/openal-soft
arch = any
- license = GPL2
- makedepends = mingw-w64-gcc
+ license = LGPL
makedepends = mingw-w64-cmake
depends = mingw-w64-crt
options = !strip
options = !buildflags
options = staticlibs
- source = http://kcat.strangesoft.net/openal-releases/openal-soft-1.16.0.tar.bz2
- md5sums = 14db4b0d12f07252070b4fe5eb5911f6
+ source = http://kcat.strangesoft.net/openal-releases/openal-soft-1.17.2.tar.bz2
+ md5sums = 1764e0d8fec499589b47ebc724e0913d
pkgname = mingw-w64-openal
diff --git a/PKGBUILD b/PKGBUILD
index 9c86a0467918..b67196c3e8d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
-# Maintainer: naelstrof <naelstrof@gmail.com>
-
pkgname=mingw-w64-openal
-pkgver=1.16.0
-pkgrel=5
-pkgdesc="OpenAL audio library for use with opengl (mingw-w64)"
+pkgver=1.17.2
+pkgrel=1
+pkgdesc="Cross-platform 3D audio library, software implementation (mingw-w64)"
arch=(any)
-url="http://connect.creativelabs.com/openal/"
-license=('GPL2')
+url="https://github.com/kcat/openal-soft"
+license=('LGPL')
depends=('mingw-w64-crt')
-makedepends=('mingw-w64-gcc' 'mingw-w64-cmake')
+makedepends=('mingw-w64-cmake')
options=(!strip !buildflags staticlibs)
source=(http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2)
-md5sums=('14db4b0d12f07252070b4fe5eb5911f6')
+md5sums=('1764e0d8fec499589b47ebc724e0913d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-build() {
- unset LDFLAGS
+build() {
+ cd "${srcdir}/openal-soft-${pkgver}"
for _arch in ${_architectures}; do
- mkdir -p "${srcdir}/build-${_arch}" && cd "${srcdir}/build-${_arch}"
- ${_arch}-cmake -DEXAMPLES=OFF \
- ../openal-soft-${pkgver}
- make
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DALSOFT_EXAMPLES=OFF -DALSOFT_TESTS=OFF -DALSOFT_UTILS=OFF ..
+ make
+ popd
done
}
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/build-${_arch}"
- make DESTDIR="${pkgdir}" install
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ cd "${srcdir}/openal-soft-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ rm -r "$pkgdir"/usr/${_arch}/share
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}
+