summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-08-09 20:09:17 +0200
committerMichel Zou2021-08-09 20:09:17 +0200
commitdabf0412c6d8cb37a4304721d3f57c7f7b44b88f (patch)
tree58303be334724ede11a953dfb1d347ba1441b837
parenteffb30d51711285143658a033cef065886e77b31 (diff)
downloadaur-dabf0412c6d8cb37a4304721d3f57c7f7b44b88f.tar.gz
2021.06.30
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 35 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dda7683eb2a..c29bd42daa05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
-# Generated by mksrcinfo v8
-# Sat Jan 9 21:41:09 UTC 2016
pkgbase = mingw-w64-opencl-headers
- pkgdesc = OpenCL (Open Computing Language) header files (mingw-w64 symlinks)
- pkgver = 2.1.20151224
+ pkgdesc = OpenCL (Open Computing Language) header files (mingw-w64)
+ pkgver = 2021.06.30
pkgrel = 1
- url = http://www.khronos.org/registry/cl/
+ url = https://github.com/KhronosGroup/OpenCL-Headers
arch = any
- license = custom
- depends = opencl-headers
- depends = mingw-w64-crt
+ groups = mingw-w64-vulkan-devel
+ license = APACHE
+ makedepends = mingw-w64-cmake
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ source = https://github.com/KhronosGroup/OpenCL-Headers/archive/v2021.06.30.tar.gz
+ sha256sums = 6640d590c30d90f89351f5e3043ae6363feeb19ac5e64bc35f8cfa1a6cd5498e
pkgname = mingw-w64-opencl-headers
-
diff --git a/PKGBUILD b/PKGBUILD
index a42cd3242303..1005951c9750 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,31 @@
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Contributor: Daniel Kirchner <daniel at ekpyron dot org>
pkgname=mingw-w64-opencl-headers
-pkgver=2.1.20151224
+pkgver=2021.06.30
pkgrel=1
-pkgdesc="OpenCL (Open Computing Language) header files (mingw-w64 symlinks)"
-arch=('any')
-license=('custom')
-url='http://www.khronos.org/registry/cl/'
-depends=('opencl-headers' 'mingw-w64-crt')
+pkgdesc="OpenCL (Open Computing Language) header files (mingw-w64)"
+arch=(any)
+url="https://github.com/KhronosGroup/OpenCL-Headers"
+groups=("mingw-w64-vulkan-devel")
+license=('APACHE')
+makedepends=(mingw-w64-cmake)
+options=(!buildflags staticlibs !strip)
+source=("https://github.com/KhronosGroup/OpenCL-Headers/archive/v${pkgver}.tar.gz")
+sha256sums=('6640d590c30d90f89351f5e3043ae6363feeb19ac5e64bc35f8cfa1a6cd5498e')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+build() {
+ cd "${srcdir}/OpenCL-Headers-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DBUILD_TESTING=OFF ..
+ make
+ popd
+ done
+}
+
package() {
- for _arch in ${_architectures}; do
- mkdir -p "${pkgdir}/usr/${_arch}/include"
- ln -s ../../../usr/include/CL "${pkgdir}/usr/${_arch}/include"
- done
+ for _arch in ${_architectures}; do
+ cd "${srcdir}"/OpenCL-Headers-${pkgver}/build-${_arch}
+ make DESTDIR="${pkgdir}" install
+ done
}