summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-09-24 13:12:24 -0400
committerPatrick Northon2021-09-24 13:12:24 -0400
commitdc37c638becb63f724ae8aac76586428efd11253 (patch)
treed45ef3e059a3c63a848ac81e0dbbbc0971812ae3
parente04d838e882e591853dcf511458298776b27984c (diff)
downloadaur-dc37c638becb63f724ae8aac76586428efd11253.tar.gz
Update version and add static build.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD65
-rw-r--r--fix.patch215
-rw-r--r--opencolorio-openexr3.patch182
4 files changed, 44 insertions, 429 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2d687e6b509..246cc0ef7b78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-opencolorio
pkgdesc = A color management framework for visual effects and animation (mingw-w64)
- pkgver = 2.0.1
+ pkgver = 2.1.0
pkgrel = 1
url = https://opencolorio.org/
arch = any
@@ -12,14 +12,11 @@ pkgbase = mingw-w64-opencolorio
depends = mingw-w64-lcms2
depends = mingw-w64-freeglut
depends = mingw-w64-glew
- depends = mingw-w64-openexr
+ depends = mingw-w64-imath
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/AcademySoftwareFoundation/OpenColorIO/archive/v2.0.1.tar.gz
- source = opencolorio-openexr3.patch
- sha256sums = ff1397b4516fdecd75096d5b575d6a23771d0c876bbcfc7beb5a82af37adcdf9
- sha256sums = 1b857e43fb4e3c048a88a00c379d1fd61c557a24a3f6a7d475daf588af8ea064
+ source = mingw-w64-opencolorio-2.1.0.tar.gz::https://github.com/AcademySoftwareFoundation/OpenColorIO/archive/v2.1.0.tar.gz
+ sha256sums = 81fc7853a490031632a69c73716bc6ac271b395e2ba0e2587af9995c2b0efb5f
pkgname = mingw-w64-opencolorio
-
diff --git a/PKGBUILD b/PKGBUILD
index 8bd4575bccb1..e601e3048ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=mingw-w64-opencolorio
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=1
-pkgdesc="A color management framework for visual effects and animation (mingw-w64)"
+pkgdesc='A color management framework for visual effects and animation (mingw-w64)'
arch=(any)
-url="https://opencolorio.org/"
-license=("BSD-3-Clause")
+url='https://opencolorio.org/'
+license=('BSD-3-Clause')
makedepends=('mingw-w64-cmake' 'git')
depends=(
'mingw-w64-crt'
@@ -14,45 +14,60 @@ depends=(
'mingw-w64-lcms2'
'mingw-w64-freeglut'
'mingw-w64-glew'
- 'mingw-w64-openexr')
+ 'mingw-w64-imath')
options=('!strip' '!buildflags' 'staticlibs')
-_repo="OpenColorIO"
+_repo='OpenColorIO'
source=(
- "https://github.com/AcademySoftwareFoundation/${_repo}/archive/v${pkgver}.tar.gz"
- "opencolorio-openexr3.patch"
+ "$pkgname-$pkgver.tar.gz::https://github.com/AcademySoftwareFoundation/${_repo}/archive/v${pkgver}.tar.gz"
)
sha256sums=(
- 'ff1397b4516fdecd75096d5b575d6a23771d0c876bbcfc7beb5a82af37adcdf9'
- '1b857e43fb4e3c048a88a00c379d1fd61c557a24a3f6a7d475daf588af8ea064'
+ '81fc7853a490031632a69c73716bc6ac271b395e2ba0e2587af9995c2b0efb5f'
)
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-_dir="${_repo}-${pkgver}"
-
+_srcdir="${_repo}-${pkgver}"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DOCIO_BUILD_APPS=OFF -DOCIO_USE_SSE=ON -DOCIO_BUILD_PYTHON=OFF
+ -DCMAKE_VISIBILITY_INLINES_HIDDEN=ON -DCMAKE_CXX_VISIBILITY_PRESET=hidden
+ -DCMAKE_CXX_STANDARD=17 -DOCIO_INSTALL_EXT_PACKAGES=NONE
+ -DCMAKE_CXX_FLAGS_RELEASE='-O2 -DNDEBUG -msse4.2' )
+
prepare() {
- cd "${_dir}"
- patch -p1 < "${srcdir}/opencolorio-openexr3.patch"
- sed -i -r "s/if\(Half_FOUND\)/if\(TARGET IlmBase::Half\)/" "share/cmake/modules/FindHalf.cmake"
- sed -i -r "s/if\(NOT WIN32\)/if\(NOT WIN32 OR MINGW\)/" "src/OpenColorIO/CMakeLists.txt"
- sed -i -r "s/if\(WIN32\)/if\(WIN32 AND NOT MINGW\)/" "src/OpenColorIO/CMakeLists.txt"
- for f in $(find "src/" -type f -name "*.cpp" -o -type f -name "*.h"); do sed -i -r 's/<Windows.h>/<windows.h>/' "$f"; done
+ cd "${_srcdir}"
+ sed -i -r 's/if\(NOT WIN32\)/if\(NOT WIN32 OR MINGW\)/' 'src/OpenColorIO/CMakeLists.txt'
+ sed -i -r 's/if\(WIN32\)/if\(WIN32 AND NOT MINGW\)/' 'src/OpenColorIO/CMakeLists.txt'
+ sed -i -r 's/\$\{OCIO_LIBNAME_SUFFIX\}_\$\{OpenColorIO_VERSION_MAJOR\}_\$\{OpenColorIO_VERSION_MINOR\}/${OCIO_LIBNAME_SUFFIX}/' 'src/OpenColorIO/CMakeLists.txt'
+ sed -i -r 's/add_test\(test_utils_exec test_utils_exec\)/add_test\(NAME test_utils_exec COMMAND test_utils_exec\)/' 'tests/utils/CMakeLists.txt'
+ sed -i -r 's/add_test\(\$\{TEST_NAME\} \$\{TEST_BINARY\}\)/add_test(NAME ${TEST_NAME} COMMAND ${TEST_BINARY})/' 'tests/cpu/CMakeLists.txt'
+ sed -i -r "s/filename = tmpFilename;/filename = tmpFilename[0] == '\\\\\\\\' ? tmpFilename + 1 : tmpFilename;/" 'src/OpenColorIO/Platform.cpp'
}
-build() {
- _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DOCIO_BUILD_APPS=OFF -DOCIO_USE_SSE=ON -DOCIO_BUILD_PYTHON=OFF
- -DCMAKE_VISIBILITY_INLINES_HIDDEN=ON -DCMAKE_CXX_VISIBILITY_PRESET=hidden -DCMAKE_CXX_STANDARD=17 -DOCIO_INLINES_HIDDEN=ON
- -DOCIO_INLINES_HIDDEN=ON -DOCIO_BUILD_TESTS=OFF -DOCIO_BUILD_GPU_TESTS=OFF -DOCIO_INSTALL_EXT_PACKAGES=NONE
- -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG -msse4.2" )
+build() {
+ for _arch in ${_architectures}; do
+ ${_arch}-cmake -S "${_srcdir}" -B "build-${_arch}-static" "${_flags[@]}" -DOCIO_BUILD_TESTS=OFF -DOCIO_BUILD_GPU_TESTS=OFF \
+ -DBUILD_SHARED_LIBS=OFF -DCMAKE_INSTALL_PREFIX="/usr/${_arch}/static"
+ cmake --build "build-${_arch}-static"
+ ${_arch}-cmake -S "${_srcdir}" -B "build-${_arch}" "${_flags[@]}" -DOCIO_BUILD_TESTS=OFF -DOCIO_BUILD_GPU_TESTS=OFF
+ cmake --build "build-${_arch}"
+ done
+}
+
+check() {
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "${_dir}" -B "build-${_arch}" "${_flags[@]}"
+ ${_arch}-cmake -S "${_srcdir}" -B "build-${_arch}" "${_flags[@]}" -DOCIO_BUILD_TESTS=ON -DOCIO_BUILD_GPU_TESTS=OFF
cmake --build "build-${_arch}"
+ cmake --build "build-${_arch}" --target test
done
}
package() {
for _arch in ${_architectures}; do
+ DESTDIR="${pkgdir}" cmake --install "build-${_arch}-static"
+ rm -rf "$pkgdir"/usr/${_arch}/static/share
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/static/lib/*.a
+
DESTDIR="${pkgdir}" cmake --install "build-${_arch}"
+ rm -rf "$pkgdir"/usr/${_arch}/share
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
diff --git a/fix.patch b/fix.patch
deleted file mode 100644
index 5df9f41d6b2a..000000000000
--- a/fix.patch
+++ /dev/null
@@ -1,215 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e4f3119..cdbed74 100755
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -36,11 +36,9 @@ option(OCIO_PYGLUE_RESPECT_ABI "If ON, the Python module install path includes P
- option(OCIO_PYGLUE_SONAME "If ON, soname/soversion will be set for Python module library" OFF)
- option(OCIO_PYGLUE_LIB_PREFIX "If ON, prefix the Python module with 'lib'" OFF)
-
--if(UNIX AND NOT APPLE)
-- option(USE_EXTERNAL_YAML "Use system installed yaml-cpp library." OFF)
-- option(USE_EXTERNAL_TINYXML "Use system installed tinyxml library." OFF)
-- option(USE_EXTERNAL_LCMS "Use system install lcms2 library." OFF)
--endif()
-+option(USE_EXTERNAL_YAML "Use system installed yaml-cpp library." OFF)
-+option(USE_EXTERNAL_TINYXML "Use system installed tinyxml library." OFF)
-+option(USE_EXTERNAL_LCMS "Use system install lcms2 library." OFF)
-
- # This does not include the SOVERSION override, on purpose, so that the
- # OCIO_VERSION value will be an accurate reflection of the underlying library version.
-@@ -231,7 +229,7 @@ else(USE_EXTERNAL_TINYXML)
- INSTALL_DIR ext/dist
- CMAKE_ARGS ${TINYXML_CMAKE_ARGS}
- )
-- if(WIN32)
-+ if(OFF)
- set(TINYXML_STATIC_LIBRARIES ${PROJECT_BINARY_DIR}/ext/dist/lib/tinyxml.lib)
- else()
- set(TINYXML_STATIC_LIBRARIES ${PROJECT_BINARY_DIR}/ext/dist/lib/libtinyxml.a)
-@@ -251,48 +249,9 @@ endif(USE_EXTERNAL_TINYXML)
- if(USE_EXTERNAL_YAML)
- # Set minimum yaml version for non-patched sources.
- set(YAML_VERSION_MIN "0.3.0")
-- include(FindPkgConfig)
-- pkg_check_modules(PC_YAML_CPP REQUIRED QUIET yaml-cpp)
-- find_path(YAML_CPP_INCLUDE_DIR yaml-cpp/yaml.h
-- HINTS ${PC_YAML_CPP_INCLUDEDIR} ${PC_YAML_CPP_INCLUDE_DIRS} )
-- find_library(YAML_CPP_LIBRARY LIBRARY_NAMES yaml-cpp libyaml-cpp
-- HINTS ${PC_YAML_CPP_LIBRARY_DIRS} )
-- set(YAML_CPP_LIBRARIES ${YAML_CPP_LIBRARY})
-- set(YAML_CPP_INCLUDE_DIRS ${YAML_CPP_INCLUDE_DIR})
-- set(YAML_CPP_VERSION ${PC_YAML_CPP_VERSION})
--
-- if(YAML_CPP_VERSION VERSION_LESS ${YAML_VERSION_MIN})
-- message(FATAL_ERROR "ERROR: yaml-cpp ${YAML_VERSION_MIN} or greater is required.")
-- endif()
--
-- find_package_handle_standard_args(yaml-cpp
-- REQUIRED_VARS YAML_CPP_LIBRARIES YAML_CPP_INCLUDE_DIRS )
-- set(YAML_CPP_FOUND ${YAML-CPP_FOUND})
-- mark_as_advanced(YAML_CPP_INCLUDE_DIR YAML_CPP_LIBRARY YAML-CPP_FOUND)
--
-- if(YAML_CPP_FOUND)
-- if(YAML_CPP_VERSION VERSION_GREATER "0.5.0")
-- # Need to also get the boost headers here, as yaml-cpp 0.5.0+ requires them.
-- # Don't bother doing this step if we are already including the boost headers for shared_ptr
-- if(NOT OCIO_USE_BOOST_PTR)
-- set(Boost_ADDITIONAL_VERSIONS "1.49" "1.45" "1.44" "1.43" "1.43.0" "1.42"
-- "1.42.0" "1.41" "1.41.0" "1.40"
-- "1.40.0" "1.39" "1.39.0" "1.38"
-- "1.38.0" "1.37" "1.37.0" "1.34.1"
-- "1_34_1")
-- set(Boost_USE_MULTITHREADED ON)
-- find_package(Boost 1.34)
-- if(NOT Boost_FOUND)
-- message(FATAL_ERROR "Error: Detected system yaml-cpp version ${YAML_CPP_VERSION} is greater than 0.5.0, and therefore requires boost, but a boost installation could not be found.")
-- endif()
--
-- set(EXTERNAL_INCLUDE_DIRS ${EXTERNAL_INCLUDE_DIRS} ${Boost_INCLUDE_DIR})
-- endif()
-- endif()
-- set(EXTERNAL_INCLUDE_DIRS ${EXTERNAL_INCLUDE_DIRS} ${YAML_CPP_INCLUDE_DIRS})
-- else(YAML_CPP_FOUND)
-- message(FATAL_ERROR "ERROR: System yaml-cpp library was not found. Make sure the library is installed and the pkg-config file exists.")
-- endif(YAML_CPP_FOUND)
-+
-+ find_package(yaml-cpp ${YAML_VERSION_MIN} REQUIRED)
-+
- else(USE_EXTERNAL_YAML) ## provide 2 ways to build this dependency
- set(YAML_CPP_VERSION 0.3.0)
- set(YAML_CPP_CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${PROJECT_BINARY_DIR}/ext/dist -DYAML_CPP_BUILD_TOOLS:BOOL=FALSE -DOCIO_INLINES_HIDDEN:BOOL=${OCIO_INLINES_HIDDEN})
-@@ -348,7 +307,7 @@ else(USE_EXTERNAL_YAML) ## provide 2 ways to build this dependency
- set(YAML_CPP_INCLUDE_DIRS ${PROJECT_BINARY_DIR}/ext/dist/include)
- set(YAML_CPP_LIBRARY_DIRS ${PROJECT_BINARY_DIR}/ext/dist/lib)
- add_library(YAML_CPP_LIB STATIC IMPORTED)
-- if(WIN32)
-+ if(OFF)
- set(YAML_CPP_STATIC_DEBUG_LIBRARIES ${PROJECT_BINARY_DIR}/ext/dist/lib/libyaml-cppmdd.lib)
- set(YAML_CPP_STATIC_OPTIMIZED_LIBRARIES ${PROJECT_BINARY_DIR}/ext/dist/lib/libyaml-cppmd.lib)
- set_property(TARGET YAML_CPP_LIB PROPERTY IMPORTED_LOCATION_DEBUG ${YAML_CPP_STATIC_DEBUG_LIBRARIES})
-@@ -384,7 +343,7 @@ else()
- set(OCIO_INLINES_HIDDEN OFF)
- endif()
-
--set(EXTERNAL_COMPILE_FLAGS "-DTIXML_USE_STL ${YAML_CPP_COMPILE_FLAGS} ${GCC_COMPILE_FLAGS}")
-+set(EXTERNAL_COMPILE_FLAGS "-DTIXML_USE_STL ${GCC_COMPILE_FLAGS}")
-
- set(EXTERNAL_LINK_FLAGS "")
- set(EXTERNAL_LIBRARY_DIRS ${PROJECT_BINARY_DIR}/ext/dist/lib)
-@@ -415,7 +374,7 @@ endif()
- messageonce("SSE Optimizations: ${OCIO_USE_SSE}")
-
- if(OCIO_USE_SSE)
-- if(WIN32)
-+ if(OFF)
- # SSE instructions are automatically compiled into 64-bit applications so enabling the option is redundant and
- # actually produces an unknown option warning in Visual Studio.
- if(NOT CMAKE_CL_64)
-@@ -602,13 +561,13 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
- get_filename_component(OpenColorIO_DIR \"\${CMAKE_CURRENT_LIST_FILE}\" PATH)
-
- ## include
-- set(OpenColorIO_INCLUDE_DIR \"\${OpenColorIO_DIR}/include\")
-+ set(OpenColorIO_INCLUDE_DIR \"\${OpenColorIO_DIR}/../include\")
- set(OpenColorIO_INCLUDE_DIRS \"\${OpenColorIO_INCLUDE_DIR}\")
- message(STATUS OpenColorIO_INCLUDE_DIRS=\${OpenColorIO_INCLUDE_DIRS})
-
- ## targets libraries + associated definitions
- if(NOT TARGET OpenColorIO)
-- include(\"\${OpenColorIO_DIR}/cmake/OpenColorIO.cmake\") ## thanks to imported target
-+ include(\"\${OpenColorIO_DIR}/OpenColorIO.cmake\") ## thanks to imported target
- if(TARGET OpenColorIO AND NOT OpenColorIO_USE_STATIC)
- message(STATUS \"shared target OpenColorIO : see OpenColorIO_LIBRARY\")
- set(OpenColorIO_LIBRARY OpenColorIO)
-@@ -646,4 +605,4 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
- message(STATUS OPENCOLORIO_FOUND=\${OPENCOLORIO_FOUND})
- "
- )
--install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION .)
-+install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION "cmake/")
-diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
-index 1eb691b..b1d65cd 100755
---- a/src/core/CMakeLists.txt
-+++ b/src/core/CMakeLists.txt
-@@ -18,13 +18,13 @@ list(APPEND core_export_headers ${CMAKE_BINARY_DIR}/export/OpenColorABI.h)
-
- # Process all warnings as errors
-
--if(WIN32)
-+if(OFF)
- # On debug mode there are other kinds of warning...
- if("${CMAKE_BUILD_TYPE}" STREQUAL "Release")
- set(EXTERNAL_COMPILE_FLAGS "${EXTERNAL_COMPILE_FLAGS} /WX")
- endif()
- else()
-- set(EXTERNAL_COMPILE_FLAGS "${EXTERNAL_COMPILE_FLAGS} -Werror")
-+ set(EXTERNAL_COMPILE_FLAGS "${EXTERNAL_COMPILE_FLAGS} ")
- endif()
-
- # SHARED
-@@ -39,7 +39,7 @@ if(OCIO_BUILD_SHARED)
- endif(USE_EXTERNAL_TINYXML)
-
- if(USE_EXTERNAL_YAML)
-- target_link_libraries(OpenColorIO ${YAML_CPP_LIBRARIES})
-+ target_link_libraries(OpenColorIO yaml-cpp)
- else(USE_EXTERNAL_YAML)
- add_dependencies(OpenColorIO YAML_CPP_LIB)
- endif()
-@@ -48,7 +48,7 @@ if(OCIO_BUILD_SHARED)
- target_link_libraries(OpenColorIO ${EXTERNAL_LIBRARIES})
- endif()
-
-- if(WIN32)
-+ if(OFF)
- # Mute a design issue where the Exception public class inherits
- # from a STL Exception. STL classes are never supposed to
- # be exported among different dynamic libraries.
-@@ -66,9 +66,9 @@ if(OCIO_BUILD_SHARED)
- SOVERSION ${SOVERSION})
-
- install(TARGETS OpenColorIO EXPORT OpenColorIO
-- ARCHIVE DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/lib${LIB_SUFFIX}
-- LIBRARY DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/lib${LIB_SUFFIX}
-- RUNTIME DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin
-+ ARCHIVE DESTINATION
-+ LIBRARY DESTINATION
-+ RUNTIME DESTINATION
- )
- endif()
-
-@@ -94,7 +94,7 @@ if(OCIO_BUILD_STATIC)
- VERSION ${OCIO_VERSION}
- SOVERSION ${SOVERSION})
-
-- install(TARGETS OpenColorIO_STATIC EXPORT OpenColorIO ARCHIVE DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/lib/static)
-+ install(TARGETS OpenColorIO_STATIC EXPORT OpenColorIO ARCHIVE)
- endif()
-
- macro(target_link_OCIO target)
-diff --git a/src/core/Platform.cpp b/src/core/Platform.cpp
-index f4681fe..3889dfb 100755
---- a/src/core/Platform.cpp
-+++ b/src/core/Platform.cpp
-@@ -18,7 +18,7 @@ OCIO_NAMESPACE_ENTER
- //
- void getenv (const char* name, std::string& value)
- {
--#ifdef WINDOWS
-+#if 0
- // To remove the security compilation warning, the _dupenv_s method
- // must be used (instead of the getenv). The improvement is that
- // the buffer length is now under control to mitigate buffer overflow attacks.
-diff --git a/src/core/Platform.h b/src/core/Platform.h
-index c1796e8..15500f5 100755
---- a/src/core/Platform.h
-+++ b/src/core/Platform.h
-@@ -75,7 +75,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
- #define NOMINMAX 1
-
- // windows - defined for both Win32 and Win64
--#include <Windows.h>
-+#include <windows.h>
- #include <malloc.h>
- #include <io.h>
- #include <tchar.h>
diff --git a/opencolorio-openexr3.patch b/opencolorio-openexr3.patch
deleted file mode 100644
index 68be44cd0f28..000000000000
--- a/opencolorio-openexr3.patch
+++ /dev/null
@@ -1,182 +0,0 @@
-diff --git a/share/cmake/modules/FindExtPackages.cmake b/share/cmake/modules/FindExtPackages.cmake
-index c98e0af3..5f685935 100644
---- a/share/cmake/modules/FindExtPackages.cmake
-+++ b/share/cmake/modules/FindExtPackages.cmake
-@@ -34,7 +34,7 @@ find_package(yaml-cpp 0.6.3 REQUIRED)
-
- # Half (OpenEXR/IlmBase)
- # https://github.com/openexr/openexr
--find_package(Half 2.4.0 REQUIRED)
-+find_package(Imath 3.0 REQUIRED)
-
- # pystring
- # https://github.com/imageworks/pystring
-diff --git a/src/OpenColorIO/BitDepthUtils.h b/src/OpenColorIO/BitDepthUtils.h
-index a8b3cbd9..bb0163bf 100644
---- a/src/OpenColorIO/BitDepthUtils.h
-+++ b/src/OpenColorIO/BitDepthUtils.h
-@@ -7,7 +7,7 @@
-
- #include <OpenColorIO/OpenColorIO.h>
-
--#include "OpenEXR/half.h"
-+#include "Imath/half.h"
-
-
- namespace OCIO_NAMESPACE
-diff --git a/src/OpenColorIO/CMakeLists.txt b/src/OpenColorIO/CMakeLists.txt
-index 2ce801e6..824f8a98 100755
---- a/src/OpenColorIO/CMakeLists.txt
-+++ b/src/OpenColorIO/CMakeLists.txt
-@@ -207,7 +207,7 @@ target_link_libraries(OpenColorIO
- public_api
- PRIVATE
- expat::expat
-- IlmBase::Half
-+ Imath::Imath
- pystring::pystring
- sampleicc::sampleicc
- utils::strings
-diff --git a/src/OpenColorIO/MathUtils.h b/src/OpenColorIO/MathUtils.h
-index 309c6244..0873d490 100644
---- a/src/OpenColorIO/MathUtils.h
-+++ b/src/OpenColorIO/MathUtils.h
-@@ -9,7 +9,7 @@
-
- #include <OpenColorIO/OpenColorIO.h>
-
--#include "OpenEXR/half.h"
-+#include "Imath/half.h"
-
- namespace OCIO_NAMESPACE
- {
-diff --git a/src/OpenColorIO/ops/range/RangeOp.cpp b/src/OpenColorIO/ops/range/RangeOp.cpp
-index 9ec863e2..444dac75 100644
---- a/src/OpenColorIO/ops/range/RangeOp.cpp
-+++ b/src/OpenColorIO/ops/range/RangeOp.cpp
-@@ -7,7 +7,7 @@
- #include <OpenColorIO/OpenColorIO.h>
-
- #include "GpuShaderUtils.h"
--#include "OpenEXR/half.h"
-+#include "Imath/half.h"
- #include "HashUtils.h"
- #include "MathUtils.h"
- #include "ops/lut1d/Lut1DOpData.h"
-diff --git a/src/OpenColorIO/transforms/builtins/ACES.cpp b/src/OpenColorIO/transforms/builtins/ACES.cpp
-index 20968c0d..9ee2ac27 100644
---- a/src/OpenColorIO/transforms/builtins/ACES.cpp
-+++ b/src/OpenColorIO/transforms/builtins/ACES.cpp
-@@ -6,7 +6,7 @@
-
- #include <OpenColorIO/OpenColorIO.h>
-
--#include "OpenEXR/half.h"
-+#include "Imath/half.h"
- #include "ops/fixedfunction/FixedFunctionOp.h"
- #include "ops/gradingrgbcurve/GradingRGBCurveOp.h"
- #include "ops/log/LogOp.h"
-diff --git a/src/OpenColorIO/transforms/builtins/OpHelpers.cpp b/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
-index 04b8fbd4..288ca566 100644
---- a/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
-+++ b/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
-@@ -4,7 +4,7 @@
-
- #include <OpenColorIO/OpenColorIO.h>
-
--#include "OpenEXR/half.h"
-+#include "Imath/half.h"
- #include "ops/lut1d/Lut1DOp.h"
- #include "transforms/builtins/OpHelpers.h"
-
-diff --git a/src/apps/ocioconvert/CMakeLists.txt b/src/apps/ocioconvert/CMakeLists.txt
-index 68a5db17..6fea394a 100755
---- a/src/apps/ocioconvert/CMakeLists.txt
-+++ b/src/apps/ocioconvert/CMakeLists.txt
-@@ -27,7 +27,7 @@ set_target_properties(ocioconvert PROPERTIES
- target_link_libraries(ocioconvert
- PRIVATE
- apputils
-- IlmBase::Half
-+ Imath::Imath
- ${OCIO_GL_LIB}
- oiiohelpers
- OpenColorIO
-diff --git a/src/apps/ocioconvert/main.cpp b/src/apps/ocioconvert/main.cpp
-index b56d4999..7e8af7d0 100644
---- a/src/apps/ocioconvert/main.cpp
-+++ b/src/apps/ocioconvert/main.cpp
-@@ -24,7 +24,7 @@ namespace OIIO = OIIO_NAMESPACE;
- #endif // OCIO_GPU_ENABLED
-
- #include "oiiohelpers.h"
--#include "OpenEXR/half.h"
-+#include "Imath/half.h"
-
-
- // Array of non OpenColorIO arguments.
-diff --git a/src/apps/ocioperf/CMakeLists.txt b/src/apps/ocioperf/CMakeLists.txt
-index 69e9ba4c..bcbe47be 100644
---- a/src/apps/ocioperf/CMakeLists.txt
-+++ b/src/apps/ocioperf/CMakeLists.txt
-@@ -20,7 +20,7 @@ set_target_properties(ocioperf PROPERTIES
- target_link_libraries(ocioperf
- PRIVATE
- apputils
-- IlmBase::Half
-+ Imath::Imath
- oiiohelpers
- OpenColorIO
- OpenImageIO::OpenImageIO
-diff --git a/src/apps/ocioperf/main.cpp b/src/apps/ocioperf/main.cpp
-index 6427860d..f6e4a63c 100644
---- a/src/apps/ocioperf/main.cpp
-+++ b/src/apps/ocioperf/main.cpp
-@@ -11,7 +11,7 @@ namespace OIIO = OIIO_NAMESPACE;
- #endif
-
- #include "apputils/argparse.h"
--#include "OpenEXR/half.h"
-+#include "Imath/half.h"
- #include "oiiohelpers.h"
- #include "utils/StringUtils.h"
-
-diff --git a/src/libutils/oiiohelpers/CMakeLists.txt b/src/libutils/oiiohelpers/CMakeLists.txt
-index 6ef7c368..5f4a5113 100644
---- a/src/libutils/oiiohelpers/CMakeLists.txt
-+++ b/src/libutils/oiiohelpers/CMakeLists.txt
-@@ -31,7 +31,7 @@ target_link_libraries(oiiohelpers
-
- PRIVATE
- OpenColorIO
-- IlmBase::Half
-+ Imath::Imath
- utils::strings
- )
-
-diff --git a/src/libutils/oiiohelpers/oiiohelpers.cpp b/src/libutils/oiiohelpers/oiiohelpers.cpp
-index be1a937d..e7db652c 100644
---- a/src/libutils/oiiohelpers/oiiohelpers.cpp
-+++ b/src/libutils/oiiohelpers/oiiohelpers.cpp
-@@ -5,7 +5,7 @@
- #include <OpenColorIO/OpenColorIO.h>
-
-
--#include "OpenEXR/half.h"
-+#include "Imath/half.h"
- #include "oiiohelpers.h"
- #include "utils/StringUtils.h"
-
-diff --git a/tests/cpu/CMakeLists.txt b/tests/cpu/CMakeLists.txt
-index 67389962..8e8dd900 100755
---- a/tests/cpu/CMakeLists.txt
-+++ b/tests/cpu/CMakeLists.txt
-@@ -18,7 +18,7 @@ function(add_ocio_test NAME SOURCES PRIVATE_INCLUDES)
- public_api
- PRIVATE
- expat::expat
-- IlmBase::Half
-+ Imath::Imath
- pystring::pystring
- sampleicc::sampleicc
- unittest_data