summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-05-21 12:21:44 -0400
committerPatrick Northon2020-05-21 12:21:44 -0400
commit0d919ccff4b402bef18ed4f965801cf2dec79b07 (patch)
tree1c96ca789ae9134d5a24495a26de2098dea252b3
parentf4f8682459716d1616157538ce39463774034eed (diff)
downloadaur-0d919ccff4b402bef18ed4f965801cf2dec79b07.tar.gz
Update to version 2.5.1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD49
-rw-r--r--openexr-2.1.0_aligned-malloc.patch20
-rw-r--r--openexr-2.1.0_cast.patch12
5 files changed, 15 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 370bd4565b84..672b6fdcb969 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Jun 11 18:01:02 UTC 2018
pkgbase = mingw-w64-openexr
pkgdesc = An high dynamic-range image file format library (mingw-w64)
- pkgver = 2.2.1
+ pkgver = 2.5.1
pkgrel = 1
url = http://www.openexr.com/
arch = any
@@ -11,16 +9,11 @@ pkgbase = mingw-w64-openexr
makedepends = wine
depends = mingw-w64-crt
depends = mingw-w64-zlib
- depends = mingw-w64-ilmbase
options = staticlibs
options = !buildflags
options = !strip
- source = http://download.savannah.gnu.org/releases/openexr/openexr-2.2.1.tar.gz
- source = openexr-2.1.0_aligned-malloc.patch
- source = openexr-2.1.0_cast.patch
- sha256sums = 8f9a5af6131583404261931d9a5c83de0a425cb4b8b25ddab2b169fbf113aecd
- sha256sums = SKIP
- sha256sums = SKIP
+ source = https://github.com/AcademySoftwareFoundation/openexr/archive/v2.5.1.tar.gz
+ sha256sums = 11f806bf256453e39fc33bd1cf1fa576a54f144cedcdd3e6935a177e5a89d02e
pkgname = mingw-w64-openexr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index c7c318e8f56e..f9b8f53b8a94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,31 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=mingw-w64-openexr
-pkgver=2.2.1
+pkgver=2.5.1
pkgrel=1
pkgdesc="An high dynamic-range image file format library (mingw-w64)"
url="http://www.openexr.com/"
arch=(any)
license=('BSD')
-depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-ilmbase')
+depends=('mingw-w64-crt' 'mingw-w64-zlib')
makedepends=('mingw-w64-cmake' 'wine')
options=('staticlibs' '!buildflags' '!strip')
-source=("http://download.savannah.gnu.org/releases/openexr/openexr-${pkgver}.tar.gz"
- openexr-2.1.0_aligned-malloc.patch
- openexr-2.1.0_cast.patch)
-sha256sums=('8f9a5af6131583404261931d9a5c83de0a425cb4b8b25ddab2b169fbf113aecd'
- SKIP
- SKIP)
+source=("https://github.com/AcademySoftwareFoundation/openexr/archive/v${pkgver}.tar.gz")
+sha256sums=('11f806bf256453e39fc33bd1cf1fa576a54f144cedcdd3e6935a177e5a89d02e')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "${srcdir}/openexr-${pkgver}"
- # fedora patches
- patch -p1 -i "${srcdir}"/openexr-2.1.0_aligned-malloc.patch
- patch -p1 -i "${srcdir}"/openexr-2.1.0_cast.patch
-
- # https://github.com/openexr/openexr/pull/159
- sed -i "s|COMMAND \${CMAKE_CURRENT_BINARY_DIR}/\${CMAKE_CFG_INTDIR}/b44ExpLogTable >|COMMAND wine \${CMAKE_CURRENT_BINARY_DIR}/\${CMAKE_CFG_INTDIR}/b44ExpLogTable.exe >|g" IlmImf/CMakeLists.txt
- sed -i "s|COMMAND \${CMAKE_CURRENT_BINARY_DIR}/\${CMAKE_CFG_INTDIR}/dwaLookups >|COMMAND wine \${CMAKE_CURRENT_BINARY_DIR}/\${CMAKE_CFG_INTDIR}/dwaLookups.exe >|g" IlmImf/CMakeLists.txt
-
-
- sed -i "/ADD_SUBDIRECTORY ( IlmImfTest )/d" CMakeLists.txt
- sed -i "/ADD_SUBDIRECTORY ( IlmImfUtilTest )/d" CMakeLists.txt
- sed -i "/ADD_SUBDIRECTORY ( IlmImfFuzzTest )/d" CMakeLists.txt
- sed -i "/ADD_SUBDIRECTORY ( exr/d" CMakeLists.txt # binaries/utilities
-}
-
build() {
- cd "${srcdir}/openexr-${pkgver}"
- for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DNAMESPACE_VERSIONING=OFF -DILMBASE_PACKAGE_PREFIX=/usr/${_arch} ..
- cp /usr/${_arch}/bin/*.dll IlmImf
- make
- popd
- done
+ for _arch in ${_architectures}; do
+ ${_arch}-cmake -S openexr-${pkgver} -B build-${_arch} -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTING=OFF -DINSTALL_OPENEXR_DOCS=OFF -DINSTALL_OPENEXR_EXAMPLES=OFF -DOPENEXR_BUILD_UTILS=OFF
+ make -C build-${_arch}
+ done
}
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/openexr-${pkgver}/build-${_arch}"
- make DESTDIR="${pkgdir}" install
- install -d "$pkgdir"/usr/${_arch}/bin
- mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin
- rm -r "$pkgdir"/usr/${_arch}/share
+ make DESTDIR="${pkgdir}" -C build-${_arch} install
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
diff --git a/openexr-2.1.0_aligned-malloc.patch b/openexr-2.1.0_aligned-malloc.patch
deleted file mode 100644
index 8108ae63c832..000000000000
--- a/openexr-2.1.0_aligned-malloc.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- openexr-2.2.0/IlmImf/ImfSystemSpecific.h 2014-08-10 07:23:57.000000000 +0300
-+++ openexr-2.2.0/IlmImf/ImfSystemSpecific.h 2017-05-24 22:28:12.713121986 +0300
-@@ -62,15 +62,14 @@
-
- static void* EXRAllocAligned(size_t size, size_t alignment)
- {
-- void* ptr = 0;
-- posix_memalign(&ptr, alignment, size);
-+ void* ptr = _aligned_malloc(size, alignment);
- return ptr;
- }
-
-
- static void EXRFreeAligned(void* ptr)
- {
-- free(ptr);
-+ _aligned_free(ptr);
- }
-
- #elif defined _MSC_VER
diff --git a/openexr-2.1.0_cast.patch b/openexr-2.1.0_cast.patch
deleted file mode 100644
index f68f93150d9d..000000000000
--- a/openexr-2.1.0_cast.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rupN openexr-2.1.0/IlmImf/ImfOptimizedPixelReading.h openexr-2.1.0-new/IlmImf/ImfOptimizedPixelReading.h
---- openexr-2.1.0/IlmImf/ImfOptimizedPixelReading.h 2013-07-29 19:58:48.000000000 +0200
-+++ openexr-2.1.0-new/IlmImf/ImfOptimizedPixelReading.h 2013-12-27 02:04:23.286563455 +0100
-@@ -84,7 +84,7 @@ EXR_FORCEINLINE
- bool
- isPointerSSEAligned (const void* EXR_RESTRICT pPointer)
- {
-- unsigned long trailingBits = ((unsigned long)pPointer) & 15;
-+ intptr_t trailingBits = ((intptr_t)pPointer) & 15;
- return trailingBits == 0;
- }
-