summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-05-25 09:11:26 +0200
committerMichel Zou2017-05-25 09:11:26 +0200
commit82658840b6e0311535681603a0fe650c26eddc08 (patch)
tree721fc00cd2e03d010997c01cf8cd63b061553095
parentf92ce281225b9b110bf9d2f77af638cd91617888 (diff)
downloadaur-82658840b6e0311535681603a0fe650c26eddc08.tar.gz
fix align patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--openexr-2.1.0_aligned-malloc.patch17
3 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e728169750e..399a0c13c3c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 29 11:30:59 UTC 2016
+# Thu May 25 07:11:26 UTC 2017
pkgbase = mingw-w64-openexr
pkgdesc = An high dynamic-range image file format library (mingw-w64)
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.openexr.com/
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 1a4451e8587c..b245768c9bde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-openexr
pkgver=2.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="An high dynamic-range image file format library (mingw-w64)"
url="http://www.openexr.com/"
arch=(any)
diff --git a/openexr-2.1.0_aligned-malloc.patch b/openexr-2.1.0_aligned-malloc.patch
index 6dd66f6d5ad7..8108ae63c832 100644
--- a/openexr-2.1.0_aligned-malloc.patch
+++ b/openexr-2.1.0_aligned-malloc.patch
@@ -1,13 +1,20 @@
-diff -rupN openexr-2.1.0/IlmImf/ImfSystemSpecific.h openexr-2.1.0-new/IlmImf/ImfSystemSpecific.h
---- openexr-2.1.0/IlmImf/ImfSystemSpecific.h 2013-10-21 21:02:22.000000000 +0200
-+++ openexr-2.1.0-new/IlmImf/ImfSystemSpecific.h 2013-12-27 01:57:30.936052388 +0100
-@@ -60,8 +60,7 @@ static bool GLOBAL_SYSTEM_LITTLE_ENDIAN
+--- openexr-2.2.0/IlmImf/ImfSystemSpecific.h 2014-08-10 07:23:57.000000000 +0300
++++ openexr-2.2.0/IlmImf/ImfSystemSpecific.h 2017-05-24 22:28:12.713121986 +0300
+@@ -62,15 +62,14 @@
static void* EXRAllocAligned(size_t size, size_t alignment)
{
- void* ptr = 0;
- posix_memalign(&ptr, alignment, size);
-+ void* ptr = _aligned_malloc(alignment, size);
++ void* ptr = _aligned_malloc(size, alignment);
return ptr;
}
+
+ static void EXRFreeAligned(void* ptr)
+ {
+- free(ptr);
++ _aligned_free(ptr);
+ }
+
+ #elif defined _MSC_VER