summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-09-24 11:37:28 -0400
committerPatrick Northon2021-09-24 11:37:28 -0400
commitb86e09e86058b09399e68ae4b561ac9a0b905263 (patch)
treeeef92fae0c2d5c7250212557fa3701fe9807de2d
parent79a5b42b6c2fc99d7115c186f56cd57abb51ef2a (diff)
downloadaur-b86e09e86058b09399e68ae4b561ac9a0b905263.tar.gz
Add static build in static prefix.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
-rw-r--r--keycode.patch11
3 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f6143b31adc..157080f12295 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-openexr
pkgdesc = An high dynamic-range image file format library (mingw-w64)
pkgver = 3.1.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.openexr.com/
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 9077a215e61a..acadcb73732e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
-pkgname=mingw-w64-openexr
+_pkgname=openexr
+pkgname=mingw-w64-${_pkgname}
pkgver=3.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='An high dynamic-range image file format library (mingw-w64)'
url='http://www.openexr.com/'
arch=(any)
@@ -12,7 +13,7 @@ makedepends=('mingw-w64-cmake')
checkdepends=('mingw-w64-wine')
options=('staticlibs' '!buildflags' '!strip')
source=(
- "$pkgname-$pkgver.tar.gz::https://github.com/AcademySoftwareFoundation/openexr/archive/v${pkgver}.tar.gz"
+ "$pkgname-$pkgver.tar.gz::https://github.com/AcademySoftwareFoundation/${_pkgname}/archive/v${pkgver}.tar.gz"
)
sha256sums=(
'045254e201c0f87d1d1a4b2b5815c4ae54845af2e6ec0ab88e979b5fdb30a86e'
@@ -20,12 +21,15 @@ sha256sums=(
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE='-O2 -DNDEBUG -msse4.2' -DCMAKE_C_FLAGS_RELEASE='-O2 -DNDEBUG -msse4.2 -D__USE_MINGW_ANSI_STDIO=1'
- -DOPENEXR_INSTALL_EXAMPLES=OFF -DOPENEXR_INSTALL_TOOLS=ON )
-_srcdir="openexr-${pkgver}"
+ -DOPENEXR_INSTALL_EXAMPLES=OFF -DOPENEXR_LIB_SUFFIX= )
+_srcdir="${_pkgname}-${pkgver}"
build() {
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "${_srcdir}" -B "build-${_arch}" "${_flags[@]}" -DBUILD_TESTING=OFF
+ ${_arch}-cmake -S "${_srcdir}" -B "build-${_arch}-static" "${_flags[@]}" -DDOPENEXR_INSTALL_TOOLS=OFF -DOPENEXR_BUILD_TOOLS=OFF -DBUILD_TESTING=OFF -DBUILD_SHARED_LIBS=OFF -DCMAKE_INSTALL_PREFIX="/usr/${_arch}/static"
+ cmake --build "build-${_arch}-static"
+
+ ${_arch}-cmake -S "${_srcdir}" -B "build-${_arch}" "${_flags[@]}" -DOPENEXR_INSTALL_TOOLS=ON -DOPENEXR_BUILD_TOOLS=ON -DBUILD_TESTING=OFF
cmake --build "build-${_arch}"
done
}
@@ -40,7 +44,11 @@ check() {
package() {
for _arch in ${_architectures}; do
+ DESTDIR="${pkgdir}" cmake --install "build-${_arch}-static"
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/static/lib/*.a
+
DESTDIR="${pkgdir}" cmake --install "build-${_arch}"
+ ${_arch}-strip "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
diff --git a/keycode.patch b/keycode.patch
deleted file mode 100644
index 7ec42e25d38a..000000000000
--- a/keycode.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ImfKeyCode.h.orig 2021-06-04 04:20:36.907223980 -0400
-+++ ImfKeyCode.h 2021-06-04 04:20:58.563426122 -0400
-@@ -90,7 +90,7 @@
-
- IMF_EXPORT
- KeyCode (const KeyCode &other);
-- IMF_EXPORT
-+ //IMF_EXPORT
- ~KeyCode() = default;
- IMF_EXPORT
- KeyCode & operator = (const KeyCode &other);