summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-12-29 12:30:59 +0100
committerMichel Zou2016-12-29 12:30:59 +0100
commitf92ce281225b9b110bf9d2f77af638cd91617888 (patch)
tree7aab2134694e72ba924f6de2ce4b83234542c815
parent5ae863a491fd028331c4e073ce9b114137842e7e (diff)
downloadaur-f92ce281225b9b110bf9d2f77af638cd91617888.tar.gz
fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8548ee676174..4e728169750e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jun 19 07:25:17 UTC 2016
+# Thu Dec 29 11:30:59 UTC 2016
pkgbase = mingw-w64-openexr
pkgdesc = An high dynamic-range image file format library (mingw-w64)
pkgver = 2.2.0
@@ -15,7 +15,7 @@ pkgbase = mingw-w64-openexr
options = staticlibs
options = !buildflags
options = !strip
- source = http://download.savannah.nongnu.org/releases/openexr/openexr-2.2.0.tar.gz
+ source = http://download.savannah.gnu.org/releases/openexr/openexr-2.2.0.tar.gz
source = openexr-2.1.0_aligned-malloc.patch
source = openexr-2.1.0_cast.patch
md5sums = b64e931c82aa3790329c21418373db4e
diff --git a/PKGBUILD b/PKGBUILD
index 3bdf1fad6c73..1a4451e8587c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,12 @@ license=('BSD')
depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-ilmbase')
makedepends=('mingw-w64-cmake' 'wine')
options=('staticlibs' '!buildflags' '!strip')
-source=("http://download.savannah.nongnu.org/releases/openexr/openexr-${pkgver}.tar.gz" openexr-2.1.0_aligned-malloc.patch openexr-2.1.0_cast.patch)
-md5sums=('b64e931c82aa3790329c21418373db4e' SKIP SKIP)
+source=("http://download.savannah.gnu.org/releases/openexr/openexr-${pkgver}.tar.gz"
+ openexr-2.1.0_aligned-malloc.patch
+ openexr-2.1.0_cast.patch)
+md5sums=('b64e931c82aa3790329c21418373db4e'
+ SKIP
+ SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -28,6 +32,7 @@ prepare() {
sed -i "/ADD_SUBDIRECTORY ( IlmImfTest )/d" CMakeLists.txt
sed -i "/ADD_SUBDIRECTORY ( IlmImfUtilTest )/d" CMakeLists.txt
sed -i "/ADD_SUBDIRECTORY ( IlmImfFuzzTest )/d" CMakeLists.txt
+ sed -i "/ADD_SUBDIRECTORY ( exr/d" CMakeLists.txt # binaries/utilities
}
build() {
@@ -36,7 +41,7 @@ build() {
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake -DNAMESPACE_VERSIONING=OFF -DILMBASE_PACKAGE_PREFIX=/usr/${_arch} ..
cp /usr/${_arch}/bin/*.dll IlmImf
- make VERBOSE=1
+ make
popd
done
}
@@ -48,7 +53,6 @@ package() {
install -d "$pkgdir"/usr/${_arch}/bin
mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin
rm -r "$pkgdir"/usr/${_arch}/share
- rm "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done