summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-12-06 19:44:09 +0100
committerMichel Zou2020-12-06 19:44:09 +0100
commitf936d00db3099b15c610dbdcf5515220e0a89262 (patch)
tree720dfcb4e1b25fc8cb718591039881d9b444edc6
downloadaur-f936d00db3099b15c610dbdcf5515220e0a89262.tar.gz
1.2.4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cb7a4c77725
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-openimagedenoise
+ pkgdesc = Interl(R) Open Image Denoise library
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://openimagedenoise.github.io
+ arch = any
+ license = Apache
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-tbb
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/OpenImageDenoise/oidn/releases/download/v1.2.4/oidn-1.2.4.src.tar.gz
+ sha256sums = 948b070c780b5de0d983e7d5d37f6d9454932cc278913d9ee5b0bd047d23864a
+
+pkgname = mingw-w64-openimagedenoise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5df797f865a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=mingw-w64-openimagedenoise
+pkgver=1.2.4
+pkgrel=1
+epoch=
+pkgdesc="Interl(R) Open Image Denoise library"
+arch=("any")
+url="https://openimagedenoise.github.io"
+license=('Apache')
+depends=("mingw-w64-tbb")
+makedepends=("mingw-w64-cmake")
+options=('!strip' '!buildflags' 'staticlibs')
+source=("https://github.com/OpenImageDenoise/oidn/releases/download/v${pkgver}/oidn-${pkgver}.src.tar.gz")
+sha256sums=('948b070c780b5de0d983e7d5d37f6d9454932cc278913d9ee5b0bd047d23864a')
+
+_architectures="x86_64-w64-mingw32"
+
+prepare() {
+ cd "oidn-${pkgver}"
+}
+
+build() {
+ cd "oidn-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ MINGW_CPPFLAGS="-D_WIN32_WINNT=0x0600" ${_arch}-cmake -DTBB_ROOT=/usr/${_arch} ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/oidn-${pkgver}/build-${_arch}"
+ make install DESTDIR="${pkgdir}"
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ done
+}