summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-09-19 10:53:39 -0400
committerPatrick Northon2020-09-19 10:53:39 -0400
commit3832549b8baedd2f16ca2e2110fd8b8f9a55a546 (patch)
tree5f77f89a07f6117588c48a541b45815d7a65aebb
parent8f76e1af8806e6936b5a5ab94d5be5575adfac54 (diff)
downloadaur-3832549b8baedd2f16ca2e2110fd8b8f9a55a546.tar.gz
Add libheif support.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9bdf3e114b3..34345161c812 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-openimageio
pkgdesc = A library for reading and writing images (mingw-w64)
pkgver = 2.2.6.1
- pkgrel = 5
+ pkgrel = 6
url = http://www.openimageio.org/
arch = any
license = BSD-3-Clause
@@ -24,6 +24,7 @@ pkgbase = mingw-w64-openimageio
depends = mingw-w64-hdf5
depends = mingw-w64-robinmap
depends = mingw-w64-libraw
+ depends = mingw-w64-libheif
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index c7972c295cfb..817fbebbcc64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-openimageio
pkgver=2.2.6.1
-pkgrel=5
+pkgrel=6
pkgdesc="A library for reading and writing images (mingw-w64)"
url="http://www.openimageio.org/"
license=("BSD-3-Clause")
@@ -25,6 +25,7 @@ depends=(
"mingw-w64-hdf5"
"mingw-w64-robinmap"
"mingw-w64-libraw"
+ "mingw-w64-libheif"
)
makedepends=("mingw-w64-cmake")
arch=("any")
@@ -59,7 +60,7 @@ build() {
-DOIIO_BUILD_TESTS=OFF -DOIIO_BUILD_TOOLS=OFF -DUSE_PYTHON=OFF -DUSE_QT=OFF -DUSE_CCACHE=OFF
-DUSE_SIMD=sse4.2 -DEMBEDPLUGINS=ON -DSTOP_ON_WARNING=OFF -DOPTIONAL_DEPS=""
-DUSE_EMBEDDED_LIBSQUISH=OFF
- -DREQUIRED_DEPS="JPEGTurbo;PNG;TBB;GIF;Webp;Libsquish;Freetype;OpenColorIO;OpenCV;FFmpeg;HDF5;LibRaw" )
+ -DREQUIRED_DEPS="JPEGTurbo;PNG;TBB;GIF;Webp;Libsquish;Freetype;OpenColorIO;OpenCV;FFmpeg;HDF5;LibRaw;Libheif" )
for _arch in ${_architectures}; do
${_arch}-cmake -S "oiio-Release-${pkgver}" -B "build-${_arch}" "${_flags[@]}"