summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-06-04 06:51:25 -0400
committerPatrick Northon2020-06-04 06:51:25 -0400
commit95d6df7cabe00e4c5d49b62f80c4895dc8cf4250 (patch)
treeb7bd338676add58f41b32fa83db69c9931aa8cd0
parent07ff1f7d6042ae122370c4117915ffa226eda1f2 (diff)
downloadaur-95d6df7cabe00e4c5d49b62f80c4895dc8cf4250.tar.gz
Update dependencies.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 504711865190..fc054d960088 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-openimageio
pkgdesc = A library for reading and writing images.
pkgver = 2.1.16.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.openimageio.org/
arch = any
license = BSD-3-Clause
@@ -10,14 +10,12 @@ pkgbase = mingw-w64-openimageio
depends = mingw-w64-libtiff
depends = mingw-w64-libpng
depends = mingw-w64-libjpeg-turbo
- optdepends = mingw-w64-intel-tbb
- optdepends = mingw-w64-giflib
- optdepends = mingw-w64-libwebp
- optdepends = mingw-w64-freetype2: install mingw-w64-freetype2-bootstrap and mingw-w64-cairo-bootstrap first.
- optdepends = mingw-w64-opencolorio
- optdepends = mingw-w64-opencv
- optdepends = mingw-w64-ffmpeg
- optdepends = mingw-w64-libsquish: DDS file support
+ depends = mingw-w64-intel-tbb
+ depends = mingw-w64-giflib
+ depends = mingw-w64-libwebp
+ depends = mingw-w64-libsquish
+ depends = mingw-w64-pugixml
+ depends = mingw-w64-fmt
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index dcc6d5d7bd81..416a3db65ae4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-openimageio
pkgver=2.1.16.0
-pkgrel=1
+pkgrel=2
pkgdesc="A library for reading and writing images."
url="http://www.openimageio.org/"
license=("BSD-3-Clause")
@@ -12,20 +12,17 @@ depends=(
"mingw-w64-libtiff"
"mingw-w64-libpng"
"mingw-w64-libjpeg-turbo"
-)
-builddepends=("mingw-w64-cmake")
-arch=("any")
-options=(!strip !buildflags staticlibs)
-optdepends=(
"mingw-w64-intel-tbb"
"mingw-w64-giflib"
"mingw-w64-libwebp"
- "mingw-w64-freetype2: install mingw-w64-freetype2-bootstrap and mingw-w64-cairo-bootstrap first."
- "mingw-w64-opencolorio"
- "mingw-w64-opencv"
- "mingw-w64-ffmpeg"
- "mingw-w64-libsquish: DDS file support"
+ "mingw-w64-libsquish"
+ "mingw-w64-pugixml"
+ "mingw-w64-fmt"
)
+builddepends=("mingw-w64-cmake" "git")
+arch=("any")
+options=(!strip !buildflags staticlibs)
+optdepends=()
sha256sums=(
"f44e3b3cffe9a8f47395da1ae59e972ecb26adf65f17581e6a489fdcce0cb116"
"87e13ccaf0359ad86713721448f14073d9e4b8904fb1353b259c351482c326a7"
@@ -44,10 +41,11 @@ prepare() {
build() {
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "oiio-Release-${pkgver}" -B "build-${_arch}" -DBUILD_DOCS=OFF -DBUILD_MISSING_FMT=ON \
- -DBUILD_MISSING_ROBINMAP=ON -DBUILD_TESTING=OFF -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_STANDARD=20 \
+ ${_arch}-cmake -S "oiio-Release-${pkgver}" -B "build-${_arch}" -DBUILD_DOCS=OFF -DBUILD_MISSING_FMT=OFF \
+ -DBUILD_MISSING_ROBINMAP=ON -DBUILD_ROBINMAP_FORCE=ON -DUSE_EXTERNAL_PUGIXML=ON -DBUILD_TESTING=OFF -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_STANDARD=20 \
-DINSTALL_DOCS=OFF -DOIIO_BUILD_TESTS=OFF -DOIIO_BUILD_TOOLS=OFF -DUSE_PYTHON=OFF -DUSE_QT=OFF \
- -DUSE_CCACHE=OFF -DUSE_SIMD=sse4.2 -DEMBEDPLUGINS=ON -DSTOP_ON_WARNING=OFF \
+ -DUSE_CCACHE=OFF -DUSE_SIMD=sse4.2 -DEMBEDPLUGINS=ON -DSTOP_ON_WARNING=OFF -DOPTIONAL_DEPS="" \
+ -DREQUIRED_DEPS="JPEGTurbo;PNG;TBB;GIF;Webp;Libsquish" \
-DCMAKE_CXX_FLAGS="-fpermissive"
make -C "build-${_arch}"
done