summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-09-05 16:51:04 -0400
committerPatrick Northon2020-09-05 16:51:04 -0400
commitb948dd8afc919b2a9e2f4bcba7fc82adce9ae0bd (patch)
tree28b2e8fff980db80b8080a646ad406ed230b6613
parentdd78a1033ad856dea969ac85cde24128ce9f6a0a (diff)
downloadaur-b948dd8afc919b2a9e2f4bcba7fc82adce9ae0bd.tar.gz
Add libraw support.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9246919d45de..52f1ce485ab9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-openimageio
pkgdesc = A library for reading and writing images (mingw-w64)
pkgver = 2.2.6.1
- pkgrel = 2
+ pkgrel = 3
url = http://www.openimageio.org/
arch = any
license = BSD-3-Clause
@@ -23,6 +23,7 @@ pkgbase = mingw-w64-openimageio
depends = mingw-w64-ffmpeg
depends = mingw-w64-hdf5
depends = mingw-w64-robinmap
+ depends = mingw-w64-libraw
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 5490b2bd0e3f..915f3448c96e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-openimageio
pkgver=2.2.6.1
-pkgrel=2
+pkgrel=3
pkgdesc="A library for reading and writing images (mingw-w64)"
url="http://www.openimageio.org/"
license=("BSD-3-Clause")
@@ -24,6 +24,7 @@ depends=(
"mingw-w64-ffmpeg"
"mingw-w64-hdf5"
"mingw-w64-robinmap"
+ "mingw-w64-libraw"
)
makedepends=("mingw-w64-cmake")
arch=("any")
@@ -55,7 +56,7 @@ build() {
-DOIIO_BUILD_TESTS=OFF -DOIIO_BUILD_TOOLS=OFF -DUSE_PYTHON=OFF -DUSE_QT=OFF -DUSE_CCACHE=OFF
-DUSE_SIMD=sse4.2 -DEMBEDPLUGINS=ON -DSTOP_ON_WARNING=OFF -DOPTIONAL_DEPS=""
-DUSE_EMBEDDED_LIBSQUISH=OFF
- -DREQUIRED_DEPS="JPEGTurbo;PNG;TBB;GIF;Webp;Libsquish;Freetype;OpenColorIO;OpenCV;FFmpeg;HDF5" )
+ -DREQUIRED_DEPS="JPEGTurbo;PNG;TBB;GIF;Webp;Libsquish;Freetype;OpenColorIO;OpenCV;FFmpeg;HDF5;LibRaw" )
for _arch in ${_architectures}; do
${_arch}-cmake -S "oiio-Release-${pkgver}" -B "build-${_arch}-static" "${_flags[@]}" -DBUILD_SHARED_LIBS=FALSE