summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-09-04 14:23:18 -0400
committerPatrick Northon2020-09-04 14:23:18 -0400
commitdd78a1033ad856dea969ac85cde24128ce9f6a0a (patch)
tree4376c9bd8f6dd8ba6f971c1e5ac0cfe4085178e2
parent1e9197d356658a2ef4857887b37a76edc3105846 (diff)
downloadaur-dd78a1033ad856dea969ac85cde24128ce9f6a0a.tar.gz
Fix makedepends and add robinmap dependency.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f627e562b5f8..9246919d45de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = mingw-w64-openimageio
- pkgdesc = A library for reading and writing images.
+ pkgdesc = A library for reading and writing images (mingw-w64)
pkgver = 2.2.6.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.openimageio.org/
arch = any
license = BSD-3-Clause
+ makedepends = mingw-w64-cmake
depends = mingw-w64-boost
depends = mingw-w64-openexr
depends = mingw-w64-libtiff
@@ -21,6 +22,7 @@ pkgbase = mingw-w64-openimageio
depends = mingw-w64-opencv
depends = mingw-w64-ffmpeg
depends = mingw-w64-hdf5
+ depends = mingw-w64-robinmap
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 4a1da7cdd696..5490b2bd0e3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=mingw-w64-openimageio
pkgver=2.2.6.1
-pkgrel=1
-pkgdesc="A library for reading and writing images."
+pkgrel=2
+pkgdesc="A library for reading and writing images (mingw-w64)"
url="http://www.openimageio.org/"
license=("BSD-3-Clause")
depends=(
@@ -23,8 +23,9 @@ depends=(
"mingw-w64-opencv"
"mingw-w64-ffmpeg"
"mingw-w64-hdf5"
+ "mingw-w64-robinmap"
)
-builddepends=("mingw-w64-cmake" "git")
+makedepends=("mingw-w64-cmake")
arch=("any")
options=(!strip !buildflags staticlibs)
optdepends=()
@@ -49,7 +50,7 @@ prepare() {
build() {
_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG -fpermissive"
- -DBUILD_DOCS=OFF -DBUILD_MISSING_FMT=OFF -DBUILD_MISSING_ROBINMAP=ON -DBUILD_ROBINMAP_FORCE=ON
+ -DBUILD_DOCS=OFF -DBUILD_MISSING_FMT=OFF -DBUILD_MISSING_ROBINMAP=OFF
-DUSE_EXTERNAL_PUGIXML=ON -DBUILD_TESTING=OFF -DCMAKE_CXX_STANDARD=20 -DINSTALL_DOCS=OFF
-DOIIO_BUILD_TESTS=OFF -DOIIO_BUILD_TOOLS=OFF -DUSE_PYTHON=OFF -DUSE_QT=OFF -DUSE_CCACHE=OFF
-DUSE_SIMD=sse4.2 -DEMBEDPLUGINS=ON -DSTOP_ON_WARNING=OFF -DOPTIONAL_DEPS=""