summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-09-10 02:04:04 -0400
committerPatrick Northon2020-09-10 02:04:04 -0400
commitfcdc868cd468879c5346cfd5fc85c35479003347 (patch)
tree94a47ecf9e2ba60a52b140b07e1d7eaf5445711f
parentb948dd8afc919b2a9e2f4bcba7fc82adce9ae0bd (diff)
downloadaur-fcdc868cd468879c5346cfd5fc85c35479003347.tar.gz
Remove static build as it conflicts.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 2 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52f1ce485ab9..2a177824e633 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-openimageio
pkgdesc = A library for reading and writing images (mingw-w64)
pkgver = 2.2.6.1
- pkgrel = 3
+ pkgrel = 4
url = http://www.openimageio.org/
arch = any
license = BSD-3-Clause
diff --git a/PKGBUILD b/PKGBUILD
index 915f3448c96e..30fc13bacf63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-openimageio
pkgver=2.2.6.1
-pkgrel=3
+pkgrel=4
pkgdesc="A library for reading and writing images (mingw-w64)"
url="http://www.openimageio.org/"
license=("BSD-3-Clause")
@@ -59,8 +59,6 @@ build() {
-DREQUIRED_DEPS="JPEGTurbo;PNG;TBB;GIF;Webp;Libsquish;Freetype;OpenColorIO;OpenCV;FFmpeg;HDF5;LibRaw" )
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "oiio-Release-${pkgver}" -B "build-${_arch}-static" "${_flags[@]}" -DBUILD_SHARED_LIBS=FALSE
- make -C "build-${_arch}-static"
${_arch}-cmake -S "oiio-Release-${pkgver}" -B "build-${_arch}" "${_flags[@]}"
make -C "build-${_arch}"
done
@@ -68,9 +66,7 @@ build() {
package() {
for _arch in ${_architectures}; do
- make DESTDIR="${pkgdir}" -C "build-${_arch}-static" install
make DESTDIR="${pkgdir}" -C "build-${_arch}" install
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}