summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2019-04-03 16:16:02 +0800
committerpingplug2019-04-03 16:16:02 +0800
commit569e30fb0f4af3c2febe3214542d6032f1c02559 (patch)
treeeb77f03c352f46e1016c0764303e510444dcaece
parentb41340c2cfda001a260b31e1036efc91cc193029 (diff)
downloadaur-569e30fb0f4af3c2febe3214542d6032f1c02559.tar.gz
Updated to 2.3.1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore12
-rw-r--r--0003-versioned-dlls.mingw.patch10
-rw-r--r--0005-sock-jpip.all.patch21
-rw-r--r--PKGBUILD64
5 files changed, 52 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3d45cb56e7d..466375fccfa3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = mingw-w64-openjpeg2
- pkgdesc = An open source JPEG 2000 codec, version 2.3.0 (mingw-w64)
- pkgver = 2.3.0
+ pkgdesc = An open source JPEG 2000 codec, version 2.3.1 (mingw-w64)
+ pkgver = 2.3.1
pkgrel = 1
url = https://www.openjpeg.org
arch = any
- license = custom: BSD
+ license = BSD
makedepends = mingw-w64-cmake
depends = mingw-w64-libpng
depends = mingw-w64-lcms2
- options = staticlibs
options = !strip
+ options = staticlibs
options = !buildflags
- source = openjpeg-2.3.0.tar.gz::https://github.com/uclouvain/openjpeg/archive/v2.3.0.tar.gz
+ source = openjpeg-2.3.1.tar.gz::https://github.com/uclouvain/openjpeg/archive/v2.3.1.tar.gz
source = 0001-fix-install-for-dlls.all.patch
source = 0003-versioned-dlls.mingw.patch
- source = 0005-sock-jpip.all.patch
- sha256sums = 3dc787c1bb6023ba846c2a0d9b1f6e179f1cd255172bde9eb75b01f1e6c7d71a
+ sha256sums = 63f5a4713ecafc86de51bfad89cc07bb788e9bba24ebbf0c4ca637621aadb6a9
sha256sums = 3f3bde353ca3432f157258164c5e3c345af82ca3a9d5a68f815c3030b01cbc32
- sha256sums = a221300d278f1a57b1ea5c70314702cd4234a2560ed2335bd5940fd921e78eda
- sha256sums = b7b22dca26d5fd98ca5bc6ce775bbbabebc0e10fcf07fd0afb54d580699b8312
+ sha256sums = 4d8d0310d24e7ec0a54cf71c06ff85831e37841046e13744e58f53b87e691560
pkgname = mingw-w64-openjpeg2
diff --git a/.gitignore b/.gitignore
index 298f44f6e7d7..97589fb4de69 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
-pkg/
-src/
-*.gz
-*.log
-*.tar
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.install
+!*.patch
+!*.diff
diff --git a/0003-versioned-dlls.mingw.patch b/0003-versioned-dlls.mingw.patch
index f93d3d162ba1..5f9b7758a000 100644
--- a/0003-versioned-dlls.mingw.patch
+++ b/0003-versioned-dlls.mingw.patch
@@ -6,7 +6,7 @@
endif()
-set_target_properties(${OPENJPEG_LIBRARY_NAME} PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES})
+set_target_properties(${OPENJPEG_LIBRARY_NAME} PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES} OUTPUT_NAME openjp2 RUNTIME_OUTPUT_NAME openjp2-${OPENJPEG_SOVERSION} ARCHIVE_OUTPUT_NAME openjp2)
- if(${CMAKE_VERSION} VERSION_GREATER "2.8.11")
+ if(NOT ${CMAKE_VERSION} VERSION_LESS "2.8.12")
target_compile_options(${OPENJPEG_LIBRARY_NAME} PRIVATE ${OPENJPEG_LIBRARY_COMPILE_OPTIONS})
endif()
--- openjpeg-2.1.2/src/lib/openjp3d/CMakeLists.txt.orig 2016-10-01 08:59:49.819661900 -0400
@@ -17,13 +17,13 @@
endif()
-set_target_properties(${OPENJP3D_LIBRARY_NAME} PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES})
+set_target_properties(${OPENJP3D_LIBRARY_NAME} PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES} OUTPUT_NAME openjp3d RUNTIME_OUTPUT_NAME openjp3d-${OPENJPEG_SOVERSION} ARCHIVE_OUTPUT_NAME openjp3d)
- if(${CMAKE_VERSION} VERSION_GREATER "2.8.11")
+ if(NOT ${CMAKE_VERSION} VERSION_LESS "2.8.12")
target_compile_options(${OPENJP3D_LIBRARY_NAME} PRIVATE ${OPENJPEG_LIBRARY_COMPILE_OPTIONS})
endif()
--- openjpeg-2.1.2/src/lib/openjpip/CMakeLists.txt.orig 2016-10-01 08:31:32.305170000 -0400
+++ openjpeg-2.1.2/src/lib/openjpip/CMakeLists.txt 2016-10-01 08:40:01.492903300 -0400
@@ -65,7 +65,7 @@
- if(${CMAKE_VERSION} VERSION_GREATER "2.8.11")
+ if(NOT ${CMAKE_VERSION} VERSION_LESS "2.8.12")
target_compile_options(openjpip PRIVATE ${OPENJPEG_LIBRARY_COMPILE_OPTIONS})
endif()
-target_link_libraries(openjpip ${OPENJPEG_LIBRARY_NAME})
@@ -39,7 +39,7 @@
set_target_properties(openjpwl
- PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES})
+ PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES} OUTPUT_NAME openjpwl RUNTIME_OUTPUT_NAME openjpwl-${OPENJPEG_SOVERSION} ARCHIVE_OUTPUT_NAME openjpwl)
- if(${CMAKE_VERSION} VERSION_GREATER "2.8.11")
+ if(NOT ${CMAKE_VERSION} VERSION_LESS "2.8.12")
target_compile_options(openjpwl PRIVATE ${OPENJPEG_LIBRARY_COMPILE_OPTIONS})
endif()
--- openjpeg-2.1.2/src/lib/openmj2/CMakeLists.txt.orig 2016-10-01 08:59:49.839164400 -0400
@@ -50,6 +50,6 @@
endif()
-set_target_properties(${OPENMJ2_LIBRARY_NAME} PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES})
+set_target_properties(${OPENMJ2_LIBRARY_NAME} PROPERTIES ${OPENJPEG_LIBRARY_PROPERTIES} OUTPUT_NAME openmj2 RUNTIME_OUTPUT_NAME openmj2-${OPENJPEG_SOVERSION} ARCHIVE_OUTPUT_NAME openmj2)
- if(${CMAKE_VERSION} VERSION_GREATER "2.8.11")
+ if(NOT ${CMAKE_VERSION} VERSION_LESS "2.8.12")
target_compile_options(${OPENMJ2_LIBRARY_NAME} PRIVATE ${OPENJPEG_LIBRARY_COMPILE_OPTIONS})
endif()
diff --git a/0005-sock-jpip.all.patch b/0005-sock-jpip.all.patch
deleted file mode 100644
index 307890aa1ffd..000000000000
--- a/0005-sock-jpip.all.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- openjpeg-2.1.0/src/lib/openjpip/sock_manager.c.orig 2014-04-29 07:15:01.000000000 +0000
-+++ openjpeg-2.1.0/src/lib/openjpip/sock_manager.c 2014-07-29 15:35:10.066130700 +0000
-@@ -28,13 +28,17 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#ifdef _WIN32
-+#ifdef _MSC_VER
- #include <windows.h>
- typedef SSIZE_T ssize_t;
- #else
- #include <sys/types.h>
-+#ifdef _WIN32
-+#include <ws2tcpip.h>
-+#else
- #include <sys/socket.h>
- #include <arpa/inet.h>
-+#endif
- #include <unistd.h>
- #endif
-
diff --git a/PKGBUILD b/PKGBUILD
index 4633111760be..e8a8b3f83721 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
+# Maintainer: pingplug <pingplug@foxmail.com>
+# Contributor: Schala Zeal <schalaalexiazeal@gmail.com>
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
pkgname=mingw-w64-openjpeg2
-pkgver=2.3.0
+pkgver=2.3.1
pkgrel=1
-arch=(any)
pkgdesc="An open source JPEG 2000 codec, version ${pkgver} (mingw-w64)"
-license=("custom: BSD")
-depends=(mingw-w64-libpng mingw-w64-lcms2)
-makedepends=(mingw-w64-cmake)
-options=(staticlibs !strip !buildflags)
+arch=('any')
url="https://www.openjpeg.org"
-source=("openjpeg-$pkgver.tar.gz::https://github.com/uclouvain/openjpeg/archive/v$pkgver.tar.gz"
-"0001-fix-install-for-dlls.all.patch"
-"0003-versioned-dlls.mingw.patch"
-"0005-sock-jpip.all.patch")
-sha256sums=('3dc787c1bb6023ba846c2a0d9b1f6e179f1cd255172bde9eb75b01f1e6c7d71a'
+license=('BSD')
+depends=('mingw-w64-libpng'
+ 'mingw-w64-lcms2')
+makedepends=('mingw-w64-cmake')
+options=('!strip' 'staticlibs' '!buildflags')
+source=("openjpeg-${pkgver}.tar.gz::https://github.com/uclouvain/openjpeg/archive/v${pkgver}.tar.gz"
+ "0001-fix-install-for-dlls.all.patch"
+ "0003-versioned-dlls.mingw.patch")
+sha256sums=('63f5a4713ecafc86de51bfad89cc07bb788e9bba24ebbf0c4ca637621aadb6a9'
'3f3bde353ca3432f157258164c5e3c345af82ca3a9d5a68f815c3030b01cbc32'
- 'a221300d278f1a57b1ea5c70314702cd4234a2560ed2335bd5940fd921e78eda'
- 'b7b22dca26d5fd98ca5bc6ce775bbbabebc0e10fcf07fd0afb54d580699b8312')
-
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+ '4d8d0310d24e7ec0a54cf71c06ff85831e37841046e13744e58f53b87e691560')
prepare() {
- cd openjpeg-$pkgver
+ cd openjpeg-${pkgver}
sed -i '/add_subdirectory(thirdparty)/d' CMakeLists.txt
patch -p1 -i "${srcdir}"/0001-fix-install-for-dlls.all.patch
patch -p1 -i "${srcdir}"/0003-versioned-dlls.mingw.patch
- patch -p1 -i "${srcdir}"/0005-sock-jpip.all.patch
+ #patch -p1 -i "${srcdir}"/0005-sock-jpip.all.patch
}
build() {
- cd openjpeg-$pkgver
- for _arch in ${_architectures}; do
- unset LDFLAGS
-
+ cd openjpeg-${pkgver}
+ for _arch in ${_architectures}; do
mkdir "build-${_arch}-static" && pushd "build-${_arch}-static"
${_arch}-cmake \
-DCMAKE_BUILD_TYPE=Release \
@@ -41,7 +41,7 @@ build() {
..
make
popd
-
+
mkdir "build-${_arch}-shared" && pushd "build-${_arch}-shared"
${_arch}-cmake \
-DCMAKE_BUILD_TYPE=Release \
@@ -55,14 +55,16 @@ build() {
}
package() {
- for _arch in ${_architectures}; do
- cd "${srcdir}/openjpeg-$pkgver/build-${_arch}-static"
- make DESTDIR="$pkgdir" install
- cd "${srcdir}/openjpeg-$pkgver/build-${_arch}-shared"
- make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- find "$pkgdir/usr/${_arch}/lib" -name '*.dll' -exec mv {} "$pkgdir/usr/${_arch}/bin" \;
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/openjpeg-${pkgver}/build-${_arch}-static"
+ make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/openjpeg-${pkgver}/build-${_arch}-shared"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ find "${pkgdir}/usr/${_arch}/lib" -name '*.dll' -exec mv {} "${pkgdir}/usr/${_arch}/bin" \;
done
}
+
+# vim:set ts=2 sw=2 et: