summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2017-01-26 15:12:26 -0800
committerSchala2017-01-26 15:12:26 -0800
commit6dea4351b31263ef3d54dec8dbda5af478e5087a (patch)
tree33152bff77bf29b678e24ee1aa1b64900986f99c
parent0bb46a40fbbb9a9664759a602c68e1b76c98830b (diff)
downloadaur-6dea4351b31263ef3d54dec8dbda5af478e5087a.tar.gz
1.0.2k
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
-rw-r--r--openssl-0.9.6-x509.patch63
-rw-r--r--openssl-1.0.2a-x509.patch28
5 files changed, 41 insertions, 75 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c67449c41e50..0efcfbd21100 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Sep 28 07:36:13 UTC 2016
+# Thu Jan 26 23:11:45 UTC 2017
pkgbase = mingw-w64-openssl
pkgdesc = The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (mingw-w64)
- pkgver = 1.0.2.j
+ pkgver = 1.0.2.k
pkgrel = 1
url = http://www.openssl.org
arch = any
@@ -14,15 +14,15 @@ pkgbase = mingw-w64-openssl
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://www.openssl.org/source/openssl-1.0.2j.tar.gz
- source = http://www.openssl.org/source/openssl-1.0.2j.tar.gz.asc
- source = openssl-0.9.6-x509.patch
+ source = http://www.openssl.org/source/openssl-1.0.2k.tar.gz
+ source = http://www.openssl.org/source/openssl-1.0.2k.tar.gz.asc
+ source = openssl-1.0.2a-x509.patch
source = openssl-1.0.0a-ldflags.patch
source = openssl-1.0.1-x32.patch
source = openssl-1.0.2a-parallel-build.patch
- md5sums = 96322138f0b69e61b7212bc53d5e912b
+ md5sums = f965fc0bf01bf882b31314b61391ae65
md5sums = SKIP
- md5sums = 990d027cc82ff8b2acffead24073d43c
+ md5sums = c730f823023879de28513081aedbf06b
md5sums = dd616e53eba607f5ab46634f93d5c5a5
md5sums = 7400927e547cd4c68d2af2fe0b322345
md5sums = 7ea5aaac21cee0f89dfb58b03219caaa
diff --git a/.gitignore b/.gitignore
index 7f8bc6c44c91..3ffe417662d9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,6 @@ pkg/
src/
*.asc
*.gz
+*.log
*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 3df499cfcb0d..48b3e73b115e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: ant32 <antreimer@gmail.com>
# Contributor: Filip Brcic <brcha@gna.org>
pkgname=mingw-w64-openssl
-_ver=1.0.2j
+_ver=1.0.2k
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
pkgrel=1
pkgdesc="The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (mingw-w64)"
@@ -12,13 +12,13 @@ options=(!strip !buildflags staticlibs !emptydirs)
license=("custom:BSD")
url="http://www.openssl.org"
source=("http://www.openssl.org/source/openssl-$_ver.tar.gz"{,.asc}
-"openssl-0.9.6-x509.patch"
+"openssl-1.0.2a-x509.patch"
"openssl-1.0.0a-ldflags.patch"
"openssl-1.0.1-x32.patch"
"openssl-1.0.2a-parallel-build.patch")
-md5sums=('96322138f0b69e61b7212bc53d5e912b'
+md5sums=('f965fc0bf01bf882b31314b61391ae65'
'SKIP'
- '990d027cc82ff8b2acffead24073d43c'
+ 'c730f823023879de28513081aedbf06b'
'dd616e53eba607f5ab46634f93d5c5a5'
'7400927e547cd4c68d2af2fe0b322345'
'7ea5aaac21cee0f89dfb58b03219caaa')
@@ -31,7 +31,7 @@ prepare() {
patch -p1 -i ${srcdir}/openssl-1.0.0a-ldflags.patch
patch -p1 -i ${srcdir}/openssl-1.0.2a-parallel-build.patch
patch -p1 -i ${srcdir}/openssl-1.0.1-x32.patch
- patch -p1 -i ${srcdir}/openssl-0.9.6-x509.patch
+ patch -p1 -i ${srcdir}/openssl-1.0.2a-x509.patch
sed -i -e '/^"mingw"/ s/-fomit-frame-pointer -O3 -march=i486 -Wall/-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4/' Configure
sed -i -e '/^"mingw64"/ s/-O3 -Wall/-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4/' Configure
}
diff --git a/openssl-0.9.6-x509.patch b/openssl-0.9.6-x509.patch
deleted file mode 100644
index 4c3222533b8c..000000000000
--- a/openssl-0.9.6-x509.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Do not treat duplicate certs as an error.
-
---- openssl-0.9.6/crypto/x509/by_file.c Wed Sep 27 15:09:05 2000
-+++ openssl-0.9.6/crypto/x509/by_file.c Wed Sep 27 14:21:20 2000
-@@ -152,9 +152,12 @@
- }
- }
- i = X509_STORE_add_cert(ctx->store_ctx, x);
-- if (!i)
-- goto err;
-- count++;
-+ /* ignore any problems with current certificate
-+ and continue with the next one */
-+ if (i)
-+ count++;
-+ else
-+ ERR_clear_error();
- X509_free(x);
- x = NULL;
- }
-@@ -166,8 +169,8 @@
- goto err;
- }
- i = X509_STORE_add_cert(ctx->store_ctx, x);
-- if (!i)
-- goto err;
-+ if (!i)
-+ ERR_clear_error();
- ret = i;
- } else {
- X509err(X509_F_X509_LOAD_CERT_FILE, X509_R_BAD_X509_FILETYPE);
---- openssl-0.9.6/crypto/store/store.h 2009-08-12 00:57:20.000000000 +0200
-+++ openssl-0.9.6/crypto/store/store.h 2009-08-12 01:00:27.000000000 +0200
-@@ -77,6 +77,13 @@
- extern "C" {
- #endif
-
-+#ifdef OPENSSL_SYS_WIN32
-+/* Under Win32 these are defined in wincrypt.h */
-+#undef X509_NAME
-+#undef X509_CERT_PAIR
-+#undef X509_EXTENSIONS
-+#endif
-+
- /* Already defined in ossl_typ.h */
- /* typedef struct store_st STORE; */
- /* typedef struct store_method_st STORE_METHOD; */
---- openssl-0.9.6/crypto/pem/pem.h 2009-08-12 01:14:59.000000000 +0200
-+++ openssl-0.9.6/crypto/pem/pem.h 2009-08-12 01:15:01.000000000 +0200
-@@ -74,6 +74,13 @@
- extern "C" {
- #endif
-
-+#ifdef OPENSSL_SYS_WIN32
-+/* Under Win32 these are defined in wincrypt.h */
-+#undef X509_NAME
-+#undef X509_CERT_PAIR
-+#undef X509_EXTENSIONS
-+#endif
-+
- # define PEM_BUFSIZE 1024
-
- # define PEM_OBJ_UNDEF 0
diff --git a/openssl-1.0.2a-x509.patch b/openssl-1.0.2a-x509.patch
new file mode 100644
index 000000000000..7c96a578b60f
--- /dev/null
+++ b/openssl-1.0.2a-x509.patch
@@ -0,0 +1,28 @@
+diff -up openssl-1.0.2a/crypto/x509/by_file.c.x509 openssl-1.0.2a/crypto/x509/by_file.c
+--- openssl-1.0.2a/crypto/x509/by_file.c.x509 2015-04-09 18:16:29.365456157 +0200
++++ openssl-1.0.2a/crypto/x509/by_file.c 2015-04-09 18:16:26.398387618 +0200
+@@ -152,9 +152,12 @@ int X509_load_cert_file(X509_LOOKUP *ctx
+ }
+ }
+ i = X509_STORE_add_cert(ctx->store_ctx, x);
+- if (!i)
+- goto err;
+- count++;
++ /* ignore any problems with current certificate
++ and continue with the next one */
++ if (i)
++ count++;
++ else
++ ERR_clear_error();
+ X509_free(x);
+ x = NULL;
+ }
+@@ -167,7 +170,7 @@ int X509_load_cert_file(X509_LOOKUP *ctx
+ }
+ i = X509_STORE_add_cert(ctx->store_ctx, x);
+ if (!i)
+- goto err;
++ ERR_clear_error();
+ ret = i;
+ } else {
+ X509err(X509_F_X509_LOAD_CERT_FILE, X509_R_BAD_X509_FILETYPE);