summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-09 21:31:14 +0200
committerxantares2015-06-09 21:31:14 +0200
commitb02f0836f7ba05f73bee0189dde7e800e31ca46e (patch)
tree6c0417213534590cadf1108b7fee9ef7c20b3d45
downloadaur-b02f0836f7ba05f73bee0189dde7e800e31ca46e.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b8ef5abf365
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-opus
+ pkgdesc = Codec designed for interactive speech and audio transmission over the Internet (mingw-w64)
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://www.opus-codec.org
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://downloads.us.xiph.org/releases/opus/opus-1.1.tar.gz
+ md5sums = c5a8cf7c0b066759542bc4ca46817ac6
+
+pkgname = mingw-w64-opus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..674fb6bd730a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=mingw-w64-opus
+pkgver=1.1
+pkgrel=1
+pkgdesc="Codec designed for interactive speech and audio transmission over the Internet (mingw-w64)"
+arch=(any)
+url="http://www.opus-codec.org"
+license=("BSD")
+makedepends=(mingw-w64-gcc mingw-w64-pkg-config)
+depends=(mingw-w64-crt)
+options=(staticlibs !strip !buildflags)
+source=("http://downloads.us.xiph.org/releases/opus/opus-$pkgver.tar.gz")
+md5sums=('c5a8cf7c0b066759542bc4ca46817ac6')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ "${srcdir}"/${pkgname#mingw-w64-}-${pkgver}/configure \
+ --prefix=/usr/${_arch} \
+ --build=$CHOST \
+ --host=${_arch} \
+ --enable-custom-modes \
+ --disable-doc \
+ --disable-extra-programs
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+}