summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2015-06-10 18:49:12 +0200
committerkfg2015-06-10 18:49:12 +0200
commit6bebf1cb52df5acadd32d8297f036ef84c086b22 (patch)
tree79722b5726993963af8794ce41bb6aa39773c699
downloadaur-6bebf1cb52df5acadd32d8297f036ef84c086b22.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e124be0fecd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-orc
+ pkgdesc = The Oild Runtime Compiler (mingw-w64)
+ pkgver = 0.4.23
+ pkgrel = 2
+ url = http://code.entropywave.com/projects/orc/
+ arch = any
+ license = custom
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = !libtool
+ options = staticlibs
+ source = http://gstreamer.freedesktop.org/data/src/orc/orc-0.4.23.tar.xz
+ md5sums = 72e0612ace54d77aa2f7a006348ee81a
+
+pkgname = mingw-w64-orc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f40566cf639
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
+pkgname=mingw-w64-orc
+pkgver=0.4.23
+pkgrel=2
+pkgdesc="The Oild Runtime Compiler (mingw-w64)"
+arch=('any')
+license=('custom')
+url="http://code.entropywave.com/projects/orc/"
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
+options=('!strip' '!buildflags' '!libtool' 'staticlibs')
+source=(http://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz)
+md5sums=('72e0612ace54d77aa2f7a006348ee81a')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build () {
+ for _arch in ${_architectures}; do
+ mkdir -p ${srcdir}/orc-$pkgver/build-${_arch} && cd ${srcdir}/orc-$pkgver/build-${_arch}
+
+ unset LDFLAGS CPPFLAGS
+ ${_arch}-configure --enable-gtk-doc-html=no
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd ${srcdir}/orc-$pkgver/build-${_arch}
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ${srcdir}/orc-$pkgver/COPYING "$pkgdir/usr/${_arch}/share/licenses/orc/COPYING"
+
+ ${_arch}-strip -x -g ${pkgdir}/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
+ rm ${pkgdir}/usr/${_arch}/bin/*.exe
+ done
+}