summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2020-09-25 23:52:10 +0200
committerkfg2020-09-26 00:05:24 +0200
commitb76822e02045e2b80e61e0765f484c8670459991 (patch)
tree7d7407973196ff8f4cd30aa2f99b63606903cabd
parentc51b8cc682936ee178b2090db52c9299817f04a5 (diff)
downloadaur-b76822e02045e2b80e61e0765f484c8670459991.tar.gz
Update to 0.4.32
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 222d2fddb5dc..e20471de6220 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
-# Generated by mksrcinfo v8
-# Tue Nov 5 20:44:48 UTC 2019
pkgbase = mingw-w64-orc
pkgdesc = Optimized Inner Loop Runtime Compiler (mingw-w64)
- pkgver = 0.4.31
+ pkgver = 0.4.32
pkgrel = 1
url = https://gitlab.freedesktop.org/gstreamer/orc
arch = any
- license = custom
+ license = custom:BSD
makedepends = mingw-w64-gcc
makedepends = mingw-w64-meson
makedepends = wine
@@ -16,9 +14,10 @@ pkgbase = mingw-w64-orc
options = !buildflags
options = !libtool
options = staticlibs
- source = git+https://gitlab.freedesktop.org/gstreamer/orc.git#commit=9901a96eaff271c2d3b595214213f6805ff803c8
+ source = git+https://gitlab.freedesktop.org/gstreamer/orc.git#commit=629864f073ae003e63c026c1de2407fec713cb53
source = meson_i686-w64-mingw32
source = meson_x86_64-w64-mingw32
+ validpgpkeys = 7F4BC7CC3CA06F97336BBFEB0668CC1486C2D7B5
sha256sums = SKIP
sha256sums = 3eed78156a85a6b8238cd9b64d37df1a0dd8ec9816e71c2ed7a70874289f8e2e
sha256sums = a07b08deafafabf9196dbc0583093fff8be9c45e29f73f7c286d5fc99492434d
diff --git a/PKGBUILD b/PKGBUILD
index c2f2d3ed74a9..d4f432f733aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
pkgname=mingw-w64-orc
-pkgver=0.4.31
+pkgver=0.4.32
pkgrel=1
pkgdesc="Optimized Inner Loop Runtime Compiler (mingw-w64)"
arch=('any')
-license=('custom')
+license=('custom:BSD')
url="https://gitlab.freedesktop.org/gstreamer/orc"
depends=('mingw-w64-crt')
makedepends=('mingw-w64-gcc' 'mingw-w64-meson' 'wine' 'git')
options=('!strip' '!buildflags' '!libtool' 'staticlibs')
#source=(https://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz{,.asc}
-_commit=9901a96eaff271c2d3b595214213f6805ff803c8 # tags/0.4.31^0
+_commit=629864f073ae003e63c026c1de2407fec713cb53 # tags/0.4.32^0
source=("git+https://gitlab.freedesktop.org/gstreamer/orc.git#commit=$_commit"
meson_i686-w64-mingw32
meson_x86_64-w64-mingw32)
@@ -26,6 +30,7 @@ build() {
mkdir -p "${srcdir}/orc/build-${_arch}" && cd "${srcdir}/orc/build-${_arch}"
${_arch}-meson \
+ --default-library both \
"${srcdir}/orc"
ninja
done