summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2017-04-14 11:42:18 +0200
committerkfg2017-04-14 11:42:18 +0200
commitdaf52c2922f17c989988a89a199cf1e9d2883a76 (patch)
tree391cb3079d9a2c2d4652ddca6123c704d07563dc
parent3de0bbd5e55c3cc52ff356ae8d15d3f1af8eef89 (diff)
downloadaur-daf52c2922f17c989988a89a199cf1e9d2883a76.tar.gz
keep EXEs
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0df87692253..faba7a35c544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Oct 28 23:31:14 UTC 2016
+# Fri Apr 14 09:42:02 UTC 2017
pkgbase = mingw-w64-orc
pkgdesc = Optimized Inner Loop Runtime Compiler (mingw-w64)
pkgver = 0.4.26
- pkgrel = 1
+ pkgrel = 2
url = https://cgit.freedesktop.org/gstreamer/orc/
arch = any
license = custom
@@ -14,8 +14,10 @@ pkgbase = mingw-w64-orc
options = !buildflags
options = !libtool
options = staticlibs
- source = http://gstreamer.freedesktop.org/data/src/orc/orc-0.4.26.tar.xz
+ source = https://gstreamer.freedesktop.org/data/src/orc/orc-0.4.26.tar.xz
+ source = https://gstreamer.freedesktop.org/data/src/orc/orc-0.4.26.tar.xz.asc
sha256sums = 7d52fa80ef84988359c3434e1eea302d077a08987abdde6905678ebcad4fa649
+ sha256sums = SKIP
pkgname = mingw-w64-orc
diff --git a/PKGBUILD b/PKGBUILD
index a0801267a29e..f336cca206c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-orc
pkgver=0.4.26
-pkgrel=1
+pkgrel=2
pkgdesc="Optimized Inner Loop Runtime Compiler (mingw-w64)"
arch=('any')
license=('custom')
@@ -9,8 +9,10 @@ url="https://cgit.freedesktop.org/gstreamer/orc/"
depends=('mingw-w64-crt')
makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
options=('!strip' '!buildflags' '!libtool' 'staticlibs')
-source=(http://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz)
-sha256sums=('7d52fa80ef84988359c3434e1eea302d077a08987abdde6905678ebcad4fa649')
+source=(https://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz{,.asc})
+validpgpkeys=('7F4BC7CC3CA06F97336BBFEB0668CC1486C2D7B5') #Sebastian Dröge
+sha256sums=('7d52fa80ef84988359c3434e1eea302d077a08987abdde6905678ebcad4fa649'
+ 'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build () {
@@ -29,8 +31,8 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 ${srcdir}/orc-$pkgver/COPYING "$pkgdir/usr/${_arch}/share/licenses/orc/COPYING"
+ ${_arch}-strip -s ${pkgdir}/usr/${_arch}/bin/*.exe
${_arch}-strip -x -g ${pkgdir}/usr/${_arch}/bin/*.dll
${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
- rm ${pkgdir}/usr/${_arch}/bin/*.exe
done
}