summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-01-19 19:15:18 +0100
committerMichel Zou2018-01-19 19:15:18 +0100
commit884b1383b8895af937ba0c6bb4932aedfe14c3fd (patch)
treed9f0691b756e0cd13e1362b9938774ce5bee9c89
parentd942befd54e1214bd931b868ea932f6f953a33ce (diff)
downloadaur-884b1383b8895af937ba0c6bb4932aedfe14c3fd.tar.gz
0.23.9
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--mingw-p11-kit-setenv.patch28
3 files changed, 8 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bb06b44fc59..64719bb7ced4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 6 11:08:28 UTC 2016
+# Fri Jan 19 18:15:18 UTC 2018
pkgbase = mingw-w64-p11-kit
pkgdesc = Library to work with PKCS#11 modules (mingw-w64)
- pkgver = 0.23.2
+ pkgver = 0.23.9
pkgrel = 1
url = http://p11-glue.freedesktop.org
arch = any
@@ -14,10 +14,8 @@ pkgbase = mingw-w64-p11-kit
options = staticlibs
options = !buildflags
options = !strip
- source = http://p11-glue.freedesktop.org/releases/p11-kit-0.23.2.tar.gz
- source = mingw-p11-kit-setenv.patch
- md5sums = 738af2442331fc22f440df9bee9b062a
- md5sums = 51efa37a12ce2843ffc2244baca3c272
+ source = https://github.com/p11-glue/p11-kit/releases/download/0.23.9/p11-kit-0.23.9.tar.gz
+ sha256sums = e1c1649c335107a8d33cf3762eb7f57b2d0681f0c7d8353627293a58d6b4db63
pkgname = mingw-w64-p11-kit
diff --git a/PKGBUILD b/PKGBUILD
index 57b30c96e0da..3676c1351b3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-p11-kit
-pkgver=0.23.2
+pkgver=0.23.9
pkgrel=1
pkgdesc="Library to work with PKCS#11 modules (mingw-w64)"
arch=(any)
@@ -10,16 +10,13 @@ depends=('mingw-w64-crt' 'mingw-w64-libtasn1' 'mingw-w64-libffi')
makedepends=('mingw-w64-configure')
options=('staticlibs' '!buildflags' '!strip')
source=($url/releases/p11-kit-$pkgver.tar.gz mingw-p11-kit-setenv.patch)
-md5sums=('738af2442331fc22f440df9bee9b062a'
- '51efa37a12ce2843ffc2244baca3c272')
+source=("https://github.com/p11-glue/p11-kit/releases/download/${pkgver}/p11-kit-${pkgver}.tar.gz")
+sha256sums=('e1c1649c335107a8d33cf3762eb7f57b2d0681f0c7d8353627293a58d6b4db63')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "$srcdir"/p11-kit-${pkgver}
- patch -p0 -i "$srcdir"/mingw-p11-kit-setenv.patch
- aclocal --force
- autoreconf -vfi
}
build() {
@@ -37,7 +34,7 @@ package() {
cd "$srcdir"/p11-kit-${pkgver}/build-${_arch}
make install DESTDIR="$pkgdir"
rm "$pkgdir"/usr/${_arch}/bin/*.exe
- rm -r "$pkgdir"/usr/${_arch}/lib/p11-kit
+ rm -r "$pkgdir"/usr/${_arch}/libexec
rm -r "$pkgdir"/usr/${_arch}/etc
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
diff --git a/mingw-p11-kit-setenv.patch b/mingw-p11-kit-setenv.patch
deleted file mode 100644
index 14065151e15a..000000000000
--- a/mingw-p11-kit-setenv.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- common/test-compat.c.orig 2014-10-02 01:24:44.000000000 -0500
-+++ common/test-compat.c 2014-10-04 15:26:10.657823106 -0500
-@@ -90,7 +90,11 @@
- char *path;
- int ret;
-
-+#ifdef OS_UNIX
- setenv ("BLAH", "5", 1);
-+#else
-+ _putenv_s ("BLAH", "5");
-+#endif
-
- ret = p11_test_run_child (args, true);
- assert_num_eq (ret, 5);
---- p11-kit/test-transport.c.orig 2014-10-02 01:24:44.000000000 -0500
-+++ p11-kit/test-transport.c 2014-10-04 15:27:02.691227676 -0500
-@@ -74,7 +74,11 @@
- test.user_config = p11_path_build (test.directory, "pkcs11.conf", NULL);
- p11_test_file_write (NULL, test.user_config, data, strlen (data));
-
-+#ifdef OS_UNIX
- setenv ("P11_KIT_PRIVATEDIR", BUILDDIR, 1);
-+#else
-+ _putenv_s ("P11_KIT_PRIVATEDIR", BUILDDIR);
-+#endif
- data = "remote: |" BUILDDIR "/p11-kit/p11-kit remote " BUILDDIR "/.libs/mock-two.so\n";
- p11_test_file_write (test.user_modules, "remote.module", data, strlen (data));
-