summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-01-13 22:36:34 +0100
committerMichel Zou2019-01-13 22:36:34 +0100
commit441b094d6fda4d00c9aa4fe069d73a02a1b69a7f (patch)
treeaee9374570bf14791ae191d309771548c16f32e9
downloadaur-441b094d6fda4d00c9aa4fe069d73a02a1b69a7f.tar.gz
2.10
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3ce17d4a3b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mingw-w64-pagmo2
+ pkgdesc = Perform parallel computations of optimisation tasks (global and local) via the asynchronous generalized island model (mingw-w64)
+ pkgver = 2.10
+ pkgrel = 1
+ url = https://github.com/esa/pagmo2
+ arch = any
+ license = GPLv3
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-boost
+ optdepends = mingw-w64-gsl: Mathematical operations (symbolic)
+ optdepends = mingw-w64-blas: GSL CBLAS functions
+ optdepends = mingw-w64-nlopt: Nonlinear optimization algorithms
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ source = https://github.com/esa/pagmo2/archive/v2.10.tar.gz
+ sha512sums = 87417c105bc887439a7a089d3569e7df942584bf4af4c3fe2df738498bf17be99e450e02ef3d0bf1fdfab5d37cd7a2218aed39492215ed49d9a029a19d143794
+
+pkgname = mingw-w64-pagmo2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66f14ff7093c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=mingw-w64-pagmo2
+pkgver=2.10
+pkgrel=1
+pkgdesc="Perform parallel computations of optimisation tasks (global and local) via the asynchronous generalized island model (mingw-w64)"
+arch=('any')
+url="https://github.com/esa/pagmo2"
+license=('GPLv3')
+depends=('mingw-w64-boost')
+optdepends=('mingw-w64-gsl: Mathematical operations (symbolic)'
+ 'mingw-w64-blas: GSL CBLAS functions'
+ 'mingw-w64-nlopt: Nonlinear optimization algorithms')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' 'staticlibs' '!strip')
+source=("https://github.com/esa/pagmo2/archive/v${pkgver}.tar.gz")
+sha512sums=('87417c105bc887439a7a089d3569e7df942584bf4af4c3fe2df738498bf17be99e450e02ef3d0bf1fdfab5d37cd7a2218aed39492215ed49d9a029a19d143794')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/pagmo2-$pkgver"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/pagmo2-${pkgver}/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ done
+}