summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-06-19 21:49:28 +0200
committerMichel Zou2018-06-19 21:49:28 +0200
commit284e4b02773a3605a2bb454bb272d43df02e72be (patch)
treeae805e221b2ecdfecf1de80d13cc172058880f73
parent4d4644f3a4b783acff87526827de95b31f020b57 (diff)
downloadaur-284e4b02773a3605a2bb454bb272d43df02e72be.tar.gz
5.5.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--compile-tools.patch30
-rw-r--r--fix-invalid-conversion.patch25
4 files changed, 73 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e43c5441f13d..2a104dede3e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jun 2 12:21:27 UTC 2018
+# Tue Jun 19 19:49:27 UTC 2018
pkgbase = mingw-w64-paraview
pkgdesc = Parallel Visualization Application using VTK (mingw-w64)
- pkgver = 5.5.1
+ pkgver = 5.5.2
pkgrel = 1
url = http://www.paraview.org
arch = any
@@ -31,12 +31,16 @@ pkgbase = mingw-w64-paraview
options = !buildflags
options = !strip
options = staticlibs
- source = http://paraview.org/files/v5.5/ParaView-v5.5.1.tar.gz
+ source = http://paraview.org/files/v5.5/ParaView-v5.5.2.tar.gz
+ source = compile-tools.patch
source = vtk-fix-jsoncpp-module.patch
source = support-qt5.11.patch
- sha256sums = a6e67a95a7a5711a2b5f95f38ccbff4912262b3e1b1af7d6b9afe8185aa85c0d
+ source = fix-invalid-conversion.patch
+ sha256sums = 64561f34c4402b88f3cb20a956842394dde5838efd7ebb301157a837114a0e2d
+ sha256sums = ea4211078f1e1d7d2bb999861d81fbcb0cc6176844fead431c473035e94bd4bb
sha256sums = 86af85dddde9d02877d6eda60c440db3ae903e525238d4dc19be7a25a92597f7
sha256sums = 4a6103ddaf51ada6011ecc752ce9abde227bf5deb35bccf08b94a8db97e5a51c
+ sha256sums = 7f159d4034fa0fcc2f976254129c288af4e732fe1d799310f3d2ab252460ebab
pkgname = mingw-w64-paraview
diff --git a/PKGBUILD b/PKGBUILD
index 73c4fe30cda5..d30c10c667a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-paraview
_majordotminor=5.5
-pkgver=${_majordotminor}.1
+pkgver=${_majordotminor}.2
_pkgver=${pkgver}
pkgrel=1
pkgdesc='Parallel Visualization Application using VTK (mingw-w64)'
@@ -11,11 +11,15 @@ depends=('mingw-w64-qt5-xmlpatterns' 'mingw-w64-qt5-tools' 'mingw-w64-boost' 'mi
makedepends=('mingw-w64-cmake' 'mingw-w64-eigen' 'mingw-w64-wine')
options=('!buildflags' '!strip' 'staticlibs')
source=("http://paraview.org/files/v${_majordotminor}/ParaView-v${_pkgver}.tar.gz"
+ "compile-tools.patch"
"vtk-fix-jsoncpp-module.patch"
- "support-qt5.11.patch")
-sha256sums=('a6e67a95a7a5711a2b5f95f38ccbff4912262b3e1b1af7d6b9afe8185aa85c0d'
+ "support-qt5.11.patch"
+ "fix-invalid-conversion.patch")
+sha256sums=('64561f34c4402b88f3cb20a956842394dde5838efd7ebb301157a837114a0e2d'
+ 'ea4211078f1e1d7d2bb999861d81fbcb0cc6176844fead431c473035e94bd4bb'
'86af85dddde9d02877d6eda60c440db3ae903e525238d4dc19be7a25a92597f7'
- '4a6103ddaf51ada6011ecc752ce9abde227bf5deb35bccf08b94a8db97e5a51c')
+ '4a6103ddaf51ada6011ecc752ce9abde227bf5deb35bccf08b94a8db97e5a51c'
+ '7f159d4034fa0fcc2f976254129c288af4e732fe1d799310f3d2ab252460ebab')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -23,10 +27,10 @@ prepare() {
cd "${srcdir}/ParaView-v${_pkgver}"
# cannot be modified upstream, see https://gitlab.kitware.com/paraview/paraview/merge_requests/1716
- sed -i "s|IF(NOT CMAKE_CROSSCOMPILING)|IF(NOT PARAVIEW_COMPILE_TOOLS_IMPORTED)|g" ThirdParty/protobuf/vtkprotobuf/src/CMakeLists.txt
+ patch -p1 -i "${srcdir}/compile-tools.patch"
# https://gitlab.kitware.com/vtk/vtk/merge_requests/4017
- sed -i "s|GetLibraryPathForSymbolWin32(\&function)|GetLibraryPathForSymbolWin32(reinterpret_cast<const void*>(\&function))|g" VTK/Common/Misc/vtkResourceFileLocator.h
+ patch -p1 -i "${srcdir}/fix-invalid-conversion.patch"
# https://gitlab.kitware.com/vtk/vtk/merge_requests/4107
patch -p1 -i "${srcdir}/vtk-fix-jsoncpp-module.patch"
diff --git a/compile-tools.patch b/compile-tools.patch
new file mode 100644
index 000000000000..147458db32f5
--- /dev/null
+++ b/compile-tools.patch
@@ -0,0 +1,30 @@
+--- a/ThirdParty/protobuf/vtkprotobuf/src/CMakeLists.txt 2018-06-15 21:09:45.000000000 +0200
++++ b/ThirdParty/protobuf/vtkprotobuf/src/CMakeLists.txt 2018-06-19 21:34:12.346101716 +0200
+@@ -283,7 +283,7 @@
+
+ # protoc executable
+ link_directories(${LIBRARY_OUTPUT_PATH})
+-IF(NOT CMAKE_CROSSCOMPILING)
++IF(NOT PARAVIEW_COMPILE_TOOLS_IMPORTED)
+ # We build the protoc executable without any dependencies on libraries built
+ # here viz. protobuf/protoc. This avoids unnecessary build-time
+ # complications when using protoc to generate headers in projects.
+@@ -295,15 +295,15 @@
+ OUTPUT_NAME protoc)
+ target_link_libraries(protoc_compiler
+ ${THREAD_LINK_LIB})
+-ENDIF(NOT CMAKE_CROSSCOMPILING)
++ENDIF(NOT PARAVIEW_COMPILE_TOOLS_IMPORTED)
+
+-IF(NOT CMAKE_CROSSCOMPILING)
++IF(NOT PARAVIEW_COMPILE_TOOLS_IMPORTED)
+ export(TARGETS protobuf protobuf-lite protoc_compiler
+ APPEND FILE "${PROTOBUF_EXPORTS_FILE}")
+ ELSE(NOT CMAKE_CROSSCOMPILING)
+ export(TARGETS protobuf protobuf-lite
+ APPEND FILE "${PROTOBUF_EXPORTS_FILE}")
+-ENDIF(NOT CMAKE_CROSSCOMPILING)
++ENDIF(NOT PARAVIEW_COMPILE_TOOLS_IMPORTED)
+
+ install (TARGETS protobuf protobuf-lite
+ EXPORT ${PROTOBUF_INSTALL_EXPORT_NAME}
diff --git a/fix-invalid-conversion.patch b/fix-invalid-conversion.patch
new file mode 100644
index 000000000000..eec392bf0416
--- /dev/null
+++ b/fix-invalid-conversion.patch
@@ -0,0 +1,25 @@
+diff --git a/Common/Misc/vtkResourceFileLocator.h b/Common/Misc/vtkResourceFileLocator.h
+index 5f8443f0ee..becf14e55d 100644
+--- a/VTK/Common/Misc/vtkResourceFileLocator.h
++++ b/VTK/Common/Misc/vtkResourceFileLocator.h
+@@ -84,7 +84,7 @@ public:
+ * Returns the name of the library providing the symbol. For example, if you
+ * want to locate where the VTK libraries located call
+ * `GetLibraryPathForSymbolUnix("GetVTKVersion")` on Unixes and
+- * `GetLibraryPathForSymbolUnix(GetVTKVersion)` on Window. Alternatively, you
++ * `GetLibraryPathForSymbolWin32(GetVTKVersion)` on Windows. Alternatively, you
+ * can simply use the `vtkGetLibraryPathForSymbol(GetVTKVersion)` macro
+ * that makes the appropriate call as per the current platform.
+ */
+@@ -105,7 +105,7 @@ private:
+
+ #if defined(_WIN32) && !defined(__CYGWIN__)
+ #define vtkGetLibraryPathForSymbol(function) \
+- vtkResourceFileLocator::GetLibraryPathForSymbolWin32(&function)
++ vtkResourceFileLocator::GetLibraryPathForSymbolWin32(reinterpret_cast<const void*>(&function))
+ #else
+ #define vtkGetLibraryPathForSymbol(function) \
+ vtkResourceFileLocator::GetLibraryPathForSymbolUnix(#function)
+--
+2.16.4
+