summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-11-07 21:05:20 +0100
committerMichel Zou2018-11-07 21:05:20 +0100
commit302e8af488b09d48b4dcf4e8d3a9a69b8e7f455f (patch)
tree86eca17f0930073950798d49e676dacc44f9d76a
parent8580711bf19c55bfbfa384c8d9b9e2183d46d89b (diff)
downloadaur-302e8af488b09d48b4dcf4e8d3a9a69b8e7f455f.tar.gz
5.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD35
2 files changed, 13 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbaab40b1326..aa8ef8f63505 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-paraview
pkgdesc = Parallel Visualization Application using VTK (mingw-w64)
- pkgver = 5.5.2
+ pkgver = 5.6.0
pkgrel = 1
url = http://www.paraview.org
arch = any
@@ -26,12 +26,14 @@ pkgbase = mingw-w64-paraview
depends = mingw-w64-lz4
depends = mingw-w64-cgns
depends = mingw-w64-netcdf-cxx-legacy
+ depends = mingw-w64-double-conversion
+ depends = mingw-w64-protobuf
options = !buildflags
options = !strip
options = staticlibs
- source = http://paraview.org/files/v5.5/ParaView-v5.5.2.tar.gz
+ source = http://paraview.org/files/v5.6/ParaView-v5.6.0.tar.gz
source = compile-tools.patch
- sha256sums = 64561f34c4402b88f3cb20a956842394dde5838efd7ebb301157a837114a0e2d
+ sha256sums = cb8c4d752ad9805c74b4a08f8ae6e83402c3f11e38b274dba171b99bb6ac2460
sha256sums = ea4211078f1e1d7d2bb999861d81fbcb0cc6176844fead431c473035e94bd4bb
pkgname = mingw-w64-paraview
diff --git a/PKGBUILD b/PKGBUILD
index 48564a4b1fd4..41937cb2bb40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
pkgname=mingw-w64-paraview
-_majordotminor=5.5
-pkgver=${_majordotminor}.2
+_majordotminor=5.6
+pkgver=${_majordotminor}.0
_pkgver=${pkgver}
pkgrel=1
pkgdesc='Parallel Visualization Application using VTK (mingw-w64)'
arch=('any')
url='http://www.paraview.org'
license=('custom')
-depends=('mingw-w64-qt5-xmlpatterns' 'mingw-w64-qt5-tools' 'mingw-w64-boost' 'mingw-w64-glew' 'mingw-w64-expat' 'mingw-w64-freetype2' 'mingw-w64-libjpeg' 'mingw-w64-libxml2' 'mingw-w64-libtheora' 'mingw-w64-libpng' 'mingw-w64-libtiff' 'mingw-w64-zlib' 'mingw-w64-jsoncpp' 'mingw-w64-pugixml' 'mingw-w64-hdf5' 'mingw-w64-lz4' 'mingw-w64-cgns' 'mingw-w64-netcdf-cxx-legacy')
+depends=('mingw-w64-qt5-xmlpatterns' 'mingw-w64-qt5-tools' 'mingw-w64-boost' 'mingw-w64-glew' 'mingw-w64-expat' 'mingw-w64-freetype2' 'mingw-w64-libjpeg' 'mingw-w64-libxml2' 'mingw-w64-libtheora' 'mingw-w64-libpng' 'mingw-w64-libtiff' 'mingw-w64-zlib' 'mingw-w64-jsoncpp' 'mingw-w64-pugixml' 'mingw-w64-hdf5' 'mingw-w64-lz4' 'mingw-w64-cgns' 'mingw-w64-netcdf-cxx-legacy' 'mingw-w64-double-conversion' 'mingw-w64-protobuf')
makedepends=('mingw-w64-cmake' 'mingw-w64-eigen' 'mingw-w64-wine')
options=('!buildflags' '!strip' 'staticlibs')
source=("http://paraview.org/files/v${_majordotminor}/ParaView-v${_pkgver}.tar.gz"
"compile-tools.patch")
-sha256sums=('64561f34c4402b88f3cb20a956842394dde5838efd7ebb301157a837114a0e2d'
+sha256sums=('cb8c4d752ad9805c74b4a08f8ae6e83402c3f11e38b274dba171b99bb6ac2460'
'ea4211078f1e1d7d2bb999861d81fbcb0cc6176844fead431c473035e94bd4bb')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -22,17 +22,6 @@ prepare() {
# cannot be modified upstream, see https://gitlab.kitware.com/paraview/paraview/merge_requests/1716
patch -p1 -i "${srcdir}/compile-tools.patch"
-
- # qt 5.11 support
- curl -L https://gitlab.kitware.com/paraview/paraview/merge_requests/2474.patch | patch -p1
-
- cd VTK
-
- # fix invalid conversion
- curl -L https://gitlab.kitware.com/vtk/vtk/merge_requests/4017.patch | patch -p1
-
- # fix jsoncpp module
- curl -L https://gitlab.kitware.com/vtk/vtk/merge_requests/4107.patch | patch -p1
}
build() {
@@ -40,24 +29,16 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
- -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON \
- -DPARAVIEW_ENABLE_FFMPEG:BOOL=OFF \
- -DPARAVIEW_ENABLE_PYTHON:BOOL=OFF \
- -DPARAVIEW_PYTHON_VERSION=2 \
+ -DCMAKE_RULE_MESSAGES=OFF \
+ -DPARAVIEW_INSTALL_DEVELOPMENT_FILES=ON \
+ -DPARAVIEW_ENABLE_PYTHON=OFF \
-DPARAVIEW_ENABLE_EMBEDDED_DOCUMENTATION=OFF \
- -DPARAVIEW_QT_VERSION=5 \
- -DPARAVIEW_USE_VISITBRIDGE:BOOL=OFF \
- -DPARAVIEW_USE_OSPRAY:BOOL=OFF \
+ -DPARAVIEW_USE_VTKM=OFF \
-DVTK_USE_SYSTEM_LIBRARIES=ON \
-DVTK_USE_SYSTEM_QTTESTING=OFF \
-DVTK_USE_SYSTEM_XDMF2=OFF \
- -DVTK_USE_SYSTEM_PROTOBUF:BOOL=OFF \
-DVTK_USE_SYSTEM_GL2PS=OFF \
-DVTK_USE_SYSTEM_LIBHARU=OFF \
- -DVTK_PYTHON_VERSION=2 \
- -DVTK_QT_VERSION=5 \
- -DVTK_RENDERING_BACKEND:STRING=OpenGL2 \
- -DVTK_SMP_IMPLEMENTATION_TYPE:STRING=OpenMP \
-DHDF5_ROOT=/usr/${_arch}/ ..
make
popd