summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-03-02 19:55:29 +0100
committerMichel Zou2017-03-02 19:55:29 +0100
commit4958b990d4719b747f503d37cffdf2d6568591a3 (patch)
treedefd39a0c5bd4c8d0b25f4e708e3736562b8d662
downloadaur-4958b990d4719b747f503d37cffdf2d6568591a3.tar.gz
5.2.0
-rw-r--r--.SRCINFO40
-rw-r--r--332e61a.patch25
-rw-r--r--6541e9c.patch64
-rw-r--r--PKGBUILD97
-rw-r--r--vtk_hdf5_internal.patch39
5 files changed, 265 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..173ece5df83f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+# Generated by mksrcinfo v8
+# Thu Mar 2 18:55:29 UTC 2017
+pkgbase = mingw-w64-paraview
+ pkgdesc = Parallel Visualization Application using VTK (mingw-w64)
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = http://www.paraview.org
+ arch = any
+ license = custom
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-qt5-xmlpatterns
+ depends = mingw-w64-qt5-tools
+ depends = mingw-w64-boost
+ depends = mingw-w64-glew
+ depends = mingw-w64-expat
+ depends = mingw-w64-freetype2
+ depends = mingw-w64-libjpeg
+ depends = mingw-w64-libxml2
+ depends = mingw-w64-libtheora
+ depends = mingw-w64-libpng
+ depends = mingw-w64-libtiff
+ depends = mingw-w64-zlib
+ depends = mingw-w64-jsoncpp
+ depends = mingw-w64-pugixml
+ depends = mingw-w64-hdf5
+ depends = mingw-w64-lz4
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = http://paraview.org/files/v5.2.0/ParaView-v5.2.0.tar.gz
+ source = vtk_hdf5_internal.patch
+ source = 332e61a.patch
+ source = 6541e9c.patch
+ sha1sums = c578cdad44673cd3311bd5c5fec52075ea923701
+ sha1sums = cbadaa87cd775d1edb1dbc1db4dedb9f3cdc4fd5
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = mingw-w64-paraview
+
diff --git a/332e61a.patch b/332e61a.patch
new file mode 100644
index 000000000000..6f8207c539b4
--- /dev/null
+++ b/332e61a.patch
@@ -0,0 +1,25 @@
+From 332e61a1df65e58c2b2991aebc2ad52799a67936 Mon Sep 17 00:00:00 2001
+From: xantares <xantares09@hotmail.com>
+Date: Wed, 1 Mar 2017 10:06:30 -0500
+Subject: [PATCH] Do not use extern templates for mingw as suggested in https://gitlab.kitware.com/vtk/vtk/issues/16916
+
+---
+ Common/Core/vtkConfigure.h.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Common/Core/vtkConfigure.h.in b/Common/Core/vtkConfigure.h.in
+index dad3005..c2f58e0 100644
+--- a/Common/Core/vtkConfigure.h.in
++++ b/Common/Core/vtkConfigure.h.in
+@@ -169,7 +169,7 @@
+
+ /** extern template declarations for C++11
+ */
+-#if __cplusplus >= 201103L || (defined(_MSC_VER) && _MSC_VER >= 1700)
++#if ((__cplusplus >= 201103L) || (defined(_MSC_VER) && _MSC_VER >= 1700)) && !defined(__MINGW32__)
+ #define VTK_USE_EXTERN_TEMPLATE
+ #endif
+
+--
+libgit2 0.24.0
+
diff --git a/6541e9c.patch b/6541e9c.patch
new file mode 100644
index 000000000000..40637b16ab0c
--- /dev/null
+++ b/6541e9c.patch
@@ -0,0 +1,64 @@
+From 6541e9c7662d3987baded0ea90de80937fa23d7a Mon Sep 17 00:00:00 2001
+From: Steven Hahn <hahnse@ornl.gov>
+Date: Tue, 14 Feb 2017 13:30:12 -0500
+Subject: [PATCH] Fix compilation errors when building with HDF5 1.10.0
+
+---
+ ThirdParty/netcdf/vtknetcdf/libsrc4/nc4internal.h | 2 +-
+ ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx | 12 +++++++++++-
+ 2 files changed, 12 insertions(+), 2 deletions(-)
+
+diff --git a/ThirdParty/netcdf/vtknetcdf/libsrc4/nc4internal.h b/ThirdParty/netcdf/vtknetcdf/libsrc4/nc4internal.h
+index 628d0c9..e023f38 100644
+--- a/ThirdParty/netcdf/vtknetcdf/libsrc4/nc4internal.h
++++ b/ThirdParty/netcdf/vtknetcdf/libsrc4/nc4internal.h
+@@ -367,7 +367,7 @@ NC_FILE_INFO_T *nc4_find_nc_file(int ncid);
+ int nc4_find_dim(NC_GRP_INFO_T *grp, int dimid, NC_DIM_INFO_T **dim, NC_GRP_INFO_T **dim_grp);
+ int nc4_find_dim_len(NC_GRP_INFO_T *grp, int dimid, size_t **len);
+ int nc4_find_type(NC_HDF5_FILE_INFO_T *h5, int typeid, NC_TYPE_INFO_T **type);
+-NC_TYPE_INFO_T *nc4_rec_find_nc_type(NC_GRP_INFO_T *start_grp, hid_t target_nc_typeid);
++NC_TYPE_INFO_T *nc4_rec_find_nc_type(NC_GRP_INFO_T *start_grp, nc_type target_nc_typeid);
+ NC_TYPE_INFO_T *nc4_rec_find_hdf_type(NC_GRP_INFO_T *start_grp, hid_t target_hdf_typeid);
+ NC_TYPE_INFO_T *nc4_rec_find_named_type(NC_GRP_INFO_T *start_grp, char *name);
+ NC_TYPE_INFO_T *nc4_rec_find_equal_type(NC_GRP_INFO_T *start_grp, int ncid1, NC_TYPE_INFO_T *type);
+diff --git a/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx b/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx
+index 48a7753..5db2620 100644
+--- a/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx
++++ b/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx
+@@ -139,7 +139,11 @@ static int H5FD_dsm_cmp(const H5FD_t *_f1, const H5FD_t *_f2);
+ #if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8))
+ static haddr_t H5FD_dsm_get_eoa(const H5FD_t *_file, H5FD_mem_t type);
+ static herr_t H5FD_dsm_set_eoa(H5FD_t *_file, H5FD_mem_t type, haddr_t addr);
++#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=10))
++static haddr_t H5FD_dsm_get_eof(const H5FD_t *_file, H5FD_mem_t type);
++#else
+ static haddr_t H5FD_dsm_get_eof(const H5FD_t *_file);
++#endif
+ #else
+ static haddr_t H5FD_dsm_get_eoa(H5FD_t *_file);
+ static herr_t H5FD_dsm_set_eoa(H5FD_t *_file, haddr_t addr);
+@@ -155,6 +159,9 @@ static const H5FD_class_t H5FD_dsm_g = {
+ "dsm", /*name */
+ MAXADDR, /*maxaddr */
+ H5F_CLOSE_WEAK, /*fc_degree */
++#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=10))
++ NULL, /*terminate */
++#endif
+ NULL, /*sb_size */
+ NULL, /*sb_encode */
+ NULL, /*sb_decode */
+@@ -687,7 +694,10 @@ H5FD_dsm_set_eoa(H5FD_t *_file, haddr_t addr)
+ *-------------------------------------------------------------------------
+ */
+ static haddr_t
+-#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8))
++
++#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=10))
++H5FD_dsm_get_eof(const H5FD_t *_file, H5FD_mem_t type)
++#elif ((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8))
+ H5FD_dsm_get_eof(const H5FD_t *_file)
+ #else
+ H5FD_dsm_get_eof(H5FD_t *_file)
+--
+libgit2 0.24.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cbdbd938943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+pkgname=mingw-w64-paraview
+_majordotminor=5.2
+pkgver=${_majordotminor}.0
+pkgrel=1
+pkgdesc='Parallel Visualization Application using VTK (mingw-w64)'
+arch=('any')
+url='http://www.paraview.org'
+license=('custom')
+depends=('mingw-w64-qt5-xmlpatterns' 'mingw-w64-qt5-tools' 'mingw-w64-boost' 'mingw-w64-glew' 'mingw-w64-expat' 'mingw-w64-freetype2' 'mingw-w64-libjpeg' 'mingw-w64-libxml2' 'mingw-w64-libtheora' 'mingw-w64-libpng' 'mingw-w64-libtiff' 'mingw-w64-zlib' 'mingw-w64-jsoncpp' 'mingw-w64-pugixml' 'mingw-w64-hdf5' 'mingw-w64-lz4')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("http://paraview.org/files/v${pkgver}/ParaView-v${pkgver}.tar.gz"
+ 'vtk_hdf5_internal.patch' 332e61a.patch 6541e9c.patch)
+sha1sums=('c578cdad44673cd3311bd5c5fec52075ea923701'
+ 'cbadaa87cd775d1edb1dbc1db4dedb9f3cdc4fd5' SKIP SKIP)
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/ParaView-v${pkgver}"
+
+ patch -p1 -i ../vtk_hdf5_internal.patch
+
+ # disable all plugins ~ -DPARAVIEW_BUILD_PLUGIN_XXX
+ sed -i "s|if (PARAVIEW_BUILD_PLUGIN|if(OFF|g" CMake/ParaViewPluginsMacros.cmake
+
+ pushd VTK && patch -p1 -i "${srcdir}"/332e61a.patch && popd
+ pushd VTK && patch -p1 -i "${srcdir}"/6541e9c.patch && popd
+
+ # https://gitlab.kitware.com/paraview/paraview/merge_requests/1434
+ sed -i "s|#include <Windows.h>|#include <windows.h>|g" ParaViewCore/ServerManager/SMApplication/vtkInitializationHelper.cxx
+
+ # https://gitlab.kitware.com/paraview/paraview/merge_requests/1436
+ echo "target_link_libraries(paraview LINK_PRIVATE msvcr90)" >> Applications/ParaView/CMakeLists.txt
+}
+
+build() {
+ cd "${srcdir}/ParaView-v${pkgver}"
+ # native build
+ mkdir -p build-native && pushd build-native
+ cmake ..
+ make vtkEncodeString vtkHashSource vtkWrapClientServer protoc_compiler kwProcessXML
+ popd
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake \
+ -DCOMPILE_TOOLS_IMPORTED=OFF \
+ -DParaViewCompileTools_DIR=$PWD/../build-native \
+ -DBUILD_TESTING:BOOL=OFF \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF \
+ -DOSPRAY_INSTALL_DIR:PATH=/usr \
+ -DPARAVIEW_ENABLE_CGNS:BOOL=OFF \
+ -DPARAVIEW_ENABLE_FFMPEG:BOOL=OFF \
+ -DPARAVIEW_ENABLE_PYTHON:BOOL=OFF \
+ -DPARAVIEW_PYTHON_VERSION=2 \
+ -DPARAVIEW_QT_VERSION=5 \
+ -DPARAVIEW_USE_MPI:BOOL=OFF \
+ -DPARAVIEW_USE_VISITBRIDGE:BOOL=OFF \
+ -DPARAVIEW_USE_OSPRAY:BOOL=OFF \
+ -DVTK_USE_SYSTEM_LIBRARIES=ON \
+ -DVTK_USE_SYSTEM_QTTESTING=OFF \
+ -DVTK_USE_SYSTEM_NETCDF=OFF \
+ -DVTK_USE_SYSTEM_XDMF2=OFF \
+ -DVTK_USE_SYSTEM_PROTOBUF:BOOL=OFF \
+ -DVTK_USE_SYSTEM_GL2PS=OFF \
+ -DVISIT_BUILD_READER_CGNS:BOOL=OFF \
+ -DVTK_PYTHON_VERSION=2 \
+ -DVTK_QT_VERSION=5 \
+ -DVTK_RENDERING_BACKEND:STRING=OpenGL2 \
+ -DVTK_SMP_IMPLEMENTATION_TYPE:STRING=OpenMP \
+ -DPARAVIEW_BUILD_PLUGIN_AcceleratedAlgorithms=OFF \
+ -DPARAVIEW_BUILD_PLUGIN_AnalyzeNIfTIIO=OFF \
+ ..
+
+ # fix some generation rules
+ find . -name build.make | xargs sed -i "s|bin/rcc Qt5::rcc|bin/rcc|g"
+ find . -name build.make | xargs sed -i "s|bin/moc Qt5::moc|bin/moc|g"
+ find . -name build.make | xargs sed -i "s|bin/vtkEncodeString-pv${_majordotminor} vtkEncodeString|bin/vtkEncodeString-pv${_majordotminor}|g"
+ find . -name build.make | xargs sed -i "s|bin/vtkHashSource-pv${_majordotminor} vtkHashSource|bin/vtkHashSource-pv${_majordotminor}|g"
+ find . -name build.make | xargs sed -i "s|bin/protoc protoc_compiler|bin/protoc|g"
+ find . -name build.make | xargs sed -i "s|bin/vtkkwProcessXML-pv${_majordotminor} kwProcessXML|bin/vtkkwProcessXML-pv${_majordotminor}|g"
+ find . -name build.make | xargs sed -i "s|bin/vtkWrapClientServer-pv${_majordotminor} vtkWrapClientServer|bin/vtkWrapClientServer-pv${_majordotminor}|g"
+
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/ParaView-v${pkgver}/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+# ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
diff --git a/vtk_hdf5_internal.patch b/vtk_hdf5_internal.patch
new file mode 100644
index 000000000000..839881f6b811
--- /dev/null
+++ b/vtk_hdf5_internal.patch
@@ -0,0 +1,39 @@
+diff -Naur ParaView-v5.1.2_org/VTK/ThirdParty/hdf5/vtkhdf5/CMakeInstallation.cmake ParaView-v5.1.2/VTK/ThirdParty/hdf5/vtkhdf5/CMakeInstallation.cmake
+--- ParaView-v5.1.2_org/VTK/ThirdParty/hdf5/vtkhdf5/CMakeInstallation.cmake 2016-07-26 21:52:16.000000000 +0200
++++ ParaView-v5.1.2/VTK/ThirdParty/hdf5/vtkhdf5/CMakeInstallation.cmake 2016-10-13 17:01:06.326836570 +0200
+@@ -58,7 +58,7 @@
+ )
+ install (
+ FILES ${HDF5_BINARY_DIR}/CMakeFiles/FindHDF5${HDF_PACKAGE_EXT}.cmake
+- DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}
++ DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}_paraview
+ COMPONENT configinstall
+ )
+ endif (NOT HDF5_EXTERNALLY_CONFIGURED)
+@@ -73,7 +73,7 @@
+ )
+ install (
+ FILES ${HDF5_BINARY_DIR}/CMakeFiles/${HDF5_PACKAGE}${HDF_PACKAGE_EXT}-config.cmake
+- DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}
++ DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}_paraview
+ COMPONENT configinstall
+ )
+ endif (NOT HDF5_EXTERNALLY_CONFIGURED)
+@@ -88,7 +88,7 @@
+ )
+ install (
+ FILES ${HDF5_BINARY_DIR}/CMakeFiles/${HDF5_PACKAGE}${HDF_PACKAGE_EXT}-config-version.cmake
+- DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}
++ DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}_paraview
+ COMPONENT configinstall
+ )
+ endif (NOT HDF5_EXTERNALLY_CONFIGURED)
+@@ -107,7 +107,7 @@
+ )
+ install (
+ FILES ${HDF5_BINARY_DIR}/libhdf5.settings
+- DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}
++ DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}_paraview
+ COMPONENT libraries
+ )
+