summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-06-28 18:12:57 +0200
committerMichel Zou2021-06-28 18:12:57 +0200
commit797d4b7168d71dd05f4c2c05c58b18b2f3a4d7c0 (patch)
tree1c0fb457e56f3629a05fdd891df3b869ab0e3181
parenteb6ad3cd6ab55daa49b45f25e71d3ae4c5482d23 (diff)
downloadaur-797d4b7168d71dd05f4c2c05c58b18b2f3a4d7c0.tar.gz
GL7611
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 5 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2d2fbb698aa..d222f54b0b5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,11 +34,6 @@ pkgbase = mingw-w64-paraview
options = !strip
options = staticlibs
source = https://www.paraview.org/files/v5.9/ParaView-v5.9.1.tar.xz
- source = https://gitlab.kitware.com/vtk/vtk/-/merge_requests/7038.patch
- source = https://gitlab.kitware.com/paraview/catalyst/-/merge_requests/7.patch
sha256sums = 0d486cb6fbf55e428845c9650486f87466efcb3155e40489182a7ea85dfd4c8d
- sha256sums = SKIP
- sha256sums = SKIP
pkgname = mingw-w64-paraview
-
diff --git a/PKGBUILD b/PKGBUILD
index 3f86d183e584..0de02dc62641 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,19 +8,16 @@ license=('custom')
depends=('mingw-w64-qt5-xmlpatterns' 'mingw-w64-qt5-tools' 'mingw-w64-qt5-svg' 'mingw-w64-boost' 'mingw-w64-glew' 'mingw-w64-freetype2' 'mingw-w64-libxml2' 'mingw-w64-libtiff' 'mingw-w64-jsoncpp' 'mingw-w64-hdf5' 'mingw-w64-lz4' 'mingw-w64-proj' 'mingw-w64-cgns' 'mingw-w64-netcdf' 'mingw-w64-double-conversion' 'mingw-w64-protobuf' 'mingw-w64-libtheora' 'mingw-w64-pugixml' 'mingw-w64-gl2ps')
makedepends=('mingw-w64-cmake' 'mingw-w64-eigen' 'mingw-w64-utf8cpp' 'mingw-w64-wine' 'mingw-w64-wine-qt' 'protobuf')
options=('!buildflags' '!strip' 'staticlibs')
-source=("${url}/files/v${pkgver:0:3}/ParaView-v${pkgver}.tar.xz"
- https://gitlab.kitware.com/vtk/vtk/-/merge_requests/7038.patch
- https://gitlab.kitware.com/paraview/catalyst/-/merge_requests/7.patch)
-sha256sums=('0d486cb6fbf55e428845c9650486f87466efcb3155e40489182a7ea85dfd4c8d' SKIP SKIP)
+source=("${url}/files/v${pkgver:0:3}/ParaView-v${pkgver}.tar.xz")
+sha256sums=('0d486cb6fbf55e428845c9650486f87466efcb3155e40489182a7ea85dfd4c8d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/ParaView-v${pkgver}"
- cd VTK
- patch -p1 -i "${srcdir}"/7038.patch
- cd ../ThirdParty/catalyst/vtkcatalyst/catalyst
- patch -p1 -i "${srcdir}"/7.patch
+ curl -L https://gitlab.kitware.com/vtk/vtk/-/merge_requests/7038.patch | patch -p1 -d VTK
+ curl -L https://gitlab.kitware.com/vtk/vtk/-/merge_requests/7611.patch | patch -p1 -d VTK
+ curl -L https://gitlab.kitware.com/paraview/catalyst/-/merge_requests/7.patch | patch -p1 -d ThirdParty/catalyst/vtkcatalyst/catalyst
}
build() {